Jump to content
RESET Forums (homeservershow.com)

RocketRaid 2640x4 broken or incompatible


DarkUltra
 Share

Recommended Posts

LSI MEGARAID SAS 9211-4ILSI MEGARAID SAS 9211-4I LSI MEGARAID SAS 9211-4I Hi!

 

I bought a used Highpoint RocketRAID 2640x4 and a Seagate Cheetah 600GB ST3600057SS SAS hard drive and I have two issues.

 

1. Slow post. It takes 30 seconds to post its bios, and scanning drives, even if the drives already are spun up (reboot). I believe this is normal, but are there SAS controllers that initializes faster?

 

2. Slow file transfer rate with a Seagate Cheetah 15.7k, WD Scorpio and a WD Raptor 150GB. During the first few seconds it is fast, 80-100MB/s but later it slows down to 10MB/s and stays there. HD TAch and HD Tune sometimes shows proper read rate, sometimes slow rate. Random access time benchmarks always at ca 5.6ms.

 

I have flashed the rocketraid 2640x4 to firmware 1.4 and are using the 1.6-12.524 drivers from highpoints web page. I've also tried it in a different computer and there it too is initially fast but slows to 16MB/s transfer rates on non-fragmented files. Can this be incompatibilites between the motherboard, raid card or hdd, or is it the raid card that is broken? Neither my motherboard or my HDDs are in the compatibility pdf.

 

Would I have better luck with an LSI 9211-4I and a mSAS to SASx4 cable?

 

Thank you

 

 

specs:

Windows 7 64bit and Windows 8 64bit (msdn subscription)

core i7 3930k

asus p9x79 deluxe

auzentech x-fi hometheater hd

16gb ram

rocketraid 2640x4

seagate cheetah 600gb sas ST3600057SS

wd velociraptor 600gb

 

RocketRAID_2640x4_Seagate_Cheetah_slow_file_transfer.png

Link to comment
Share on other sites

Couple questions:

1) How do you know it isn't the drive? Sounds to me like with the benchmark and the intermittent speeds that depending on where the drive is accessing is causing slow downs. That said, SAS drives are of course more robust than most SATA pure (home use) drives.

 

2) Does it matter how long the card has been used?

 

3) Unlikely that it is an incompatibility issue even if you hadn't tried it in another system with the same results.

 

4) Do you have any SFF-8087 cables (mSAS to SATA)? You could test the card out with a standard SATA drive then.

 

In regards to the slow boot times, 30 seconds is a bit long for the card's BIOS to acquire one drive. Again, sounds like a fault there. If you really want to bypass the check altogether, you can enable your onboard RAID - don't have to use the drives in RAID, just enable it in BIOS - but that might require at minimum an update to your OS and potentially a re-install. The end result is there can be only one RAID initiated upon boot, so the onboard will quickly run and stop and the HighPoint card's BIOS will just flash a notice saying there has already been a RAID initiated.

 

Bottom line: It's a toss-up as to card vs hard drive, but the cards tend to fail less often than the drives, even SAS drives.

Link to comment
Share on other sites

Hmmm, we actually didn't find much difference in longevity between SATA and SAS drives. We stopped buying SAS drives for nearline storage because of it; we just could not justify the extra cost for non-primary storage. We kept SAS for primary, not because of robustness, because of the higher rotational speeds and, therefor, faster data access.

Link to comment
Share on other sites

The slow post is definitely not normal in anything i ever ran. The big variable is two card in a system trying to fight for the same space. I agree with TimeKills and that it indicates an issue. Trying new cables would also be a great suggestion. It would certainly be easier to try a different card if you can "borrow" one from a retailer that has a return policy or if you know someone with a different card. Because of the speed of the drive, the card could be misreading the drive.

Link to comment
Share on other sites

@timekills

1. I have tried two sata drives in addition to the seagate sas and a different computer, and the issue persists. I don't think it is where the drive is written to. I can move files for a while until it slows down, then wait for maybe 15 minutes and move some more and it slows down after the same amount of time. Something seems to bottle up after a while.

 

2. No it happens whenever I wanto. Just wait for things to cool down and it all happens over again; initially the transfer speed is fast, then slows down.

 

3. Yes, and two others sata drives

 

4. this card have four of those black plastic sata/sas ports so I use a sata to sas cable for the seagate sas drive and regular sata cables for the two sata drives.

 

Good idea I'll try that to reduce boot time. Yes I think its the card I bought it used on ebay

Link to comment
Share on other sites

Could be you got a dud. The symptoms are odd though - they remind me of heat related issues.

 

Is it possible the LSI is getting overheated? Like most LSI RAID cards, I presume this one has an onboard CPU. If so, it may be overheating and automatically stepping down to prevent burnout. Perhaps you could try opening the side of the case and directing a desktop fan (or something of the sort) directly at the LSI card. If you have a can of Freeze-It, that could work too - just spray some on every minute of so.

 

It would be interesting to see how long the data transfer continues at high speed with extra cooling vs regular.

Link to comment
Share on other sites

Ok I'll check later tonight. Uhm it is not an LSI card, it is the highpoint rocketraid 2640x4. I somehow included LSI MEGARAID SAS 9211-4ILSI in the top of the post during cut-and paste and I can't edit the first post it seems.

 

I might buy an LSI 9211-4I instead depending on the answer from my ebay seller.

Link to comment
Share on other sites

Ah. Gotchya. AFAIK, the 2640 does not have an onboard CPU (I'm not sure any of the RR cards have CPUs) but it might still be worth trying to cool the card and see what effect it has.

Link to comment
Share on other sites

I did! The RR 2640x4 main chip got 69-70c, buth when HDDs were idle and under load. I stuck some leftover thermal sticky tape and small heatsinks to it, and directed a fan towards it but no difference. I believe 70c is indeed within spec.

 

I did some further testing an LSI SAS 9211-4I and it seems the Seagate Cheetah is incompatible with both. I get good performance on the RR 2640x4 and a WD VelociRaptor.

 

Does anyone have a Cheetah 15K.7 600GB ST3600057SS and if so, what controller do you use?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...