Jump to content
RESET Forums (homeservershow.com)

Microserver poor copy performance


geeba
 Share

Recommended Posts

Hello all!

 

My first post so I hope I have the correct location :)

 

I was wondering if anyone can help me out with my HP Microservers.... I'm at my witts end...

 

This is what I have:-

 

1 x N36L running WHS 2011 - file copy to the server over Gig LAN less than 150Kbps copy from the server 9Mbps

1 x N40L running Server 2012 Beta - file copy to the server on same gig LAN roughly 80kbps... copy from... 15Mbps

 

Two microservers, two different OS's, all at a Gig on the same flat LAN, copying to the servers is just not possible... I have to copy everything to USB drive and move it that way....

 

My games rig, laptops (multiple) XP, Vista, Win7, XBMC Zotac, XBMC XBOX, and Android devices... completely unaffected all on the same network, I have no speed issues at all...

 

I've tried different switches, new cables, new drivers. new NIC firmware..

 

A 2 gig file will take literally hours to copy over usually 2 to 3hrs... yet I can copy the same file to my game rig in seconds...

 

I'm getting close to a Microserver bonfire! :(

Link to comment
Share on other sites

  • Replies 26
  • Created
  • Last Reply

Top Posters In This Topic

  • jmwills

    7

  • ikon

    4

  • Joe_Miner

    3

  • geeba

    7

Top Posters In This Topic

Welcome geeba!

 

I know that Joe_Miner will chime in, but what kind of network layout do you have? I am more interested in knowing if you have dedicated switches or using the one from a router and how many interrupt positions are between the two boxes.. Dedicated would be better and what are you using to copy?

Link to comment
Share on other sites

Hi jmwills! Really appreciate your help!

 

I do have Netgear gigabit switches, all cable is Cat5e And the servers are both connected to the same one, as is my games rig, then one cable runs down to the ground floor and connects to the DSL router which does the wireless for my laptops etc... so files between the servers and the games rig should be switching at MAC level, wire speed.

 

I'm just using windows file sharing SMB, and the usual drag and drop 'move here' with the right click... I did try TerraCopy as well but it makes no odds :-(

Link to comment
Share on other sites

I would check the advanced setting for the network adapter on the servers and compare them to a machine that you're having no trouble with. Perhaps flow control, checksum or something similar is causing a bottleneck at the server NIC. And perhaps that's why it's happening on the server OS's and not the client (defaults might be different on server OS's)

Link to comment
Share on other sites

Firstly, welcome to the forums. Hope you stick around.

 

Those speeds, both ways, are really slow.

 

Have you tried connecting client computers directly to the servers, as a test? It seems to me that, at this point, you need to get right down to basics.

Link to comment
Share on other sites

Welcome to the Forums Geeba!

 

Obviously, you shouldn’t be having these problems, I’ve had S2008R2, Server 8, Server 2012 RC all running at one time or another as the host OS on my Microserver and am currently running WHS-2011 on it with no problems on transfer speeds.

 

Tell us about your systems.

 

MicroServers: OS drive (what port is it plugged in), other drives, RAM, BIOS (factory or modified BIOS), did you modify anything in the BIOS

 

Network: what is the layout? How have you already tested it?

 

What is your test copy case – from which client to which server. Have you replaced the Server with another client (unplug the cable from the server NIC and plug it into another client) and run your test copy case with that exact same setup except for the physical switch from the Server to another client? Have you tried ikon’s suggestions? (When your testing try to only change one thing at a time.) Have you tried “Lan Speed Test” on/between machines on your network?

 

Here is my performance last March from a Hyper-V client using “Lan Speed Test” http://homeservershow.com/forums/index.php?/topic/3656-network-performance-microserver-to-ex-487/

 

2012-03-03NetworkSpeedTestfromHALtoSkyNET.jpg

 

I posted a more recent test in this thread that may also have some good info about your situations: http://homeservershow.com/forums/index.php?/topic/4258-slow-transfer-speeds-after-converting-to-whs-2011/

 

gallery_1229_27_6936.jpg

 

The first test above was over CAT 6 cable that went thru a D-Link DGS-2208 switch while the 2nd test above was over CAT 6 cable that went thru a D-Link DGS-2208 and a D-Link DGS-2205 switches (plus a wall CAT 6 connector)

Link to comment
Share on other sites

Geessss swamped with info!!! Fantastic! thanks fellas!

 

Well I think I've found the issue! I did the back to back with a cross cable as ikon recommended, my laptop only has 10/100 for wired connection as I messed the drivers up, but bang! straight in at 11 - 12Mbps which is about right for 100Mb LAN.

 

A quick swap back to the Gigabit Switch and the speed slowly drops off... it got down to 2.3mbps and I swaped back to the x-cable and the speed instantly ramped up!

 

Odd thing is.... this doesn't happen with my games rig which has an EVGA nVidia mainboard.... So I can only think that there is an incompatibility between between the Netgear and the Broadcom NIC in the server!? :wacko:

 

I'm just browsing eBuyer now for a new switch!

 

More testing here I feel!

 

Great site thou! having a good read on the 2012 stuff.... still not made my mind up on that as a WHS replacement... I loved WHS V1.... WHS 2011 is ok... an unwanted necessary for larger drives... but Metro! geessss what were you thinking Microsoft!?!?! it clearly SUX hugely! why would I want it on a server!

 

Thanks again guys!

Edited by geeba
Link to comment
Share on other sites

Great news! Sounds like you've zeroing in on a problem.

 

Lots of testing is a good thing -- gives you a chance to stress a piece of equipment and learn how it works.

Link to comment
Share on other sites

Please do not start a MicroServer fire, there are other ways to vent frustration. You're in the right place for sure! Welcome to the forums. (hide your wallet)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...