Jump to content
RESET Forums (homeservershow.com)
KiwiGlen

Have to enter a Userid/Password to access shares

Recommended Posts

KiwiGlen

Pretty sure this is a dumb question but I just can get it going so I thought I'd ask.

 

The problem I'm having is that when a user tries to access to server its rejected and a dialogue box appears asking for the user id and password. Now I thought that if the user id and password for the user on the PC matched the userid and password on the server it would use it and allow access? Is that right or do I need to enter these again?

 

I was using homegroup on the server but decided to turn it off. With homegroup I didn't need to enter the user id and password, I could just access the shares. But all users had the same access, which I now don't want.

 

I'm sure before I used homegroup that I didn't need to enter the userid and password to access the server.

 

Any ideas?

 

Glen

Share this post


Link to post
Share on other sites
jmwills

First of all, do not use the Homegroup option. It causes more issues than it solves, however if you wish to continue to use it make note of this.

 

Your problem seems to be rooted in the fact that all users are part of the same Group that has full access granted by permissions. There are several ways around this. You can create your own Groups and assign permissions that way or simply adjust permission levels on the exisiting groups.

 

One thing to remember is that Windows grants access based on the principle of "least privilege". Say a user was a member of two groups that both had access to the same folder. One Group gave them full access while another only gave them Read access". The effective granted permission level would be Read Only.

 

Review your Users and Groups and then look at the Shares to see what level of permissions have beeen given to each. Windows is very flexible, yet very secure with sharing. You can create your own Groups or stick with what is provided.

 

Hope this helps.

Share this post


Link to post
Share on other sites
gcoupe

On your client PC that needs to access a shared folder on WHS, you need to add a Windows Credential that references a user account/password that has been set up on the WHS.

 

On the client PC, go to Control Panel/User accounts/Manage Windows Credentials and create a Windows Credential that references a user account/password on the WHS.

Share this post


Link to post
Share on other sites
ikon

On your client PC that needs to access a shared folder on WHS, you need to add a Windows Credential that references a user account/password that has been set up on the WHS.

 

On the client PC, go to Control Panel/User accounts/Manage Windows Credentials and create a Windows Credential that references a user account/password on the WHS.

 

Does this work for XP clients?

Share this post


Link to post
Share on other sites
gcoupe

Does this work for XP clients?

I have no idea. I haven't used Windows XP for years.

Share this post


Link to post
Share on other sites
jmwills

Use this:

 

nameofserver\username

 

password

Share this post


Link to post
Share on other sites
awraynor

I just rebuilt my Win7 Ultimate machine which finally enabled a complete install of the connector. Too bad

the last build wasn't backed up as an unfortunate choice in Acronis hosed my data drive. I went ahead

and rebuilt my server too while I was at it.

 

This time around I have tried HomeGroup and it seems to work okay. I still have some issues accessing

files and folders, but much better than before. Even my hackintosh connects to the WHS without a problem.

Share this post


Link to post
Share on other sites
ikon

Use this:

 

nameofserver\username

 

password

 

This is the technique I'm used to. Also, if you get the dreaded "there is already a link to this share" message (or whatever it is exactly) try IPaddress\userID.

Share this post


Link to post
Share on other sites
KiwiGlen

OK I tried doing that but now when I try and RDP into the server it fails saying that the connection was denied because the user account is not authorised for remote logon.

 

So how do I get both to work?

Share this post


Link to post
Share on other sites
ikon

Are you logging in as Administrator?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...