Jump to content
RESET Forums (homeservershow.com)

Raid 5 on RR2680 goes crazy!


tmpspiff
 Share

Recommended Posts

Hi

 

I just wanted to hear if anyone here had some good advice, or maybe encountered a similar situation.

 

I have a Highpoint Rocket Raid 2680 with a RAID 5 array consisting of 5 x 1TB samsung sata drives. It's been running well for a little over a year now, but suddenly windows froze and the alarm went off.

 

I tried manually rebooting, and the alarm shut down until during windows load screen when it went on again, and the machine froze. During Bios boot nothing indicated a degraded array...

So i booted into safe mode with networking, where i got into windows (with the alarm back on again) but could not load the Raid manager. It failed to initialize the Raid card?!The RAID drive was missing from windows and device manager.

I rebooted to Bios, where the array now came up as degraded, with 1 out of 5 drives degraded, the other 4 where fine.

 

Now to my knowledge a Raid 5 array should still be functional (though slow) with one drive missing or broken. Two degraded drives would render it totally broken, right?

 

Okay, now the scary stuff starts to happen!

 

I boot normally into windows again, the alarm goes on during load, but i get all the way into the system. The drive is still missing from windows, and when i load the Raid Manager, it tells me that my raid array is broken, and do i want to delete it?!

I click NO!

The overview says 1 degraded drive, and 2 missing! That can't be true. Bios said on drive degraded 4 was fine, and everything was working a minute ago?!?! It's highly unlikely that you loose three hard drives at once, unless you drop your system on the floor or lightning strike! Neither has happened to me.

I hit refresh, and the three drives with issues disappear from the overview, and the alarm stop ...

I try to hit the refresh again, but nothing happens.

 

Well, I kind of panic (since i don't have a backup of that drive) and shut down the machine. I boot it back into Bios where it says four working drives and one degraded in the array.

 

Now I don't dare to try and load into windows again. I'm going out and buying a new harddisk tomorrow and install it as a Hot-Spare, and hopefully the card will rebuild the array automatically.

 

Does anyone have some good advice, or have experienced something like this?

I'd appreciate the help!

 

Regards

Thomas Pape

Link to comment
Share on other sites

It may be exactly as the BIOS says. It could also be a hardware failure of some kind that isn't the hard drives. One thing you can do is transfer the whole array, RocketRaid card and drives, to another system and see if the boot process changes in any way. If it's more consistent,it could be that there is something wrong with the base system. Just make sure to label the cables and drives so you get them in the correct order.

Link to comment
Share on other sites

Are you booting from the array? Or are you booting from a single OS drive with the array used for data?

If you're booting from the array (OS is on the array) then you can't move it to another system without causing all kinds of OS blunders.

Link to comment
Share on other sites

Might want to try removing any USB attached devices (I know,it sounds crazy but they sometime cause a voltage issue). If that doesn't work, try moving the RAID card to a different slot on your motherboard. Also, confirm nothing changed on your mobo BIOS settings, especially relating to onboard RAID.

Link to comment
Share on other sites

Are you booting from the array? Or are you booting from a single OS drive with the array used for data?

If you're booting from the array (OS is on the array) then you can't move it to another system without causing all kinds of OS blunders.

 

It's a good question. I was assuming that it's a separate drive because he was able to get into Windows in Safe Mode, but maybe not.

Link to comment
Share on other sites

The OS (windows 7 x64) is running on a separate Raid array (raid 0) on the same controller.

 

Here's a quick update, unfortunately nothing good.

 

I bought a new hard disk, initialized it and assigned it to the hot spare pool via Bios. During windows load the alarm went off again, and inside windows I could open up the Management console and see that there is still two drives missing and the new hard disk is shown as degraded.

 

This is from the Management console event viewer:

 

 

E 14-06-2012 19:59:34 Disk 'SAMSUNG HD103UJ-S13PJQSZ600689' at Controller1-Channel5 failed.

E 14-06-2012 19:59:34 Disk 'SAMSUNG HD103UJ-S13PJQSZ600686' at Controller1-Channel7 failed.

E 14-06-2012 19:59:34 An error occured on the disk at 'SAMSUNG HD103UJ-S13PJQSZ600689' at Controller1-Channel5.

 

Both of these drive show up fine in the Bios.

 

I tried switching the cables around, to see if that made any difference. But it gave me the same result.

 

I even tried disconnecting my newly bought spare disk, and re-attaching the drive that is said to be degraded in the first place, with the result that I now have 2 broken raid arrays showing up! One with two drives (that are fine) two drives that apparently die during windows booting. And one array with 1 degraded disk.

 

If I load up Bios i can still get my array showing with four drives that are fine. But if I plug in the spare, it just shows up as degraded. The original degraded disk only comes online as a separate array which in turn is disabled.

 

If I remove the new spare disk from the array, and re-assign it to the spare pool, it just sits there, and nothing happens in Bios. If I try loading into windows, everything breaks down again.

 

Does anyone know if the 2680 controller can rebuild on its own without loading into an OS?

 

I have nothing connected to the system except mouse and keyboard on USB. The MB Bios looks untouched, and on-board Raid is disabled.

Edited by tmpspiff
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...