Jump to content
RESET Forums (homeservershow.com)

Is it possible to enable sleep mode?


MarkJohnson
 Share

Recommended Posts

I am trying to get my whs2011 to sleep when not in use. I only need it a few hours a day tops. I found no sleep mode for PC in power config, only monitor sleep.

 

I goodled and seen that this board doesn't even have s1 or s3 enabled in BIOS, let alone windows server doesn't enable it either. Makes sense I guess as servers usually run 24/7.

 

anyway, I was wondering if these modified BIOSs out there have this feature enabled, or if it is disabled in hardware? I found so many different ones when getting the one I have now, that I thought maybe one had S1 or S3 enabled.

 

I see Hibernate is available, but disabled by whs2011 by default. But I don't think it will wake except for keyboard since there is no S-staes available.

 

I see posts on people trying to get lights-out add-on to do it, but I haveen't found anyone with success yet.

 

I have an Intel CT gigabit card that usally has a wake on lan feature. But would that alone wake it? or does that work in conjuction with the BIOS S-states?

 

I think my system uses around 40watts at idle with 4 HDDs and an SSD boot drive.

 

Hopefully someone can point me to a BIOS file with S-states so I can put this thing to sleep when not in use. or to wake from hibernate other than power button.

 

-=Mark=-

Link to comment
Share on other sites

I can't offer advice on turning it off, but leaving it on 24/7 would cost you around $2.40 a month.

 

40w x 24h x 365d / 1000 x 8c kwh = $28.03 a year.

 

I see that my ex487 has the option to turn off the hard drives, that would save some power.

Edited by jeffla
Link to comment
Share on other sites

I can't offer advice on turning it off, but leaving it on 24/7 would cost you around $2.40 a month.

 

40w x 24h x 365d / 1000 x 8c kwh = $28.03 a year.

 

I see that my ex487 has the option to turn off the hard drives, that would save some power.

 

Sooooo, less than the price of 1 Starbucks ;)

Link to comment
Share on other sites

I can't offer advice on turning it off, but leaving it on 24/7 would cost you around $2.40 a month.

 

40w x 24h x 365d / 1000 x 8c kwh = $28.03 a year.

 

I see that my ex487 has the option to turn off the hard drives, that would save some power.

 

yes, but if it only runs 3 hrs a day it will be around $0.30 a month or $3.60 a year!

 

forgot to add, my system allows the drive to sleep after 30 minutes.

 

I don't think the MicroServer will go to sleep.

 

No, powercfg -a reports The system firmware does not support S1, S2, & S3 states.

 

but it does say hibernate has not been enabled.

 

I was just hoping a BIOS update could fix the S-states.

 

Still searching

-=Mark=-

Edited by MarkJohnson
Link to comment
Share on other sites

Ah ha, I have slight progress. first, I found Wake on LAN in BIOS. For some reason it was listed uunder the Boot tab.

 

Next I install Lights-Out trial version and hit Standby Now, but get an error. I then enable hibernate powercfg /h on in elevated command prompt. Lights-Out errors out again. I reboot and try Lights-out again and VOILA! Hibernates just fine. Only wakes from power button.

 

I go to power setting and there is still no sleep modes for PC timer.

 

I check NIC adapter and see wake this computer is disabled. I enable it and also wake on magic packet as I remember reading some got wake to work, but with only magic packet enabled. Still no wake up, but I didn't configure magic packet and not sure how. I have looked up articles and each ones seems to conflict with the other.

 

I also found that hibernate is an s-state. It is S4.

 

Still searching

-=Mark=-

Link to comment
Share on other sites

Sweet, I almost got it working.

 

Lights out sleeps and wakes. I got the computer to put itself to sleep in the power setting. I set sleep mode to hibernate and time to 30minutes.

 

I found a WoL executable and it works fine. I just need the mac addrress of pc to wake. I even had regular wake on lan working, but it was waking after a couple of minutes. Lights out reported unknown device wake up.

 

Now I just need to find a way to get win7 to wake anytime I try to access the server. right now I have to manually run the WoL.exe file everytime I want to access the server.

 

I also get a C++ runtime error from atibtmon.exe. It appears to be an AMD driver issue of some sort.

 

It says application has requested the runtime to terminate in an unuaual way.

 

I just looked and the aribtmon.exe error happens when I select powerplay on battery permance to maximize battery life. If I select maximize performance, no isses. I have a UPS connected to my server.

 

all I seem to have left is figuring how to auto wake magic packets in windows so I don't have to manually run programs to wake. especially on automated programs or torrents.

 

Still searching

-=Mark=-

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...