Jump to content
RESET Forums (homeservershow.com)

Installing WHS 2011 on 60GB SSD


Joe_Miner
 Share

Recommended Posts

I have installed WHS2011 on G7 microservers using small SSDs at least 5 times and best practice was to insert cfg.ini to root of the SSD drive.

There is absolutely no need to involve USB pendrives and modify boot setting in bios. Just make sure that SSD is preformatted and cfg.ini is there.

Link to comment
Share on other sites

  • 11 months later...

Resurrecting this thread.

 

I've got some time on my hands, so I decided it might be nice to test installing WHS2011 onto an OCZ Revo 128GB PCIe SSD I've had sitting on the shelf.

 

Because it's a PCIe SSD, rather than SATA, it requires drivers for Windows to recognise it. I didn't recall for sure how large the Revo is, so I decided to just try a direct installation. I inserted a USB flash drive with the Revo drivers into my test computer, installed the Revo into a PCIe slot, a WHS2011 DVD into the ODD drive, and booted up.

 

Everything proceeded fine to start with. I was able to load the Revo drivers and have the SSD recognised by the Installer. However, after I clicked Proceed, I ran into an issue. The Installer reported that the drive is smaller than 160GB, so it rejected it.

 

I immediately thought of Joe_Miner's forum posts about installing WHS2011 onto a 60GB SSD. I looked up the info and created an NTFS USB stick with the cfg.ini file that the article stipulates.

 

I inserted the USB cfg.ini stick into the test computer and booted up again. Instead of the Attended Install configuration screen I'm used to seeing, the installation displayed an error, with a hyperlink to a log file. Checking the log file, it became clear that the Installer had again rejected the drive. It also became clear that the Installer had attempted an Unattended Install.

 

I wasn't sure how to proceed, so I did a BING search for homeservershow.com items containing WHS2011 and 60GB. One of the links lead me to Joe_Miner's blog post about installing WHS2011 on a 60GB SSD. In that article I learned that the SSD cannot be larger 104132MB (basically, 100GB). So, I modified the cfg.ini file and changed MAX to 75000. I figured that would give me some extra space on the C: drive, in case I should need/want it in the future.

 

I placed the USB flash drive into the test computer again and booted up. This time I got the Attended Install installation screen I'm used to seeing. I clicked New Installation, loaded the Revo drivers and clicked Proceed. Unfortunately, I got the error about the drive not being 160GB. It seemed as though I was back to an Attended Install.

 

This seemed a little odd. I checked the cfg.ini file and noticed a line I hadn't entered: Processed=True. I recalled reading about this from the forum posts, so I deleted it, saved the file, moved the USB stick back to the test computer, and booted up again. Failure. I got the normal Attended Install screen

 

I did a BING search for cfg.ini info and found the Drivers= parameter. I entered it into cfg.ini with the path to the Revo drivers. My cfg.ini wound up like this:

 

[WinPE]
ConfigDisk=1
CheckReqs=0
WindowsPartitionSize=75000
Drivers=_:\Revo_Drivers_64-bit

 

According to the article I read, "_:\" is the wild card entry to use when you're not sure which drive letter the USB stick will be assigned.

 

Well, the bottom line is that none of this has worked. If anyone has any ideas how to make it work, please chime in.

 

Basically, my summary is the situation is that I need to know how to configure things so that I can both use an SSD smaller than 160GB and load drivers for that SSD.
 

EDIT: I may have found the problem. I changed the Drivers=_:\Revo_Drivers_64-bit line to Drivers=_:\Drivers and renamed the folder to Drivers. I rebooted and the installation appears to be proceeding. So, perhaps, the path to the drivers in cfg.ini has to point to a folder named 'Drivers'. So stupid (IMHO) :angry:

 

EDIT 2: Well, the server is up & running. Apparently, the supposition that the driver folder has to be named "Drivers" is correct. I do not know if it's possible to have subfolders under Drivers. I assume it must be possible. If it wasn't, if all the driver files for multiple devices had to be immediately under Drivers, I could see some real issues with .INF file name conflicts.

Link to comment
Share on other sites

Yes, the drivers folder must be named "drivers". In fact, IIRC, if you have the folder, it will check it without the line in the config (though I'm not 100% sure about that.

 

 

Alternatively, busting out the Windows AIK and using DISM to integrate the drivers into the boot.wim and the install.wim files should allow you to install to the disk without an issue.

 

Additionally, the size issue is weird. I installed to a 120GB SSD wayy back in the day without an issue...

Link to comment
Share on other sites

Well, my installation is hosed. I tried to do a reinstall, to do 2 things:

  1. test that it's possible to reinstall on the RevoDrive;
  2. test to see if subfolders can be used under the Drivers folder.

I have confirmed that #2 is possible. I copied the RevoDrive driver files into a subfolder under the Drivers folder and the installer found them just fine.

 

However, after the installation completed, much as it had done successfully yesterday, it failed to reboot, saying that no bootable drive could be found. I connected a bootable hard drive to the system, booted it up, loaded the RevoDrive driver onto the system, rebooted, then used DISKPART to /CLEAN the drive. Then I tried to install again but got the same result.

 

I was going to try to repair the bootloader, but it can't work unless the RevoDrive driver is installed, and I can't find a way to load it. I used Shift+F10 to open a command window after booting up from the WHS2011 Installation Disk, in order to try to use devload.exe to load the driver, but devload.exe could not be found.

 

So, I'm SoL at this point, unless someone has any bright ideas. I guess I'll download the MS WAIK and see if I can incorporate the RevoDrive driver into the base install.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...