Jump to content
Greg Welch

Is your Crash Plan Crashing ?

Recommended Posts

Greg Welch    4
Greg Welch

CrashPlan support fixed the problen first try :)

 

 

Gregwelch, May 09 07:41 pm (CDT):

 

Hi, I have CrashPlan Pro installed on my WHS 2011. What happens is that the

tray icon closes and from what I can tell service stops working.

 

The first time it runs it will last for about an hour or longer then say the next day I go to see

progress and its closed and tray icon is gone, then when I try and start the

program it only stays open say 30 seconds and closes.

 

Please help

 

 

Their responce

 

 

 

Michael W., May 11 04:02 pm (CDT):

 

Good day Greg,

 

It appears that the CrashPlan backup engine is running out of memory. Could you follow the instructions below to allocate more memory to the CrashPlan backup engine?

Running Notepad or any other text-editor as an Admin, edit the CrashPlan engine's CrashPlanService.ini file to allow it to use more java memory:

 

1. Stop the backup engine: http://support.crashplan.com/doku.php/how_to/stop_and_start_engine

2. Locate the Notepad program, right-click and Launch as Administrator

3. Go to File > Open, and navigate to C:\Program Files\CrashPlan\CrashPlanService.ini

4. Find the following line in the file:

-Xmx512m

5. Edit to something larger such as 640, 768, 896, or 1024. E.g.:

-Xmx1024m

This sets the maximum amount of memory that CrashPlan can use. CrashPlan will not use that much until it needs it. I would recommend starting out setting it to 768, and go higher only if you continue experiencing problems. You can set it as high as 2048 on 32-bit systems, or even higher on 64-bit systems.

6. Start the backup engine.

Please let me know if you have any questions.

 

 

Regards,

~Michael

 

 

 

This worked perfectly, Thank you

Share this post


Link to post
Share on other sites
pcdoc    107
pcdoc

Thanks Greg, will keep this as reference. Not having an issue with 2008R2 but just in case I install it on 2011this is good to know.

Share this post


Link to post
Share on other sites
tojoski    3
tojoski

Interesting. I had an issue with the free version of Crashplan on my 2011 box where the service kept crashing and wound I up removing it.

 

Thanks for the tip, I'm going to try reloading it and allocating more memory to it.

Share this post


Link to post
Share on other sites
Greg Welch    4
Greg Welch

Interesting. I had an issue with the free version of Crashplan on my 2011 box where the service kept crashing and wound I up removing it.

 

Thanks for the tip, I'm going to try reloading it and allocating more memory to it.

 

Thanks for letting me know, ill bet they automate this in later updates

Share this post


Link to post
Share on other sites
ImTheTypeOfGuy    33
ImTheTypeOfGuy

So instead of fixing the reason it is requiring more memory they tell you to just feed it more. Eventually, will it run out of memory and not work?

Share this post


Link to post
Share on other sites
ikon    420
ikon

So instead of fixing the reason it is requiring more memory they tell you to just feed it more. Eventually, will it run out of memory and not work?

 

That's assuming there is something to fix - there may not be. It may simply be a case that he has so many files that CrashPlan doesn't have enough room to index them all for backup. That's just one example; there could be many other legitimate reasons.

Share this post


Link to post
Share on other sites
Greg Welch    4
Greg Welch

Well here is what i can tell ya,

 

1) I set CrashPlan to 4096 of Ram

 

2) Backing up total of 1.1 TB

 

3) WHS 2011 was a VM with static 4GB of Ram alocated so i set it to Dynamic with Min-4GB max-16GB

 

4)CrashPlan Network Settings 2MB sending rate 2048KB Buffer size and TCP packets set to throughput

 

5) at the moment system is using 2.3GB of ram, not alot going on

 

 

seams to be working great , may increase setting later

Share this post


Link to post
Share on other sites
ImTheTypeOfGuy    33
ImTheTypeOfGuy

Guess what problem I just ran into? So now I am contacting them to see what happens when 1024 for my 32 bit WHS v1 is consumed.

Share this post


Link to post
Share on other sites
Greg Welch    4
Greg Welch

Guess what problem I just ran into? So now I am contacting them to see what happens when 1024 for my 32 bit WHS v1 is consumed.

 

I set mine to 4096 and havent had a problem since, it only uses what it needs of the amount you set

Share this post


Link to post
Share on other sites
ImTheTypeOfGuy    33
ImTheTypeOfGuy

I set mine to 4096 and havent had a problem since, it only uses what it needs of the amount you set

 

I fear that isn't the case though because if it were, we wouldn't of had to increase it in the first place. I look forward to seeing how hey respond to my email.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×