Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
bondisdead

Gigabyte Z68XP-UD3 sluggish with 16GB RAM installed

Recommended Posts

ikon

It's disappointing to hear this news. Reminds me of the late 90s when Gigabyte went bad. That time it was due to their popularity. The increased demand caused QC problems and it got so you couldn't trust any of their boards. I hope this is just a bump in the road and they get their quality back where it should be. It'll be worse if Asus has issues too.

Share this post


Link to post
Share on other sites
mrossco

Bummer. It's true that enthusiast boards tend to go in cycles. I've personally had both great successes and failures with both ASUS and Gigabyte. Intels tend to be solid, but they also tend to be fairly vanilla in terms of features and performance.

 

Good luck on your RMA. I hope it fixes your issue.

Share this post


Link to post
Share on other sites
ikon

Intels tend to be solid, but they also tend to be fairly vanilla in terms of features and performance.

 

True.

Share this post


Link to post
Share on other sites
bondisdead

One thing I have noticed on the sub $100 Intel mobo is that the components seem cheaper. Lots of old-school electrolytic caps, versus solid-state.

Share this post


Link to post
Share on other sites
ImTheTypeOfGuy

Only board I have bought without any problems is EVGA. I love that board. But I don't buy as many boards as you guys do. Only board I have had real problems with is ASUS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...