Jump to content
RESET Forums (homeservershow.com)

Verifying Port Forwarding for your router failed


jvk
 Share

Recommended Posts

Hi everyone. I have had my franken-build server up for about 2 years now and I have always had this issue. Every couple of days or so I will get the yellow icon in the notification area telling me that port forwarding has failed. To get rid of this issue, I do the following...

Restart my router
Then go into the WHS console, click on settings> remote access> details> and then click refresh.

This gets rid of the issue 100% of the time, however it is a pain to have to do this every couple of days or so.

My router model is a Belkin F5D8236-4v1(01). I also had a different belkin router on the network with the same error.

At one time I had WHS set up with a static IP address as outlined on page 46 of the book "Microsoft Windows Home Server Unleashed", however this didn't help.

UNPH is enabled on my router.

Does anyone have any ideas?
Thanks

Link to comment
Share on other sites

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

  • dvn

    5

  • cskenney

    3

  • jvk

    7

  • roddy

    3

Top Posters In This Topic

Does it only fix the problem if you restart the router?

I use DHCP reservation in my D-Link router to basically assign a fixed IP address to my WHS. It works like a fixed IP address, but the router takes care of everything.

Link to comment
Share on other sites

I agree with cskenney about using DHCP reservation.

My first couple steps would be to disable UPNP and see if this helps. Also, what router is it? Is there an updated firmware?

Link to comment
Share on other sites

Yes, I need to restart the router, if not the problem will not be fixed.

I'll look into DHCP reservation and disabling UPNP, thanks for the tip.

The router is a Belkin Wireless N (model #F5D8236-4v1(01)). The firmware is the latest version.

I'll post my findings.

Thanks again

Link to comment
Share on other sites

I get this from time to time on my D-Link DIR-655 router. When I look into the router the UPNP mappings of the ports are always there and forwarding works.
If you want to get rid of the issue simply map the ports statically to your WHS. Then reserve the WHS Ip address as talked about above.

Link to comment
Share on other sites

Unfortunately, it appears that my router does not support DHCP Reservation.

Do you guys suggest assigning the IP statically on the server side and then forward the ports necessary in the router?

The book I have "Microsoft Windows Home Server Unleashed" on page 242 states that I will need to forward ports 443 and 4125 to Windows Home Server.

Thanks,

jvk

Link to comment
Share on other sites

I have this router, I set a static IP address on my EX490 and on the router under Virtual Servers I set port 80,443,4125 to forward to the server. Note: Since PP2 the Remote Access tab in the Console settings always shows up as not available with the red X. This worked pre-PP2. Might be that they changed how the router reports back and the N1 must do something strange. But I don't get the failed error and the site connects.

Link to comment
Share on other sites

I have heard about the static ip address several times on the podcast. What is the advantage of setting this up?

Link to comment
Share on other sites

@Diehard. My remote access tab always shows up as connected unless there is actually a problem. I don't have a red X. I just verified, remote access is available and it confirmed it works.

Link to comment
Share on other sites

I just did the following... Disabled the UNHP feature on my router, applied a static IP address on the server side, forwarded ports 80, 443, and 4125 to my server's new static IP address and it works.

I will keep checking that it stays fixed permanently, but so far so good. I just wish I didn't have to jump through all these hoops... it would be nice if WHS could manage the settings on my router, but I'm pretty sure that it is a problem with my router. Ironically, when I go to the DHCP client list on my router the server never shows up (static IP or Not). Anyways I'm not touching it now that it is working :)

Thanks!

jvk

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...