Jump to content
Joe_Miner

3TB Drive Performance on MicroServer & Hyper-V Pass Thru

Recommended Posts

Joe_Miner

Everyone know's from my earlier thread that I had placed a Seagate ST3000DM001 3TB drive and tested it's performance in my MicroServer that is running Server 2008 R2 Enterprise.

 

The Seagate is a SATA III drive though the MicroServer is only a SATA II so I expected some degradation in performance but as you recall the performance was amazing. One of the things I wanted to do was to learn how to do a SATA drive pass through to a VM Running in Hyper-V on the MicroServer. The Seagate seemed to be the perfect test subject for this. Below is the performance of The Seagate 3TB first running under Server 2008 R2 Enterprise then The Seagate 3TB is running attached to WHS 2011 VM as a Hyper-V pass through disk.

 

2012-02-24_DriveG_MicroServer_Seagate_3TB_ST3000DM01_Port3.jpg2012-02-29_MicroServer_Seagate_3TB_ST3000DM01_Hyper-V_VM_WHS2011.jpg

 

While the performance curves are different early on they still max out at respectible levels and from my perspective it was educational to do the pass thru and see the real world results.

 

Of course, it couldn't end here -- I felt obligated to pull my 3TB WD drive from my main client and test it's performance and the Hyper-V pass thru in the Microserver.

 

My 3TB WD30EZRX is also a SATA III drive.

 

Again, I tested it while running under Server 2008 R2 and then running as a Hyper-V pass thru to a VM WHS 2011.

 

2012-02-29_DriveE_MicroServer_WD30EZRX_3TB_Port2Bay3.jpg2012-02-29_MicroServer_WD30EZRX_3TB_Hyper-V_VM_WHS2011.jpg

 

I'm a bit taken aback by the huge difference in performance between the two drives. The WD performs quite a bit better when attached to a SATA III port in my Main Client.

 

But clearly, the Seagate 3TB is a top performer in the MicroServer.

Share this post


Link to post
Share on other sites
ikon

Very interesting. Just goes to show that matching specs are no guarantee of matching performance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • JackoUK
      By JackoUK
      After 2 days and no problems with the Windows 10 Fall Creators Update I thought I'd report my conversion experiences.
       
      The upgrade was offered immediately on N36, N54 and Gen8 microservers, which in my case are running Windows 10 Pro.
      I accepted the 'in place' upgrade on 3 of my 4 machines ... with some trepidation since the last upgrade destroyed my shared folder configurations.
      No problems of any sort thus far: only the splash screens for the new features in Edge makes one aware that things have changed.
      'In place' with HDD's for the OS drive is .... very slow ... we're talking hours.
       
      The 2nd of my Gen8 machines stalled mid way through upgrade ...but I don't think that was a server or Windows problem: when I reverted to the old OS version disk errors were reported so I suspect the OS disk is on its way out.
      After repairing bad blocks I tried a clean reinstall. This is much faster (40 minutes) but one has to reinstall programs and reconfigure. Not a problem since this is only a file server, so only shared folders to reset. I'm glad this happened in one way ... good I think to remind oneself of how to handle a rebuild ... since I could not find the B120i driver file ... or indeed any other HP drivers for the Gen8, which should have been in my machine installation archive. Corrected.
       
      The usual sites were reporting that the new version of Onedrive requires manual installation. Worked fine.
       
      Time to explore the new features then.
      I've had it in the back of my mind to try REFS via Storage Spaces for some time. Unfortunately this is another case of NASDAQ:MSFT going backwards for consumers: that option is now removed and only available in the new Windows Pro for Workstations edition. Which I won't be buying.
      To be fair though the upgrade has worked without problems on LINX 1010 tablets and my old DELL PC, SAMSUNG laptop, so my initial reaction is to give MSFT the thumbs up.
      Hope everyone else has good experiences too!
    • Aleksander
      By Aleksander
      Hi guys!
      Trying to configure AlertMail in iLO, but I don't receive a mail. I have installed Debian, need I to configure mail server (postfix) on it?
    • luckyfabian@gmail.com
      By luckyfabian@gmail.com
      Hi all,
       
       I recently obtained a Standard license for 2016 Server and was thinking to run it on a new box. Can somebody please correct me because AFAIK a Standard 2016 license is ok for 2 cores (dual-core) how does this work if I obtain a server with 4 cores? I was looking at HPE Gen10 Proliant but no ILO (as I have a Gen8 VMware box). I am thinking however to get another Gen8 box but could do with your advice please as following...
       
      As my Microserver Gen8 box has 16gb (which I believe is the maximum amount of memory supported? Or somebody could say otherwise) I have Win2012 R2 running on one VM (ESXi v6), I COULD provision another VM for running Win2016 Standard, do you think this would be feasible with 16gb in total on the Server?? Plus with 2016 Standard License I can run two Hyper V VM's (was thinking a Win10 and maybe a Win7 clients) so I was thinking a barebones server (maybe another Gen8 Microserver, not sure about the new HPE Gen10's as no ILO and I want the ILO functionality) or was looking at the ML Gen9 XEON server recently (no ILO but I believe can switch with the onboard AMT) or was just looking at a Fujitsu PRIMERGY TX1310 M1 Xeon E3-1226 V3 16GB 2TB Tower Server, could anyone advise me on these?
       
      I was thinking I could load 2016 on another VM and have 4gb provisioned for 2012 R2 and probably provision the rest of the memory (12gb) for the 2016 Server with 2x Hyper V clients eventually
      Can someone confirm that I could run 2016 as a VM on my Gen8 Microserver or should I go for another server (not sure about the Microserver Gen10 boxes as no ILO) or was looking at the Fujitsu system as mentioned above.
       
      ANY advice would be MOST GREATLY appreciated.
       
      This Server is to practise Group Policy, Power Shell and setting up a Domain and a trial of Office365 to practise Azure AD at home probably over the internal network with a couple of PC's in the house, so nothing heavy.
      Thanks in advance,
       
      Lucky
    • luckyfabian@gmail.com
      By luckyfabian@gmail.com
      Hi all,
       
       I recently obtained a Standard license for 2016 Server and was thinking to run it on a new box. Can somebody please correct me because AFAIK a Standard 2016 license is ok for 2 cores (dual-core) how does this work if I obtain a server with 4 cores? I was looking at HPE Gen10 Proliant but no ILO (as I have a Gen8 VMware box). 
       
      As my Microserver Gen8 box has 16gb (which I believe is the maximum amount of memory supported? Or somebody could say otherwise) I have Win2012 R2 running on one VM (ESXi v6), I COULD provision another VM for running Win2016 Standard, do you think this would be feasible with 16gb in total on the Server?? Plus with 2016 Standard License I can run two Hyper V VM's (was thinking a Win10 and maybe a Win7 clients) so I was thinking a barebones server (maybe another Gen8 Microserver, not sure about the new HPE Gen10's as no ILO and I want the ILO functionality) or was looking at the ML Gen9 XEON server recently (no ILO but I believe can switch with the onboard AMT) or was just looking at a Fujitsu PRIMERGY TX1310 M1 Xeon E3-1226 V3 16GB 2TB Tower Server, could anyone advise me on these?
       
      I was thinking I could load 2016 on another VM and have 4gb provisioned for 2012 R2 and probably provision the rest of the memory (12gb) for the 2016 Server with 2x Hyper V clients eventually
      Can someone confirm that I could run 2016 as a VM on my Gen8 Microserver or should I go for another server (not sure about the Microserver Gen10 boxes as no ILO) or was looking at the Fujitsu system as mentioned above.
       
      ANY advice would be MOST GREATLY appreciated.
       
      This Server is to practise Group Policy, Power Shell and setting up a Domain and a trial of Office365 to practise Azure AD at home probably over the internal network with a couple of PC's in the house, so nothing heavy.
      Thanks in advance,
       
      Lucky
    • Joe_Miner
      By Joe_Miner
      By: JohnStutsman
       
       
       

       
      Figure 1 – Preparing to install new 64GB of RAM
       
       
       
      I upgrade the stock 8GB to 64GB of RAM in the HPE ProLiant ML30 Gen9 using 4 DIMMs (“Sticks”) of Kingston KVR21E15D8/16.
       
       
       

       
      Figure 2 – Kingston KVR21E15D8/16
       
       
       

       
      Figure 3 – 64GB RAM about to be installed in HPE ProLiant ML30 Gen9
       
       
       
       
       
      Figure 4 – HPE ProLiant ML30 Gen9 – System Board Components & Memory “Type” requirement from “QuickSpecs” – DIMMs removal & installation instructions from “Maintenance & Service Guide” (see links in References below)
       
       
       

       
      Figure 5 – HPE ProLiant ML30 Gen9 – Memory & DDR4 memory population guidelines from “QuickSpecs” (see links in References below)
       
       
       
      I upgraded to 64GB of RAM in my HPE ProLiant ML30 Gen9 using Kingston KVR21E15D8/16 from Newegg. The KVR21E15D8/16 was suggested by Schoondoggy on the forum thread RAM for ML30 Gen9.
       
       
       
       
      Video 1 – 64GB RAM in HPE ProLiant ML30 Gen9.
       
       
       

       
      Figure 6 – View of the four new DIMMs installed for 64GB of RAM. Time to replace the air baffle, tower bezel, and side panel then hook up the ML30 Gen9 and see if it works!
       
       
       
       
       

       
      Figure 7 – IT WORKS! Screen during first post showing 64GB RAM - for the first time!  Thank you Schoondoggy!!
       
       
       

       
      Figure 8 – System Summary Information showing 64GB RAM installed
       
       
       

       
      Figure 9 – System Information with Installed Physical Memory (64GB RAM) Highlighted
       
       
       

       
      Figure 10 – Task Manager showing 64GB of DDR4.
       
       
       

       
      Figure 11 – iLO4 System Information – Memory Information showing four 16GB DIMMs installed.  Status is "Good, In Use".
       
       
       

       
      Figure 12 – Temperatures appear well within range while system fan speed was a consistent 6% - BIOS set to Optimal Cooling (Note that the two 40mm fans in the Icy Dock ToughArmor MB994SP-4SB-1 were also running).
       
       
       

       
      Figure 13 – HPE ProLiant ML30 Gen9 running with 64GB RAM and using 30.1 Watts. Everything seems to be working well – time to think about adding more drives and turn on Hyper-V!!
       
       
       
      As-Built (I named my Computer: Serenity)
      HPE ProLiant ML30 Gen9 (Product No. 830893) Xeon E3-1240v5 (SkyLake LGA 1151) 64GB ECC RAM – Kingston KVR21E15D8/16 OS: Windows 10 Pro B140i Dynamic Smart Array: Ports 1-4: (4*3.5” Drive Tray Caddies for Main Drive-Cage Assembly Bays 1-4) B140i Dynamic Smart Array: Ports 5-6: Icy Dock MB994SP-4SB-1 in Top 5.25” half-height Bay; with/ 2*18” SATA III (6 Gb/s) cables attached to Bays 1 & 2 (Bays 3 & 4 are available for future); Molex to Molex & Fan Y-Connector Cable; Samsung 840 Pro 256GB in Bay 1;  
       
      Please join us in the HomeServerShow Forums to discuss this and tell us what you are building at home.
       
       
       
      Reference:
       
      RAM for ML30 Gen9 http://homeservershow.com/forums/index.php?/topic/14807-ram-for-ml30-gen9/
       
      ValueRAM Decoder https://www.kingston.com/us/memory/valueram/valueram_decoder
       
      ValueRAM KVR21E15D8/16 Specs Sheet http://www.kingston.com/dataSheets/KVR21E15D8_16.pdf
       
      Check HSS Forum Post: Other HSS ML30 Blog Postings: http://homeservershow.com/tag/ML30
       
      HomeServerShow Forum for ML10’s & ML30’s http://homeservershow.com/forums/index.php?/forum/98-ml10-and-ml10v2/
       
      HPE ProLiant ML30 Gen9 Server Maintenance & Service Guide http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c04905980-1.pdf
       
      HPE ProLiant ML30 Gen9 Server QuickSpecs http://h20195.www2.hp.com/v2/GetDocument.aspx?docname=c04834998&doctype=quickspecs&doclang=EN_US&searchquery=&cc=us&lc=en


×