Jump to content
RESET Forums (homeservershow.com)
diehard

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

biosblues

You should be able to repeat the procedure with the stock bios from HP. Does that not work?

 

I've tried, does nothing. The USB stick flashes a few times, and only when its in the onboard USB port, but otherwise nothing.

 

 

Are you saying the system doesn't display anything during POST?!?!

 

That is correct.

Edited by biosblues

Share this post


Link to post
Share on other sites
jmwills

RMA it.

Share this post


Link to post
Share on other sites
ikon

That is correct.

 

Well that certainly seems abnormal. Like jmwills says, try to RMA it. I just hope HP doesn't give you a hassle because you tried to flash a non-HP-supplied BIOS.

Share this post


Link to post
Share on other sites
biosblues

Well that certainly seems abnormal. Like jmwills says, try to RMA it. I just hope HP doesn't give you a hassle because you tried to flash a non-HP-supplied BIOS.

 

Thanks for all the help. I think I'm going to have to take your advice on this one and just do a RMA.

Share this post


Link to post
Share on other sites
Dade

Hi,

I've got my microserver few days ago. I would like to flash with the modded firmware from the first post but my microserver is connected with my tv and after startup I got a message from the tv which told me that the video mode is not supported.

Is there any way to force bios update without any interaction?

 

Thanks

Share this post


Link to post
Share on other sites
ikon

I would find that a bit risky. Personally, I would find a real monitor, somewhere, somehow, and connect it to the server.

Share this post


Link to post
Share on other sites
mR JoLLy

I agree. Even if you managed to get the BIOS to flash unaided, which is possible, I very much doubt the flashing process would make the picture appear on the monitor. Deffo get a momitor and do it !

Share this post


Link to post
Share on other sites
Dade

Thanks,

I will search for a monitor, it will be definitely better.

 

Cheers

Share this post


Link to post
Share on other sites
hp bios are trash

Hello folks I'm new here as you can tell. Let me start off with a small introduction. My name is Larry I know some things when it comes to computers but not near as much as most here. I REALLY need help on getting my bios to show the "shadowed" aka hidden BIOS options. I have a HP Pavilion dv9008nr Notebook PC

Serial Number: CNF6453S0T

Product Number: ez458ua

I want to turn my fans on before my system reaches overheating temps (why would anyone set the fan this way), change my video settings and a few other things. But the most important things I need to know how to do is fix when my fan comes on and my video options. I have looked for weeks and stumbled on this and you guys give me lots of hope again ! PLEASE please I BEG of anyone who is willing to help out a rookie, I have never did anything with BIOS. If there was anyway I could help you fellas out I honest to God would but lets be honest you know more than I do so I'm no use. We can chat here or I'll be more than happy to chat with any messenger you like. Thanks in advanced.

(I'm glued to this page for the time being lol)

Share this post


Link to post
Share on other sites
jmwills

There is a great post by forum member "Joe_Miner" where he goes into the BIOS modification in depth. Other posts by member "Diehard" are also excellent reference guides.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny


×
×
  • Create New...