Jump to content
RESET Forums (homeservershow.com)
diehard

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

timjn

Perfect, thank you for the screen shots.

 

I have two RAID 1 disks configured on my microserver will updating the BIOS cause any problems with the RAID configuration?

 

Also another question about the RAID configuration on the microserver, is the onboard RAID controller a software based controller or hardware based, and if it's software based is it any better than the mirror ing that I could set up in Windows disk manager?

Share this post


Link to post
Share on other sites
jmwills

Not saying that it will, but I would check the consistency of the array after you mod the BIOS. If this were an approved procedure from HP, I would have no worries, but since this is a hack, I'd check the array afterwards.

Share this post


Link to post
Share on other sites
ikon

Also another question about the RAID configuration on the microserver, is the onboard RAID controller a software based controller or hardware based, and if it's software based is it any better than the mirror ing that I could set up in Windows disk manager?

 

If it's like every other mobo-based RAID I've seen, it's a hybrid between hardware and software. One disadvantage of it is it's very unlikely it could be moved to another box if the mobo fails; with add-in RAID cards this is usually possible. It's also often possible with Disk Manager based RAID. You can normally just import the array into the new Windows box.

Share this post


Link to post
Share on other sites
dannybuoy

Hi, does anybody know if this BIOS can be used with the N36L?

Share this post


Link to post
Share on other sites
jmwills

One of those links should tell you. From memory, I think the N36L is also good to go but look at the documentation in the links.

Share this post


Link to post
Share on other sites
ikon

Thanks for clarifying the situation; I'm sure it will help a lot of people in these forums. if you still have some of those links you found, I'm sure others would be grateful if you posted them.

Share this post


Link to post
Share on other sites
jazzerjay

Looks like only 1 drive is visable from the Sans Digital TR4M, so it's as if it's a regular single hard drive connected externally. Bummer. :( Looks like I would have to install a esata port multiplier card in the PCIx slot.

 

At least the DROBO-S is visable as 1 drive, but that's a premuim device.

 

I cannot believe I missed this post. I jumped on that Shell Shocker and figured I'd be good to go. Now I'll need an esata port multiplier card. This one is all on me though. Thanks John!

Share this post


Link to post
Share on other sites
biosblues

Hi, Hope someone can help me, seems I've bricked my N40L.

I followed all the instructions regarding the BIOS mod update, but after getting to the C:\ prompt and doing the restart my server is basically dead.

On power up the HP logo turns red for a second and then goes out, the power button is green, fans are all on, but the screen is just black?

 

Any idea what i could do to recover the factory BIOS or any other BIOS? I even tried doing the CMOS clear procedure by changing the jumpers on the board.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites
jmwills
biosblues

Get a copy of the BIOS form the HP site.

 

http://h20566.www2.h...achetoken#12212

 

Thanks, but I've tried this.

 

When using the USB stick, are you supposed to use the on board USB port?

What i don't understand is when I ran the mod, I could see it was doing something because of all the output to the screen. It did not take long until I saw the C:\ prompt, I removing the USB stick and did the restart. What is the actual procedure for powering down when you get to the prompt, hold the power button down till it turns orange or pull the plug?

 

I've followed the following forum too, but with no luck.

http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/BIOS-recovery-Proliant-Microserver-N36L/m-p/4726699#M107808

 

Is there any way to get back to factory defaults?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • Phil Croxford
      By Phil Croxford
      Hi,
       
      Not sure if this is a taboo subject?? but delete if needed.
      I have bought a Gen 10 Micro Server for my home so i can run a Plex Server in house. i have all the drivers and updates that i need from the HP website
      but gone and noticed that the Bios update i need from what i can gather i need a contract? I'm not sure what to do?
      how do i get the bios update for this server?
       
      when i bought this server its running on 5.12 version with a build date of 05/25/2017 so my bios is well out of date.
       
      can any one guide me in the right direction to get the update?
       
      thanks
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
       
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
       
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
       
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
       
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.
       


×
×
  • Create New...