Jump to content
RESET Forums (homeservershow.com)
diehard

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

nrf

my foggy recollection is that it is also necessary to go into some of the 'new' settings that the upgrade made available and adjust them to get full functionality.

Share this post


Link to post
Share on other sites
LVLouisCyphre

Update and my bad; it does work.  You need to go to Southbridge Configuration > SB SATA Configuration > SATA IDE Combined Mode > DISABLED; it's enabled by default.

 

If you don't, the last two SATA ports will be bifurcated to a separate PCI device with only SATA 1 capabilities (AMD SB7x0/SB8x0) or appear as a pair of Southbridges at kernel loading; two IDE ports and four AHCI ports.  It's unknown if this is the default configuration for the AMD chipset that's on the G7s.  AMD doesn't have a technical archive of their products like Intel does.

 

When you disable combined mode; you get a single AMD SB7x0/SB8x0/SB9x0 with six AHCI SATA 2 ports with SATA multiplier capability which is what you want to get the most out of a G7.

Share this post


Link to post
Share on other sites
LVLouisCyphre
On 2/10/2020 at 7:51 PM, nrf said:

my foggy recollection is that it is also necessary to go into some of the 'new' settings that the upgrade made available and adjust them to get full functionality.

I found it.  What threw me off when it's in brain damaged combined mode, SATA ports 5 and 6 are bifurcated to a separate IDE controller.  A bit confusing since this is called "combined mode" as bifurcate and combine are antonyms. I was expecting it to show up as a six SATA ports from the beginning with ports 5 and 6 being locked at SATA 1 speeds.

Edited by LVLouisCyphre

Share this post


Link to post
Share on other sites
nrf
1 hour ago, LVLouisCyphre said:

SATA IDE Combined Mode

not exactly clear usable menu text. thanks for the explanation

Share this post


Link to post
Share on other sites
glenncol

Hi all

 

I came across a Brand new unsued N54L t he other day for a song so i gradded id, i am planing on runinmg Xpenology as and wanted ot run the modded Bios update to enable the adddtional HD.

 

Can someone please point me in the direction of the current links to the moded Bios and installations files and any instrustions as all the olinks i have found so far no longer exists or i get an owncloud incompatibility error or something

Share this post


Link to post
Share on other sites
Jord9857

Hi,
Just tried doing this BIOS Mod upgrade following all the steps on this website as suggested on a previous page on this thread. (https://www.nathanielperez.us/blog/hp-proliant-n40l-bios-modification-guide) soon as i plug my USB stick into my N54L HP Microserver and automatically boots off it, I get

'ROMPAQ may take a few minutes to get started. Please be patient....
Command or filename not recognized
C:\>'

Any idea's?

Share this post


Link to post
Share on other sites
chickenlip007

Flashed this on 2x N54L's without issue, I am yet to try it on my N40L but should be okay

Does anyone know if there is a Modified BIOS for the Gen8 (1610 model) ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny


×
×
  • Create New...