Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts


Indeed I saw that, I must have d/l'ed the Tobi mod the other day, however it does read still in the BIOS as:





the actual date stamp of the BIOS rev vs release date (15 NOV 2013) I assume was throwing me off.

Share this post

Link to post
Share on other sites



I downloaded and installed the o41100113-acpi-s3+s4_hotplug_fan-control.rar file. I got lot of new menu, but i have two problems:


1: on the main screen i see that the BIOS ID: 041, Bios Version 07/29/2011.

2: on the disn menu i doesn't see my disks. All of disks are non detected, but i see this on the boot menu where i can select the boot disk.


So this  is the latest modified bios? And that is normal that i didn't see any disks in the bios?





Share this post

Link to post
Share on other sites



I recently got a HP Microserver N40L and find it to be very noisy to setup in my Living Room so i bought a Noctua PWM Fan without realising that the Server needed a specific FAN Speed to Boot up.

Can the modded BIOS get around this Limitation?

Share this post

Link to post
Share on other sites

Has HP now blocked this fix from working on newer N54L stock, because ......... I'm not too damned happy :/

This is my OLD HP Microserver, you can clearly see an option for "OnBoard PCI IDE Controller", this option is MISSING on my new server :/






You can also see, when it does disk detection

All 6 hard drives are visible under AHCI.




On my new Microserver, the PCI IDE option seems to be locked in IDE mode (because the option is ENTIRELY missing)  and it only detects 4 AHCI disks and 2 IDE disks.

I'm 99.976% sure the hacked ROM was installed correctly by me, because the incredibly complex, weirdo options to the far right are there (very extensive north / southbridge menus, which I distinctly recall NOT being there on the stock ROM for the Microserver series)


Am I doing something wrong or was a change recently made?

Edited by wizzbang

Share this post

Link to post
Share on other sites

EDIT: Found the fix, it's ok - gotta change some settings in southbridge before AHCI works properly for all 6

Share this post

Link to post
Share on other sites

Hi All,


I am currently running BIOS version o41072911, what is the latest modified version available?

Could someone also let me know if there is any benefit to updating the BIOS?

I am running additional hard drives in the optical bay and I don't fancy playing with all the BIOS settings all over again if there is no real reason to update the BIOS.


Thank you

  • Like 1

Share this post

Link to post
Share on other sites

have you managed to remove the 8gb ram limit on this version?

Share this post

Link to post
Share on other sites


I've got an N40L at home with 16Gb in it...

Share this post

Link to post
Share on other sites

Its a N54L for some reason the bios says 8gb but windows is picking up the 16gb :S

Share this post

Link to post
Share on other sites

This links are not only not kept up to date but they are currently down.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Hey guys,
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
      Any help is greatly appreciated.
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.

  • Create New...