Jump to content
RESET Forums (homeservershow.com)
diehard

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

Louie

I just want to thank everyone for information on the BIOS update. I thought I had screw up when my nic was not working. Until I found this post and read threw all the post on here. I then found out I had to download a different rom file and BAMMM my network card started working once again. It had taken me almost 3 days trying to find some good information on this. 

 

Thank god there was google and this forum for pointing me in the right direction. 

 

Now I need to find out about memory upgrade and installing drives on my machine... lol... 

 

Just started playing with this mini server since I had it for about 1 yr... 

 

Thank you guys once again.

Share this post


Link to post
Share on other sites
ikon

Welcome to the forums Louie. I think you'll find this is a great, friendly community.

Share this post


Link to post
Share on other sites
gegenator

Hello everybody.

At first, i'm sorry for my verry poor English, but i'm French !

 

Well, i have a N40L since two years. It run very nice, but i want to install W8 on it.

But i discovered that not run with the originally bios...

 

But now, the new bios from HP that seems to correct this problem is only available with a warranty (mine have 2Y !).

 

Is anybody coold help me by giving me a provisory link to download the necessary ?

 

I'ill be verry prood to you.

 

Thanks.

Edited by gegenator

Share this post


Link to post
Share on other sites
adobo

We have discussed this many times. The N40L was only made for 8GB of RAM. Some have been successful getting 16GB to be recognized but others have had mixed results (like you). There is nothing to set to force it.

 

...does this bios version enable the hot-swappable hdd bays?

Share this post


Link to post
Share on other sites
Joe_Miner

While you can enable it in BIOS the hardware does not support hot-swappable

Share this post


Link to post
Share on other sites
jmwills

The thread that just keeps on giving!

Share this post


Link to post
Share on other sites
ikon

While you can enable it in BIOS the hardware does not support hot-swappable

 

Hence why it was hidden. I almost wish the modders had left this feature hidden.

Share this post


Link to post
Share on other sites
Joe_Miner

If you want to use the Port Multiplier drivers you will need to enable it in the BIOS even if the HW doesn't actually support it.  That's why you wouldn't want it hidden.

Share this post


Link to post
Share on other sites
AxlxA

Hi everyone, I'm brand new here. 

 

I just received my new N54L today and attempted to do the mod bios flash. 

 

The sequence was as described:

1) Booted up vanilla server with VGA LCD, usb keyboard/mouse --> Hit F10 and went into bios. Ver was O41. 

2) D/led and installed the flash tool. Extracted the modded bios with the lower case o41...., replaced the original on the usb. 

3) USB into server, booted up nicely and POST. See a bunch of random symbols going across screen, within a minute, I see c:\>. 

4) Removed USB

 

At this point, I shut down the server and started it back now. Now the trouble....

Server powers on with GREEN power button. No HP logo light. no video, no POST beep or anything. Fan still spinning at full speed. 

Powered off -> power on again same ordeal. 

Powered off and unplugged from power outlet -> change cmos jumpers to reset -> powered on, waited a few minutes -> powered off -> cmos jumpers back to normal

Now when plugging in the power cable, server powers on right away without me pressing power button. now HP LOGO flash blue once and turns a solid RED.

 

At this point, I redid my USB flash drive with original HP bios. Plugged it into server, powered on. still no video, no POST, waited 10 minutes with factory bios USB. 
Powered off and rebooted, still same no video, no POST, nothing's happening except fan spinning, HP logo red, power button green.

 

I even tried reseating ALL the plugs, and even switched the original RAM slots. Still stuck...

 

Please help?

(did not add any new PCIe, HDD, or any ram. The only thing that were ever plugged in were USB flash drive, USB keyboard/mouse, and VGA to LCD.

 

I'm very worried I have some major hardware fault and can't salvage this server.

Share this post


Link to post
Share on other sites
ikon

If you want to use the Port Multiplier drivers you will need to enable it in the BIOS even if the HW doesn't actually support it.  That's why you wouldn't want it hidden.

 

I'm a little confused. Are you saying the Port Multiplier feature is only available to be enabled if you first enable Hot Swapping?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • Phil Croxford
      By Phil Croxford
      Hi,
       
      Not sure if this is a taboo subject?? but delete if needed.
      I have bought a Gen 10 Micro Server for my home so i can run a Plex Server in house. i have all the drivers and updates that i need from the HP website
      but gone and noticed that the Bios update i need from what i can gather i need a contract? I'm not sure what to do?
      how do i get the bios update for this server?
       
      when i bought this server its running on 5.12 version with a build date of 05/25/2017 so my bios is well out of date.
       
      can any one guide me in the right direction to get the update?
       
      thanks
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
       
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
       
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
       
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
       
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.
       


×
×
  • Create New...