Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


diehard
 Share

Recommended Posts

hi guys! i was reading about a RED light flashing on the HP logo on bootup earlier in this thread and that it was a possible indicator of some serious problems

 

...well, I've got my n54l with the bios mod with Server 2012 essentials all up and running...I've got 16gb Crucial non-ECC Ram

running with it as well...I'm able to boot up and everything seems to be running well enough...was able to restore my drivepool from WHS 2011 no problem

...but this RED flash is freaking me out....do you think it could be the RAM causing issues? or something more serious

with the bios mod not working well or the power supply of the microserver?? any ideas would be much appreciated! Thanks!

Link to comment
Share on other sites

hmm...it went blue now...without swapping it out...do you think it was happening because I had the USB boot priority in the settings and it wasnt finding any since I had already installed the OS? just had keyboard and mouse plugged in...now i set the 250gb  hard drive as primary boot source...is there a memtest app which would let me test the RAM within 2012 Essentials?

there's no sign of the red light even when booting from being shut down.

Edited by techmuso
Link to comment
Share on other sites

Well, good news, sort of. Would be nice to know what the cause was.

 

As for RAM testing, I would recommend downloading MemTest86 and booting up with it, rather than trying to test RAM from within WSE2012.

Link to comment
Share on other sites

i flashed my n40l with the latest diehard bios and everything works fine.

But now my system says: 10240MB RAM? What happend?

With the stock bios i had 16GB RAM:
Iam using: 16GB Kingston ValueRAM DDR3-1333 ECC DIMM CL9 Dual Kit

 

Can anybody help?

Link to comment
Share on other sites

i only changed one module and leave the  original 2Gbyte Module in.

shame on me  :ph34r: delete my threads... :rolleyes: :rolleyes: :rolleyes: :rolleyes:

 

Glad you found the "problem" -- let us know how the 16G performs and when you get a chance introduce yourself http://homeservershow.com/forums/index.php?/topic/344-welcome-to-homeservershowcom-forums-introduce-yourself-here/page-11#entry58335

 

and let us know about your build.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
×
×
  • Create New...