Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


diehard
 Share

Recommended Posts

Yeah, glad it worked. The issue of USB flash drive makes & models has come up before. It's really important to find one that boots reliably.

Link to comment
Share on other sites

Good work!  I think we have discussed in this thread as well as some others, to use some brand name USB sticks when doing something like this.  It's a lesson we all learned by trial and error.

Link to comment
Share on other sites

Hey everyone.

 

Been reading all 17 pages and I've got to ask these two questions to clarify some fuzziness to what I've read so far.

 

I have an N54L for the past week.

  • Installed the Corsair Force 3, 60 gb, Sata III SSD on Sata 5 on the front of the board. Installed WHS 2011 with JM's Guide, which went perfect.
  • Installed the HP 250 Sata on bay 1, and 2x 2TB Seagates in bays 2-3.
  • Relocated all my files to those drives (350GB)
  • Drive Pool is installed.
  • Working Great.

Wanted to install a USB 3 card and perk up this OS on the SSD as it seems sluggish. That's all I need. No care for boosing eSata.  That's when I read bits and pieces of needing the modded Bios.

 

OK, so here's my questions:

  1. Bottom line- Since the OS is already installed, will modding the Bios and then changing the Sata setting to 3.0 GB's ruin my current WHS 2011 install?
  2. Will I have to remove all my data from the shared drives and reinstall the WHS OS so the AHCI drivers are installed too at the same time?

 

Most, not all of the bits and pieces have been discussed, but it's all broken up. There's not a step by step to cover just Sata III enablement portion from start to finish with Dos-Dont's, costs, pitfalls, benefits. To help with those that don't enherently know about AHCI configuration.  So, I thought it best to ask first rather than get into trouble later with a hosed OS.

 

Pretty experienced with building PC's,modding and WHS V1, but this one's new territory for me. I ain't ascared. ;-)

 

Thanks, Guys!

Link to comment
Share on other sites

LOL, I had to read your post twice. At first I read it to mean you want to install a USB3 card to boost SSD performance. I went, "say what?" :)

 

AFAIK, you can flash the mod BIOS and change the onboard SATA port to 3 Gbps without losing anything. IIRC, I flashed the BIOS back and forth a couple of times on the N40L I configured and it still booted OK. Whatever, you do, I really urge you to have plenty of backup.

 

Joe_Miner, please chime in.

Link to comment
Share on other sites

LOL, I had to read your post twice. At first I read it to mean you want to install a USB3 card to boost SSD performance. I went, "say what?" :)

 

LOL, I see what you mean by the way I wrote it.

 

I read 3-4 pages back JMinor mentioned about AHCI drivers need intalled during the OS install or after via a registry hack so it boots again. But, it was convoluted and I could not tell what portion of it was dependant upon the SATA 3gb or the eSata speed up or both.

 

I figured that flashing the bios and making basic changes would not affect an installed OS. Heck, I've updated many bios', but this ACHI and Sata 3gb switching is new to me and one or both may affect an installed OS.

 

Yeah, I've got a 2.5 Inch Sata II drive I just plug into the last bay to slurp my measly 350 gb off the WHS. It's how I got it on quickly. ;-)

 

Thanks.  

Edited by judgeschambers
Link to comment
Share on other sites

I have done the AHCI switch after the OS is installed a few times. It's really not hard IMHO.

 

First, boot WHS2011 normally.

 

Next, make a change to the registry:

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci]
"Start"=dword:00000000

 

Exit the registry editor.

Reboot and go into the BIOS (do NOT let Windows start!).

Change the SATA setting to AHCI.

Save the settings and boot up.

That should be it (I hope I haven't forgotten anything).

 

Can anyone else confirm?

Link to comment
Share on other sites

You're spot on as usual.  The only comment I would add is to be very careful in your planning if you are going to use a 60 gig SSD for a server OS.  Sure you "can" do it, but with prices as low as they are, give the OS some room to "breathe" if this is a production machine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
×
×
  • Create New...