Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


diehard
 Share

Recommended Posts

Thanks Joe for prompt reply.

 

Flashing was successful since I can see all the "unlocked" features and all are set as per instructions.

 

Boot order was/is correct. I have tried with SSD connected to ODD port (now AHCI) - did not work. System simply does not see that drive as bootable (event hough it was working before flashing).

 

Tried using old, factory disk which has Win 7 installed and was working prior to SSD swap. It does not matter if I plug in this one into the original SATA slot or ODD system still does not think it is bootable drive and goes and tries PXE boot resulting in PXE-E61 error.

 

Checked all cables and they look OK to me.

 

At the end of the day I will install Win 7 again (only if I really have to) but my confusion comes from the fact that:

 

1. Flashing was successful

2. All BIOS settings are correct, checked many times

3. Both disks (SSD and SATA) suddenly are not bootable. This is the most confusing since original disk was just unplugged and sitting on the desk while flashing the BIOS.

BIOS can see them but can't find OS on them - so registry hack is not possible since I can't get to OS.

4. Tried SATA cable that came with Intel SSD and some other SATA cables boys gave me at work to try them so the cables have been used daily and suppose to be tested very well.

5. And finally, after flashing I always have to reboot twice. First time always stuck on Checking USB configuration... ??

 

PS: I tried to lower USB priority - it was on high but no luck with either settings so I did reset it back to default. I also tried Onchip IDE with both settings: Legacy IDE and IDE only but no luck.

 

Thanks again, really appreciate your time.

 

Lopatni

Link to comment
Share on other sites

Hi,

 

Please disregard my previous post. The problem was between chair and computer. All good. SATA enabled on all ports and flashing was successful from the start it was just me forgetting "minor" things that caused all the trouble. It was busy week at work but I should have remembered that I already formatted old disk to be reused for VMs so my apology for wasting your time. :(

 

All in all the instructions are spot on and working like a charm. Thanks again for all your instructions and assistance. :)

 

Regards

 

Lopatni

Link to comment
Share on other sites

Lopatni:

 

LOL, Glad you found the problem. When you get the chance be sure to introduce yourself http://homeservershow.com/forums/index.php?/topic/344-welcome-to-homeservershowcom-forums-introduce-yourself-here/

 

Feel free to keep asking questions and don't hesitate to jump in on discussions in other threads -- that's how we all learn and have fun!

 

Joe

Link to comment
Share on other sites

  • 4 weeks later...

Instructions on installing hacked BIOS (wherever the copy initially originated from) are all over the internet and ardent users are implying that one really must install it to get "full-speed" from their server.

 

I agree that IDE (ie. PATA) emulation on SATA ports is now redundant (- all curent OSs have built-in SATA drivers and can boot off such drives); hence there's no practical use for a feature to combine two physical SATA ports (one for a IDE Master, other IDE Slave) to emulate a single logical IDE port.

 

However, what does one pratically gain from (disabling PATA emulation and) enabling using SATA ports:

0. SATAII port speed;

1. NCQ; and

2. "SATA-removeable drive" options (permitting port multiplier function)?

 

Physical IDE port are limited to (theoretical) 133MB/s. SATA ports are limited to (SATAII) 3Gb/s (theoretical, 384MB/s). This sounds like a gain, but what spinning hard-drive can handle SATAII speeds? (I am not even sure that IDE emulation does limit speeds to that of a physical IDE Port specification - it wouldn't make sense to do so).

 

NCQ is used to re-order disk requests based on minimum transition of the head from current location - mainly when drive receives numerous requests in short time - something that RAID logic should not be doing.

 

Port multiplier function is dependent on eSATA physical specifiications - operates at 1.5Gb/s which is then shared among
multiple connected disks; and even with hacked BIOS, eSATA port only implements less efficiant Command-Based Switching (CBS, in comparison to Frame-Based Switching (FBS)). Not a performance enhancement.

 

Lastly, in a NAS/SAN RAID scenario, one would be limitted by the NIC speeds. A populated RAID, even with LAG of 2 NICs will limit effective throughput more than IDE speeds.

 

I'd like someone to crush this thesis - using before and after hacked BIOS installation disk speed improvements, as solid evidence - but until this, I say that installing hacked BIOS is not  a "must do" activity and in practice, serves almost no purpose.

Edited by AlexF
Link to comment
Share on other sites

Well, I can say for sure that SATA II spinning drives do have better performance on SATA II ports than on SATA I ports. And SATA III spinning drives have even better performance on SATA II ports than SATA II drives do. Whatever the theoretical limits, the real-world performance can be measured. They may not be operating at the theoretical maximum, but it is better than it would be otherwise. That makes the mod-BIOS worthwhile in many situations. Is it a 'must'? No. Is it highly recommended? Yes.

Link to comment
Share on other sites

Whatever the theoretical limits, the real-world performance can be measured.

 

As per Anandtech testing of WD Red (http://www.anandtech.com/Gallery/Album/2223#1) avarage Read speed of that drive is 110MB/s - this is within physical IDE port capability.

 

As I wrote above, I don't see why (logical) IDE emulation would be limitted to physical IDE port speeds - the physical port is still SATA - just that IDE (ATA) control commands are used instead of SATA.

Edited by AlexF
Link to comment
Share on other sites

Except that no standard ever operates at its max rate - those rates are achieved only in test bench situations. So, I strongly suspect a WD Red would, in reality, be hampered by an IDE port. What I do know for sure is a Red operates better on SATA II than on SATA I, and even better on SATA III. So, regardless of the specification, the real-world results speak for themselves.

 

I'm wondering why you would want to use IDE for SATA drives at all. What is it about the command set that is so appealing?

Link to comment
Share on other sites

I'm wondering why you would want to use IDE for SATA drives at all. What is it about the command set that is so appealing?

 

The issue isn't about IDE drives - Microserver doesn't support them through SAS backplane (also, no point in discussing SATAI or SATAIII since we know the backplane is SATAII).

The issue is whether IDE emulation hampers performance (on physical SATAII port) - if doesn't, then, this adds to the weight of my thesis (of which port speeds is only one) that there's no practical reason to install the hacked BIOS.

Edited by AlexF
Link to comment
Share on other sites

So, your contention is that the drives would perform as well using IDE Emulation on the stock BIOS as they would running at SATA II on the mod-BIOS?

Link to comment
Share on other sites

Yes, for all (practical) intent and purpose of MicroServer, installing hacked BIOS is unnecessary.

Edited by AlexF
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
×
×
  • Create New...