Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


diehard
 Share

Recommended Posts

Thank you for your answers!

 

@Joe_Miner: I want to use the modified BIOS in order to be able to use SATA port which originally was used by the ODD for my SSD drive. I also need to use the E-SATA port on the back for my ODD. Thank you for clarifying that the modified BIOS won't support the SATA controller mode to be set to RAID.

 

@ikon: Good information that AHCI is formatting the drives in a certain way, which makes the system unbootable if I switch to RAID.

 

@jmwills: I have no intentions to run the OS on RAID. I have installed the OS on my SSD disk, but I do want to run RAID on my four drives located in the 4-bay drive beneath the SSD and ODD.

 

I guess this means that I have to stick to software RAID in the OS, if I want to run OS on my SSD, run the ODD in the E-SATA/SATA port on the back and use RAID on my four drives in the 4-bay drive.

 

/Micco

Link to comment
Share on other sites

Hi guys,

 

I've been trying to flash the bios on my N40L and follwed all the instructions above but after booting with the USB with modded bios on in the USB slot I get a o4107... rom does not exist message. Any ideas?

 

Thanks

Link to comment
Share on other sites

Hi guys,

 

I've been trying to flash the bios on my N40L and follwed all the instructions above but after booting with the USB with modded bios on in the USB slot I get a o4107... rom does not exist message. Any ideas?

 

Thanks

 

My guess is: Apparently, when Flash.Bat executes it’s not finding the BIOS file o41072911.rom that you were to copy from BIOS-MODS onto the USB Key replacing HP’s stock BIOS file O41072911.rom => Note that both files begin with the letter o (oh) or O (capital oh) and NOT the number 0 (zero).

 

Check out the latest version of the instructions at HP ProLiant N40L MicroServer Build and BIOS Modification Revisited for more detail.

Link to comment
Share on other sites

After much looking I decide to get a N40L with 4GB memory and no HDD

It arrived but along with the 4Gb it had a DVD writer installed,

 

I replaced this with an Icybox IB-2226StS 2x 2.5-inch SATA Mobile Rack in a 3.5 inch Hard Drive to 5.25 inch Front Bay Bracket Adapter I had lying about, and installes a PEXSATA22I PCIe 2 port sata card.

 

I also have a Startech eSATA USB DUAL SATA HARD DRIVE ENCLOSURE S252U2ERR, with 2 x 2.5 drives and this is hooked up to the eSATA port to give me working multiport access.

 

A Samsung MMCRE28G8MXP-0VB 128 Gb SSD & 2 x 2Tb WD greens (from an old NAS unit) complete the build.

 

Before installing any drives I flashed the BIOS using DieHard's Link. After successfully flashing the BIOS and changing the settings and loading Win7 on the Samsung

 

Plugging in the S252U2ERR to the eSata port and both drives showed up proving that the port multiplier is working. All drives show as "Hot Swap" including the Samsung.

 

One of the 2Tb Greens failed and was RMA'd, WD sent back a new 3Tb one, Everything is up and running and I can drop my 2.5" drives into the cradles and copy the data from them on to the 2 x 3.5 " drives. Will post transfer rates in my next post

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
×
×
  • Create New...