Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


Recommended Posts

Hi!

Trying to flash (in a good way), and I cant seemt to get the exact files as Joe (thanks by the way - http://homeservershow.com/forums/index.php?/topic/3397-modified-bios-for-microserver-n40l-enables-hidden-features/page__st__100#entry45899), maybe the flashing tool/files have been updated?

 

Any ideas.. ? :)

 

 

Directory of G:\

 

27/12/2012 04:35 AM 108 AUTOEXEC.BAT

27/12/2012 04:35 AM 66,785 COMMAND.COM

27/12/2012 04:35 AM 24,810 IBMBIO.COM

27/12/2012 04:35 AM 30,880 IBMDOS.COM

27/12/2012 04:35 AM 512 fat32lba.bss

27/12/2012 04:35 AM 45,341 kernel.sys

08/05/2006 02:44 PM 2,973 logo.gif

22/08/2011 10:38 AM 2,803 README.1ST

22/08/2011 10:39 AM 4,930 rev_hist.txt

25/08/2011 08:42 AM 31,926 start.htm

27/12/2012 04:35 AM 79 syslinux.cfg

11 File(s) 211,147 bytes

0 Dir(s) 32,700,366,848 bytes free

 

Thanks guys & Merry Christmas!

Link to post
Share on other sites
  • Replies 557
  • Created
  • Last Reply

Top Posters In This Topic

  • ikon

    119

  • Joe_Miner

    62

  • jmwills

    46

  • cskenney

    24

Top Posters In This Topic

Popular Posts

Hi Anttech,   I had the same issue and couldn't download it from the german site.   I found a mirror at the following address :   http://translate.google.com/translate?sl=auto&tl=en&js=n

Well I upped it to my dropbox. Please serve yourselves.   https://www.dropbox.com/s/qff7abgmt7hau6z/O41100113.ZIP Well I upped it to my dropbox. Please serve yourselves.   https://www.dropbox.co

Here are the two original versions that I have now posted in dropbox   http://www.dropbox.com/s/u6r1ogp2gt7ju1c/SP64420.exe?dl=0 http://www.dropbox.com/s/m1sisxxaa0oszoc/SP54344.exe?dl=0

Posted Images

Forgive me if I've forgotten the thrust of this thread, but you are talking about a USB thumb drive, right? If so, I'd bet money it's the brand/model of thumb drive that's the problem. Some of them are much more 'bootable' than others.

Link to post
Share on other sites

I'm a little late to this thread, and posted a message to Joe Miner's great article on Storage Spaces on an HP Proliant N40L, which he kindly rersponded to. I figured I would continue the conversation on a forum and picked this one! I appologize if this isn't the place.

 

Sarkrueger asked;

Joe, I pretty much built a system just like described. I flashed the BIOS via Diehard and installed windows 8 on an SSD drive on port 5, and have a 3.0 TB drive in port 4 in the icy dock. Both show up in the BIOS. I changed the SouthBridge settings as per described and for some reason the 4 3.0 TB Seagate drives in the internal drive bays, don't show up in the BIOS or under manage, drives in Windows. Any thoughts on what I might be missing? Thanks!

 

Joe Miner responded; Hi Scott! I had the same problem once -- it turned out that I hadn't fully seated my SAS connector that's attached to the 4 drives in the main drive bays on the MB. If you're getting power to the drives (you should be able to hear them spin up when you turn it on) then the SAS connector would be my guess.

 

I just wondered if I messed something up, and whether anyone has has the same issue that they weren't able to recover from. I seemed to have fully pressed down/reattached the 4-bay-SATA connector to the HD several times. I noticed it doesn't "click" into place. Restarted from no powere etc, etc. Still, the drive aren't recognized. Maybe I damaged the cable. Weird. Brand new N40L.

 

Scott Krueger

Link to post
Share on other sites

Sarkrueger - Someone else posted something very similar to what you are describing. They could boot just fine off the SATA port on the MB put their drive would not show up in any of the 4 HDD slots. I believe they identified a damaged SAS connector and had to send it back to HP.

 

Did the system ever recognize a drive in one of the HDD slots? Have you removed the SAS connector and examined it to see if anything looks unusual? Are all the other connectors seated properly on their mating connectors (nothing off by a row?).

 

You also mentioned port 4 in the icy dock. Did you install the ICY dock Hot Swap drive caddy and connect your 3.5" drive to the eSATA port?

 

Finally, you state that you changed the bios settings and the 4 drives don't show up. Did they show up before you changed the BIOS?

Link to post
Share on other sites

Well, sometimes it helps to just fling your issues out there to get them solved. The problem was that the left guide tab on the mini-SAS cable was sliding into the connector on the MB. The MB female receptor inside the silver guide on the MB was offset to the left. I probably messed that up due to many re-connects trying to get it to connect. After some realignment (ie-accidently breaking off the left guide on the connector), the min-SAS cable seated and all it good!! All 6 drives are recognized, (4-Seagate 3.0 TB 7200 RPM drives in the internal cages, 1-Seagate 3.0 TB 7200 drive in the icy dock and a 256 Crucial m4 SSD (Windows 8-64) boot drive in the icy dock. What a great set-up! Thanks for all the great info posts!

Link to post
Share on other sites

Good to hear you got it figured out.

 

Make sure you participate here in the forums and tell us what you are planning to do with your box. I think you are one of the few people who have mentioned running Windows 8 on their Microserver.

Link to post
Share on other sites
Marcel_Dutch

Hi there ! Houston we have a problem.....

First of all greetings from the Netherands. :)

 

I followed the steps to modify the BIOS but as result 'a dead HP Microserver'.

I created the usb flash boot disk and copied the .ROM file to it.

 

Started the machine without any disks accept the SDD at the ODD port.

The usb flash disk booted and re-writed the BIOS.

After reboot i don't get anything anymore at my screen.

:(

 

Help.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny

×
×
  • Create New...