Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


Recommended Posts

Note: I have discovered that, if you have an HP Smart Array P410 hardware RAID controller and disable SATA IDE Combined mode within this BIOS, the Microserver will suddenly fail to see your RAID controller. It will no longer show when booting, and the array will not be visible. The controller will no longer show as a Hard Drive option in the BIOS, so you will no longer be able to use it until you enable SATA IDE Combined mode again.


I would assume this also applies to P212 and P411 controllers, and possibly others.

Link to comment
Share on other sites

Hi there. Since a week or so I have the N40L, and I'm really happy with it already.

I'm using the modded BIOS, and everything seems to be working OK-ish, but there's one thing that's nagging me : all the disks are active in UDMA Mode 6 (or even UDMA Mode 2), and not in SATAII mode.


OS: Windows Server 2012

Original 250GB drive in the ODD bay, as bootdrive, connected to the ODD SATA port.

3 x 2TB Samsung Spinpoint F4 EG + 1 x 1.5TB Samsung Spinpoint F4 EG in the 4-bay enclosure.

Exampe below, one of the 2TB disks ; it shows "Supported: UDMA Mode 6" but also "Active: UDMA Mode 2".




I'm using the default MS drivers....is that the issue?

Link to comment
Share on other sites

I'm not familiar with HD Tune (heard of it; don't use it), but I already see some odd things with that screenshot. For example, it says the average speed is 95 MB/sec yet also says the Active mode is UDMA 2. That doesn't make sense because UDMA 2 has a maximum rate of 33 MB/sec.


Have you actually done any tests to see how fast data is writing and reading? That is the only true measure of performance.


Also, are you using Storage Spaces? pcdoc has done a bunch of testing and posted results that indicate SS has less than stellar performance, especially when data is being written.

Link to comment
Share on other sites

That was also pretty confusing to me ; I'm getting read/write speeds way outside the specs of UDMA Mode 2.

However, it does look like something isn't quite alright.

Using ATTO I've benchmarked the disks.

Port 0,1,2 have a Samsung 2TB F4 in it.

Port 3 has a Samsung 1.5TB F4 in it.

Port 4 has the standard 250GB disk in it.


Port 0, ~100 MB/sec

Port 1, ~133 MB/sec

Port 2, ~79 MB/sec

Port 3, ~92 MB/sec

Port 4, ~108 MB/sec.

I'm confused....the first three results are from the exact same type of disks...

Screenshots attached.

atto_samsung_2tb_sata_port0.png atto_samsung_2tb_sata_port1.png atto_samsung_2tb_sata_port2.png atto_samsung_2tb_sata_port3.png atto_samsung_2tb_sata_port4.png


BTW, I'm not using storage spaces ; they're configured as seperate disks, nothing special.

I'm going to check all the wiring inside the N40L, and make sure the SATA connectors on the disks are clean.

Also, I'm going to swap the disks, so make sure it's not the disk itself that is having trouble.

I'll post the results later today or tomorrow.

Edited by MarcelG
Link to comment
Share on other sites

Mmmm, the plot thickens.

Switching the disk in port 0 with the disk in port 1 gives some unexpected results.

Before: 0 = 100, 1 = 133.

After: 0 = 105, 1 = 105

Switched it all back. so now back2=before...but the readings are 0=100, 1=78.



I'm going to install the HP drivers....let's hope that makes the readings more stable.

Link to comment
Share on other sites

The HP/AMD drivers didn't work.... After I installed them the benchmarks dropped to write speeds of 80 kb/sec, up to a staggering 30 MB/sec. Read speeds where not affected.

Real life benchmarks showed writespeeds of up to 380 MB/sec....plus disk activity well after the copy was complete. (Awful write caching implementation)

After 10 copies or so, the real life write speeds dropped to below 1 megabyte per second.

I uninstalled those drivers and reverted to the standard Microsoft AHCI drivers.

Performance is as it was before, but SMART is now reporting issues with 3 of the 5 disks (Ultra dma crc error count on one, unstable sectors on another and calibration retry count warnings on the third). :blink:

I'm now trying to get my data of those puppies, off to other disks, to see what I can do about it.


So, that's the current status. Not what I expected.

One thing is certain: I've got a chore for the holiday season. ;)

Link to comment
Share on other sites

Well, I guess it was one disk that was the culprit ; it's going back to Samsung/Seagate. Just packaged it and filled out the RMA stuff...

Link to comment
Share on other sites

The thumb drive I setup today, even with the glitches, appears to have all the proper files on it, and are all the proper size comparing them to Joe's screenshot.


But I will still track down another drive, since I would like another anyway, and see if there is a difference while running the HP setup program. Only when I feel totally comfortable will I stick in a thumb drive and give it a shot. Thanks for all the help guys.


I decided to just go for it...and it worked. Thanks again for all the past posts that helped me with this. Thanks Joe for your posts.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
      Any help is greatly appreciated.
      Cheers Benny
  • Create New...