Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features


Recommended Posts

Yeah probably a good idea. The thumb drive I used was a LACIE 4gb. I did a full FAT32 format, not quick.


I read through just now and found that this guy had the same thing as me: http://homeservershow.com/forums/index.php?/topic/3397-modified-bios-for-microserver-n40l-enables-hidden-features/page__st__100#entry45887


I currently only have this one thumb. Guess I should track down another brand an see what happens.

Edited by g725s
Link to comment
Share on other sites

The thumb drive I setup today, even with the glitches, appears to have all the proper files on it, and are all the proper size comparing them to Joe's screenshot.


But I will still track down another drive, since I would like another anyway, and see if there is a difference while running the HP setup program. Only when I feel totally comfortable will I stick in a thumb drive and give it a shot. Thanks for all the help guys.

Link to comment
Share on other sites

I would try booting a system from the USB stick, just to be sure it is bootable. That seems to be the main area where the process fails. I think I posted earlier that I've had very good success with the Kingston Datatraveller 101 units.

Link to comment
Share on other sites

Hello All,

I have been reading about the modded bios for the HP N40L, from what im reading the AHCI functionality can dramatically improve the performance your your raid.

My current configuration is a MDADM Raid 5 using OpenMediaVault, will this pose any issue for the existing mdadm raid or the existing installation of OMV?


Thank you



Link to comment
Share on other sites

Have no idea what MDADM is?


MDADM is a linux software raid


I installed the modded bios, im getting about 58 MB/s write to the raid. Not sure if this is good or bad tbh.

One thing i noticed when the system turns on now i heard the HDDs start up and they make a different sound then b4



Link to comment
Share on other sites

it Looks like all ports 0-5 are set for AHCI in the Advanced Menu -- does that sound right?


yes, if your installing WHS2011 set that to AHCI, if your installing WHSv1 set it to IDE or else the server will continously reboot.


I set the option of setting AHCI speed to Auto, 1.5, & 3 to 3, I don't have any sloweer drives, looks like no support for 6GB/sec


Has the AHCI problem been solved? I am running Ubuntu Server & if I select AHCI in the BIOS it just gives me a blank screen at boot-up. Switched it to IDE & its working. I have an SSD for the OS & software drive which I plugged into the SATA on the mobo (no 5) & I did this BIOS update to get AHCI working but... BTW thanks for this thread which lead me to flashing with this hacked BIOS. Has unopened some good hidden things, it looks like :-)

Link to comment
Share on other sites

I think from what I have read in this thread is that AHCI runs on the RAID controller... It looks like I can't get it to run from no 5 sata port. It would be nice to get it running on my SSD but...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
      Any help is greatly appreciated.
      Cheers Benny
  • Create New...