Jump to content
RESET Forums (homeservershow.com)
diehard

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

ikon

I think one of the issues is that multi-port capability has to start with the eSATA chipset. If it doesn't have multi-port built in then it just can't happen, no matter what the BIOS. I would go with a SiL3132 card; mine has worked really well.

Share this post


Link to post
Share on other sites
libouk

Help ! my friends ! the french newbie I am made a big mistake with this new bios, so that I cannot have any graphic card available (the onboard one neither the ATI 5450 i have been inserting in the pci slot).

The only option i can see to put everything back in place is to restore the bios default settings.

Can anyone help me to know what sequence i have to press so that i could restore the bios defaults ?? F10 for bios and then ?? f9 ??

please.

Another question: i didn't succeed in putting the onboard 1GB NIC card available, i don't have any gigabit switch, can't i connect my french orange box (livebox 10/100 Mbit ports) directly on my onboard proliant's N40L gigabit card ???

 

you see, i am on a bad road to succeed withou you.

Thanks for all

Share this post


Link to post
Share on other sites
texasPI

Ok guys, after all this time, I have decided to flash the bios on my N40L. I'm having a major problem with creating a USB key. I've downloaded everything from links in this thread but when I use the HP tool to format the flash drive, when it completes there are several files on the flash drive that should not be there. Stuff like PDFs and other random things from my computer.

 

I've formatted the drive several times, tried different computers and different flash drives but the HP tool still places all these weird files once it completes.

Share this post


Link to post
Share on other sites
ikon

I have found over the years that different makes/models of USB flash drives respond quite differently. For example, I've had some USB flash drives that work well with the MS Win7 DVD Download Tool and others that wouldn't at all. I would try some other flash drives.

Share this post


Link to post
Share on other sites
Joe_Miner

Please check out the latest Step-By-Step Guide in HP ProLiant N40L MicroServer Build and BIOS Modification Revisited edited 2-3-2013

 

 

From my posting to MediaBiz at http://homeserversho...-options-setup/ -- part has been snipped out and copied below.............................

 

For instance, the 4th link on the “More Interesting MicroServer Links” page is titled ROM Firmware Upgrade from HP

At that page on HP’s website download the file SP54344.exe to your laptop or desktop and follow HP’s instructions to create a USB that can flash your BIOS.

 

 

 

 

 

 

 

USB Key - HPQUSB.exe is a Windows-based utility to locally partition, format and copy necessary files to a USB flash media device (e.g. HP Drive Key) through the Windows environment. The created USB flash media device is made bootable and ready to locally restore and/or update the firmware on the system.

1. Obtain a formatted USB Key media.

2. Download the SoftPaq to a directory on a system running Microsoft Windows 2000, Microsoft Windows XP, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows Server 2003, Microsoft Windows Server 2008, or Microsoft Windows Server 2008 R2 and change to that directory.

3. From that drive and directory, execute the downloaded SoftPaq file: Simply double click on the SPxxxxx.exe file and follow the installation wizard to complete the SoftPaq installation process. At the end of a successful installation of the SoftPaq a web page will automatically appear to provide you with the different methods for restoring and/or upgrading the firmware on the system.

4. After the USB Key is created, you may delete the downloaded file if you wish.

5. Insert this USB Key into the USB Key port of the system to be updated and power the system on to boot to the USB Key.

 

If you followed HP’s instructions (above) now you would be re-installing the factory BIOS currently on your N40L. This may be handy to have on a spare USB stick. Now create another USB stick with the Factory BIOS installed on it.

 

If you look at the USB stick you just created with Windows Explorer you’ll see (if you don't get these 11 files you may need to re-install the HP program):

 

 

fat32lba.bss

Flash.bat

IBMBIO.COM

IBMDOS.COM

Kbd.exe

kernel.sys

O41072911.ROM

Readme.1st

Readme.txt

Rev_hist.ext

syslinux.cfg

 

gallery_1229_27_9649.jpg

 

To flash the MOD BIOS you could use DieHard’s Link and in post #5 of that thread Camiloml has a link to the zipped file o41072911mod.rar

o41072911mod.rar is what you want. Un-zip it with Winzip or some other SW package and you’ll have the file o41072911mod.rom thanks to the hard work of the people at BIOS-MODS!

 

Rename o41072911mod.rom to o41072911.rom and replace the file O41072911.ROM on your USB stick created by HP with o41072911.rom – (IMPORTANT: the ROM file begins with the letter Oh NOT the number Zero – this is where many screw up and crash and burn)

 

Now, with your USB stick with the MOD ROM file replacing the Stock/factory BIOS ROM (notice the file names were the same and they are the same size) you can flash your BIOS per HP’s instructions

 

When I did it I removed all hard drives from my MicroServer – inserted the USB stick and turned the MicroServer on.

 

The MicroServer does it’s thing and takes you to a C:\ prompt.

 

Reboot and hit F10 to get into your new BIOS and make the changes outlined elsewhere in the Forums to speed up all your ports.

 

I created the Flash drive on a Win 7 pro Machine --

 

 

Before Flashing your BIOS check these Documents:

HP Support Document – Advisory: HP MicroServer G7 – System May Fail to Boot After Updating the System BIOS

HP Support Document – Notice: HP ProLiant MicroServer – BIOS RECOVERY KEY CREATION RECOMMENDED to Prevent Loss of System BIOS if Server Unexpectedly Encounters Any BIOS Corruption ISSUES – Best Practice

 

Troubleshoot a Problem <== HP Trouble Shooting Guide

 

Also read Messages #241 and #242for a detailed description of what happens during the BIOS Flash!

Edited by Joe_Miner

Share this post


Link to post
Share on other sites
texasPI

Thanks for the help. I got it sorted out after I posted but there was definitely something strange with my flash drives that kept me from making it work initially.

Share this post


Link to post
Share on other sites
ikon

Thanks for the help. I got it sorted out after I posted but there was definitely something strange with my flash drives that kept me from making it work initially.

 

Yep, they're definitely not all created equal, especially the U3 variety.

Share this post


Link to post
Share on other sites
texasPI

To complicate matters, all the flash drives I have are all the same type. I bought a Sandisk 4-pack sometime ago. I had to ask a neighbor to borrow one. :blink:

 

TapTap

Share this post


Link to post
Share on other sites
ikon

That's interesting. I have found Sandisk to be one of the better brands overall but, obviously, even they make some that don't work as bootables very well. FWIW, the Kingston 16GB DT101G2 seem to be good.

Share this post


Link to post
Share on other sites
texasPI

Yes, I've never had issues with Sandisk drives but I've ordered a Lexar and Kingston to have some variety. I actually have a Kingston plugged into my car radio that I forgot about. Its been there about two years playing back music without issue.

 

TapTap

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
       
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_13916b9b87d642bc91029439b8&swEnvOid=4184
       
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
       
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      None
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
      None
    • Phil Croxford
      By Phil Croxford
      Hi,
       
      Not sure if this is a taboo subject?? but delete if needed.
      I have bought a Gen 10 Micro Server for my home so i can run a Plex Server in house. i have all the drivers and updates that i need from the HP website
      but gone and noticed that the Bios update i need from what i can gather i need a contract? I'm not sure what to do?
      how do i get the bios update for this server?
       
      when i bought this server its running on 5.12 version with a build date of 05/25/2017 so my bios is well out of date.
       
      can any one guide me in the right direction to get the update?
       
      thanks
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
       
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
       
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
       
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
       
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.
       


×
×
  • Create New...