Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

hp bios are trash

Again, sorry I'm new here... How do I locate these post?

Also thanks a bunch for the prompt advice

Share this post

Link to post
Share on other sites

This topic is specifically about the Bios for the HP Microserver. What you are asking about is the Bios on another machine.


I would recommend you investigate the web site Bios Mods. That is the site that has the modified Bios that everyone here is using for their microserver.


You can also follow @TheWizBM on Twitter and send him your questions. He is also associated withe the Bios Mods site.

Share this post

Link to post
Share on other sites
hp bios are trash

Thanks man... SORRY for the inaccurate post.

Share this post

Link to post
Share on other sites

Hi everyone,


My name is Michael and i need your help.


I though i had read everything i need to flash my bios on my Hp n40l


Unfortunantly it stuffed up!!!


it is now bricked and dont know what to do.


it will power up with a short red light and then nothing. No screen


Can i do anything to get it fixed??


your help will be greatly appreciated

Share this post

Link to post
Share on other sites

hello all, just a question in regards to bios flashing.


I followed diehards post in regards to flashing the bios. and i kept getting "RomPaq may take a few minutes to get started, please be patient... Command or filename not recognized".


thought it may have something to do with

but replace and rename the BIOS bin file with the one from BIOS-MODS.




what am i doing wrong?


Share this post

Link to post
Share on other sites

The instructions here are confusing (I don't see a Bios.bin etc) but I figured it out using my own trial and error method. Here's what I did.


1) Run HPQUSB.exe in windows to create a bootable USB stick

2) Browse the USB drive and delete everything EXCEPT command.com

3) Download flash.zip from:


4) Extract flash.zip, and copy all files onto the root of your flash drive

5) Boot from the USB drive on your Microserver

6) Hit enter, enter, enter when it asks for the time date etc.

7) Once you see the command promt, type FLASH

8) Hit Enter, you'll see it write the new Bios VERY quickly and will return to command prompt.

9) That's it! Reboot the server, hit F10 and you'll see all the new wonderful option.


Here are the best set of over all instructions on what the MicroServer is capable of and how to set it up.



The following accessory made it MUCH easier to install a 2.5" & 3.5" hard drive into the ODD bay though.


CY DOCK MB971SP-B 1Bay DuoSwap 5.25inch Hot Swap 2.5/3.5inch SATA DOCK Storage



Edited by JazJon

Share this post

Link to post
Share on other sites

Getting ready to move my N40L over to Server 2012 Essentials, and just wondered whether this BIOS mod is still relevant or has it been superseded by a later HP or modded BIOS?

Share this post

Link to post
Share on other sites

If you are running with the modded BIOS, I'd just let it be.

Share this post

Link to post
Share on other sites

Has anyone found a setting in the modded BIOS to get the eSATA port multiplier to see more than one drive in an external multi-drive eSATA box?


Share this post

Link to post
Share on other sites

Has anyone found a setting in the modded BIOS to get the eSATA port multiplier to see more than one drive in an external multi-drive eSATA box?



Not possible just buy a card. Search amazon for SiL3132

Edited by JazJon

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
    • Phil Croxford
      By Phil Croxford
      Not sure if this is a taboo subject?? but delete if needed.
      I have bought a Gen 10 Micro Server for my home so i can run a Plex Server in house. i have all the drivers and updates that i need from the HP website
      but gone and noticed that the Bios update i need from what i can gather i need a contract? I'm not sure what to do?
      how do i get the bios update for this server?
      when i bought this server its running on 5.12 version with a build date of 05/25/2017 so my bios is well out of date.
      can any one guide me in the right direction to get the update?
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
      Any help is greatly appreciated.
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.

  • Create New...