Jump to content
RESET Forums (homeservershow.com)

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

hp bios are trash

Again, sorry I'm new here... How do I locate these post?

Also thanks a bunch for the prompt advice

Link to post
Share on other sites
  • Replies 557
  • Created
  • Last Reply

Top Posters In This Topic

  • ikon


  • Joe_Miner


  • jmwills


  • cskenney


Top Posters In This Topic

Popular Posts

Hi Anttech,   I had the same issue and couldn't download it from the german site.   I found a mirror at the following address :   http://translate.google.com/translate?sl=auto&tl=en&js=n

Well I upped it to my dropbox. Please serve yourselves.   https://www.dropbox.com/s/qff7abgmt7hau6z/O41100113.ZIP Well I upped it to my dropbox. Please serve yourselves.   https://www.dropbox.co

Here are the two original versions that I have now posted in dropbox   http://www.dropbox.com/s/u6r1ogp2gt7ju1c/SP64420.exe?dl=0 http://www.dropbox.com/s/m1sisxxaa0oszoc/SP54344.exe?dl=0

Posted Images


This topic is specifically about the Bios for the HP Microserver. What you are asking about is the Bios on another machine.


I would recommend you investigate the web site Bios Mods. That is the site that has the modified Bios that everyone here is using for their microserver.


You can also follow @TheWizBM on Twitter and send him your questions. He is also associated withe the Bios Mods site.

Link to post
Share on other sites

Hi everyone,


My name is Michael and i need your help.


I though i had read everything i need to flash my bios on my Hp n40l


Unfortunantly it stuffed up!!!


it is now bricked and dont know what to do.


it will power up with a short red light and then nothing. No screen


Can i do anything to get it fixed??


your help will be greatly appreciated

Link to post
Share on other sites

hello all, just a question in regards to bios flashing.


I followed diehards post in regards to flashing the bios. and i kept getting "RomPaq may take a few minutes to get started, please be patient... Command or filename not recognized".


thought it may have something to do with

but replace and rename the BIOS bin file with the one from BIOS-MODS.




what am i doing wrong?


Link to post
Share on other sites

The instructions here are confusing (I don't see a Bios.bin etc) but I figured it out using my own trial and error method. Here's what I did.


1) Run HPQUSB.exe in windows to create a bootable USB stick

2) Browse the USB drive and delete everything EXCEPT command.com

3) Download flash.zip from:


4) Extract flash.zip, and copy all files onto the root of your flash drive

5) Boot from the USB drive on your Microserver

6) Hit enter, enter, enter when it asks for the time date etc.

7) Once you see the command promt, type FLASH

8) Hit Enter, you'll see it write the new Bios VERY quickly and will return to command prompt.

9) That's it! Reboot the server, hit F10 and you'll see all the new wonderful option.


Here are the best set of over all instructions on what the MicroServer is capable of and how to set it up.



The following accessory made it MUCH easier to install a 2.5" & 3.5" hard drive into the ODD bay though.


CY DOCK MB971SP-B 1Bay DuoSwap 5.25inch Hot Swap 2.5/3.5inch SATA DOCK Storage



Edited by JazJon
Link to post
Share on other sites
  • 4 weeks later...

Getting ready to move my N40L over to Server 2012 Essentials, and just wondered whether this BIOS mod is still relevant or has it been superseded by a later HP or modded BIOS?

Link to post
Share on other sites

Has anyone found a setting in the modded BIOS to get the eSATA port multiplier to see more than one drive in an external multi-drive eSATA box?


Link to post
Share on other sites

Has anyone found a setting in the modded BIOS to get the eSATA port multiplier to see more than one drive in an external multi-drive eSATA box?



Not possible just buy a card. Search amazon for SiL3132

Edited by JazJon
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
    • AnthonyB
      By AnthonyB
      New BIOS for Gen 8 Server now available that resolves Spectre vulnerability. My server is out of warranty. Anyone able to download and share?
      ** CRITICAL ** Online ROM Flash Component for Windows x64 - HP ProLiant MicroServer Gen8 (J06) Servers
      Version:2018.01.22 (5 Mar 2018)
      Fixes Upgrade Requirement:
      Critical - HPE requires users update to this version immediately.
      Important Notes:
      This revision of the System ROM includes the latest revision of the Intel microcode which, in combination with operating system updates, provides mitigation for Variant 2 of the Side Channel Analysis vulnerability, also known as Spectre. The revision of the microcode included in this System ROM does NOT have issues with more frequent reboots and unpredictable system behavior which impacted the previous Intel microcode which was part of the Spectre Variant 2 mitigation. Additional information is available from Intel’s Security Exploit Newsroom, https://newsroom.intel.com/press-kits/security-exploits-intel-products/.
      Firmware Dependencies:
      Problems Fixed:
      Updated the Intel processor microcode to the latest version.
      Known Issues:
    • DaMenace
      By DaMenace
      I have a simple question about my BIOS from iLo4. Look at the picture and you will see a difference in the System ROM and Backup ROM dates.

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
      Any help is greatly appreciated.
      Cheers Benny

  • Create New...