Jump to content
diehard

Modified BIOS for Microserver N40L enables hidden features

Recommended Posts

topstuff

Hi!

Trying to flash (in a good way), and I cant seemt to get the exact files as Joe (thanks by the way - http://homeservershow.com/forums/index.php?/topic/3397-modified-bios-for-microserver-n40l-enables-hidden-features/page__st__100#entry45899), maybe the flashing tool/files have been updated?

 

Any ideas.. ? :)

 

 

Directory of G:\

 

27/12/2012 04:35 AM 108 AUTOEXEC.BAT

27/12/2012 04:35 AM 66,785 COMMAND.COM

27/12/2012 04:35 AM 24,810 IBMBIO.COM

27/12/2012 04:35 AM 30,880 IBMDOS.COM

27/12/2012 04:35 AM 512 fat32lba.bss

27/12/2012 04:35 AM 45,341 kernel.sys

08/05/2006 02:44 PM 2,973 logo.gif

22/08/2011 10:38 AM 2,803 README.1ST

22/08/2011 10:39 AM 4,930 rev_hist.txt

25/08/2011 08:42 AM 31,926 start.htm

27/12/2012 04:35 AM 79 syslinux.cfg

11 File(s) 211,147 bytes

0 Dir(s) 32,700,366,848 bytes free

 

Thanks guys & Merry Christmas!

Share this post


Link to post
Share on other sites
topstuff

I cant explain it but after several attempts it worked, no idea what it could of been.. severe operator error I guess.. thanks!

Share this post


Link to post
Share on other sites
ikon

Forgive me if I've forgotten the thrust of this thread, but you are talking about a USB thumb drive, right? If so, I'd bet money it's the brand/model of thumb drive that's the problem. Some of them are much more 'bootable' than others.

Share this post


Link to post
Share on other sites
sarkrueger

I'm a little late to this thread, and posted a message to Joe Miner's great article on Storage Spaces on an HP Proliant N40L, which he kindly rersponded to. I figured I would continue the conversation on a forum and picked this one! I appologize if this isn't the place.

 

Sarkrueger asked;

Joe, I pretty much built a system just like described. I flashed the BIOS via Diehard and installed windows 8 on an SSD drive on port 5, and have a 3.0 TB drive in port 4 in the icy dock. Both show up in the BIOS. I changed the SouthBridge settings as per described and for some reason the 4 3.0 TB Seagate drives in the internal drive bays, don't show up in the BIOS or under manage, drives in Windows. Any thoughts on what I might be missing? Thanks!

 

Joe Miner responded; Hi Scott! I had the same problem once -- it turned out that I hadn't fully seated my SAS connector that's attached to the 4 drives in the main drive bays on the MB. If you're getting power to the drives (you should be able to hear them spin up when you turn it on) then the SAS connector would be my guess.

 

I just wondered if I messed something up, and whether anyone has has the same issue that they weren't able to recover from. I seemed to have fully pressed down/reattached the 4-bay-SATA connector to the HD several times. I noticed it doesn't "click" into place. Restarted from no powere etc, etc. Still, the drive aren't recognized. Maybe I damaged the cable. Weird. Brand new N40L.

 

Scott Krueger

Share this post


Link to post
Share on other sites
cskenney

Sarkrueger - Someone else posted something very similar to what you are describing. They could boot just fine off the SATA port on the MB put their drive would not show up in any of the 4 HDD slots. I believe they identified a damaged SAS connector and had to send it back to HP.

 

Did the system ever recognize a drive in one of the HDD slots? Have you removed the SAS connector and examined it to see if anything looks unusual? Are all the other connectors seated properly on their mating connectors (nothing off by a row?).

 

You also mentioned port 4 in the icy dock. Did you install the ICY dock Hot Swap drive caddy and connect your 3.5" drive to the eSATA port?

 

Finally, you state that you changed the bios settings and the 4 drives don't show up. Did they show up before you changed the BIOS?

Share this post


Link to post
Share on other sites
sarkrueger

Well, sometimes it helps to just fling your issues out there to get them solved. The problem was that the left guide tab on the mini-SAS cable was sliding into the connector on the MB. The MB female receptor inside the silver guide on the MB was offset to the left. I probably messed that up due to many re-connects trying to get it to connect. After some realignment (ie-accidently breaking off the left guide on the connector), the min-SAS cable seated and all it good!! All 6 drives are recognized, (4-Seagate 3.0 TB 7200 RPM drives in the internal cages, 1-Seagate 3.0 TB 7200 drive in the icy dock and a 256 Crucial m4 SSD (Windows 8-64) boot drive in the icy dock. What a great set-up! Thanks for all the great info posts!

Share this post


Link to post
Share on other sites
cskenney

Good to hear you got it figured out.

 

Make sure you participate here in the forums and tell us what you are planning to do with your box. I think you are one of the few people who have mentioned running Windows 8 on their Microserver.

Share this post


Link to post
Share on other sites
Marcel_Dutch

Hi there ! Houston we have a problem.....

First of all greetings from the Netherands. :)

 

I followed the steps to modify the BIOS but as result 'a dead HP Microserver'.

I created the usb flash boot disk and copied the .ROM file to it.

 

Started the machine without any disks accept the SDD at the ODD port.

The usb flash disk booted and re-writed the BIOS.

After reboot i don't get anything anymore at my screen.

:(

 

Help.

Share this post


Link to post
Share on other sites
jmwills

See if you can downl;oad the OEM BIOS from HP and get back to square one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • bennybennybenny
      By bennybennybenny
      Hey guys,
      Not sure if this is the correct section to post this, but in a bit of a pickle after attempting to flash my HP Microserver N40L to the modified bios last night.
       
      The story goes - I've had myN40L microserver for the past few years running Windows 8.1 and acting as a media server for the house. I recently upgraded a laptop I have so had a spare Samsung 840 EVO 120gb SSD that I thought I'd throw in the microserver as the boot drive. 
       
      I ghosted the existing windows install (which was on a 250gb mechanical hard drive) over to the SSD, rebooted the computer and everything was working file. When I checked the performance of the SSD using the Samsung Magician software it indicated thatt the SSD wasn't running at full speed due to AHCI being disabled. I then did a bit of research and found that SATA port 5 (normally meant for an optical drive) that the SSD was connected to doesn't run at full speed and in IDE mode. I read that the modified bios that's floating around for Microserver's can fix this.
       
      So I flashed the bios to my machine however now when I boot up it gets to the loading screen for windows and then errors and reboots. This boot loop just continues constantly with no way to get into windows.
       
      I've tried setting the hard drive mode to both IDE and AHCI in BIOS with no success, I've reverted the BIOS back to default settings, took out the CMOS battery overnight, tried to re-flash back to default HP firmware, re-flashed the modded BIOS with no drives in the server and even run the windows 8 startup repair with no success whatsoever, it just continues to error and boot loop.
       
      I did leave all 4 of my other SATA hard drives in the machine when flashing the modded bios originally so don't know if this affected it. I wish I'd just left the original BIOS on there now.
       
      Is there anything I can try to fix this? I'd really prefer not to have to reinstall windows 8 as it took me awhile to set everything up for media (Sonarr, CouchPotato, iTunes, Serviio etc).
       
      Any help is greatly appreciated.
       
      Cheers Benny
    • felt
      By felt
      Bought this ML10v2 a few months ago and have been hitting wall after wall, frustrated- putting it away for a few weeks, and then trying again. I can not get it to boot from a USB and have not figured out how to recognize and identify drives!
       
      I have gotten iLO4 working with a valid key, I have updated the SPP, registered on who knows how many HP/HPE pages, looked through the documentation- but still can't get the machine to boot to my Linux USB for installation.
       
      This seems like a basic step, but I've kind of lost my objectivity at this point and wanted to ask for help. Is there something I need to do in iLO4 to have it recognize the install media or my drives? I can't seem to make sense of the Virtual Media field.
       
      I want to install Ubuntu 16.04 Server- HP/SPP says it supports Canonical. How do I get the machine to 1) open into BIOS? is it F2/F9/F10/F11 during boot? My POST sequence never seems to get past 10%, and then 2) recognize my hard drives, no matter what number SATA cable, it doesn't see them. I can only open the iLO4 manager from another computer on my network, so I can't open it on local host like the (very helpful) Joe Stutsman videos and instruction guides suggest.
       
      Anyhow, any input on this configuration would be appreciated. I know I'm missing something, but want to exhaust all options before I return this.
       
    • nlitend1
      By nlitend1
      I upgraded 2 identical systems (both running windows 7) to SSDs and restored images via WHS 2011 and noticed that one of the systems is not running AHCI mode (according to AS SSD benchmark and device manager). I made the 2 registry changes already in windows according to this guide....
      http://www.sevenforums.com/tutorials/61869-ahci-enable-windows-7-vista.html   I then made sure that the BIOS had SATA configured as AHCI (and not IDE). After reboot, I did not get prompted to install the AHCI drivers and the performance is significantly less with the system that appears to be running in IDE mode.   The following are two strange things:  1. Changing the BIOS setting to AHCI or IDE never gives me a BSOD. 2. Stablebit scanner states that both TRIM and NCQ are both working on the SSD and from what I can tell NCQ cannot run without AHCI mode.   This system apparently appears to be "stuck"... in what appears to be IDE mode...Any ideas on what to try at this point? Am i looking at a clean install or even worse... corrupted BIOS?    Thanks!   nlitend1
    • TheChallinor
      By TheChallinor
      Hi,
       
      Currently running the old and unsupported Bay version of the custom N54L firmware and looking to upgrade to Windows 8.1
       
      Appreciate there is an issue with the NIC stopping the upgrade as it's not supported, although there is a HP bios upgrade to fix this bug. 
       
      Obviously if I flash the bios to the latest HP version I will loose Sata II speeds on the ports that HP don't support OR I could get a NIC and keep the bios as it is.
       
      Just looking for ideas / suggestions on what other people have done, etc.
    • Jon Hill
      By Jon Hill
      How that a few here have opted for the HP Microserver I would like to pose a question /warn here about the power options.
      I jumped at this box to migrate to 2001 as I had issues with v1 box, and here in the UK 100 GBP was too good a deal to miss at the time.
       
      I run with the stock RAID 1 mirror on the first 2 * 2TB drives with the OS and my critical data then run a RAID 0 stripe on 2 more 2TB for video mainly recorded TV and ripped DVD’s.
      Due to the price and peace of mind I ended up with two boxed I am not sure about the recovery options for my data if the RAID(s) die as this RAID stuff is all new to me.
       
      Sorry to the question, I have not found a way to make the box sleep or remote shutdown, I did plan to run lights out on the box as I used it on V1 with no issues. I have the latest BIOS and tried the Light's Out pdf that can point to some checks to enable sleep but I think it is not supported at all on the box.
       
      Can anyone else verify this or know of a workaround. Not a major deal but I would like to run one box 24/7 then have the other as a backup destination NAS type thing waking and sleeping automatically.


×