Jump to content
RESET Forums (homeservershow.com)

Proper Audio Setup for HTPC


thobel

Recommended Posts

So I have a Creative Fatality X-fi connected ia Optiacal cable to a Onkyo reciever with 5.1 speakers setup. I also have Sharky007 codec pack running (In recommeneded mode)

 

How do I configure the Sound Card? What options shoul dI use or not use.

How do I configure the Reciever? (Mostly worried about HD Movies)

Anything I need to do on the codexs?

 

I'm assuming any audio work really should be done on the reciever and not by the pc? Correct?

What settings if thats correct do I use on Sound Card and Codexs to "pass threw" pure signal?

 

Sorry If i seem clueless I'm good with computers and very bad with audio any and all advice is welcome.

 

Main issue I seem to have is Voices in movies is low and Action (jets bombs etc is very loud so at night It drives me crazy trying to adjust sound so I dont piss off the neighbors (in a building in NYC)

Link to post
Share on other sites
Guest no-control

i just use the HDMI out into my reciever. previous to that I used the optical out on the mobo to the receiver. I never use sound cards and do not recommend them.

Link to post
Share on other sites

I agree with no-control. You want to use HDMI pass through from your PC to your Onkyo if you can. Your receiver should handle the decoding of the True-HD and DTS-HD. If you use optical, your PC will do the decoding and you will not be taking advantage of your receiver. The fatality is a clean card but ends up working against you in an HTPC. It is great for gaming and music but does not allow pass through. I have one sitting in my closet for the same reason.

Link to post
Share on other sites

I agree with no-control. You want to use HDMI pass through from your PC to your Onkyo if you can. Your receiver should handle the decoding of the True-HD and DTS-HD. If you use optical, your PC will do the decoding and you will not be taking advantage of your receiver. The fatality is a clean card but ends up working against you in an HTPC. It is great for gaming and music but does not allow pass through. I have one sitting in my closet for the same reason.

 

So I moved over to HDMI to the Onkyo now I have an issue where When I turn off the TV the HDMI signle does not "wakeup"? I unplug the HDMI plug it bakc in and it works fine. Any idea on how to fix something like that? PC does not hybernate or sleep

Link to post
Share on other sites
vinylfreak

So I have a Creative Fatality X-fi connected ia Optiacal cable to a Onkyo reciever with 5.1 speakers setup. I also have Sharky007 codec pack running (In recommeneded mode)

 

How do I configure the Sound Card? What options shoul dI use or not use.

How do I configure the Reciever? (Mostly worried about HD Movies)

Anything I need to do on the codexs?

 

I'm assuming any audio work really should be done on the reciever and not by the pc? Correct?

What settings if thats correct do I use on Sound Card and Codexs to "pass threw" pure signal?

 

Sorry If i seem clueless I'm good with computers and very bad with audio any and all advice is welcome.

 

Main issue I seem to have is Voices in movies is low and Action (jets bombs etc is very loud so at night It drives me crazy trying to adjust sound so I dont piss off the neighbors (in a building in NYC)

 

For the configuration of your creative card open up the Sound control panel and set the Fatality X-fi as your default sound playback device. I use a Asus Xonar sound card also connected to an Onkyo TX-SR608 AVR, my settings look like this.

 

soundpanel.jpg

 

You will need to configure your sound card to play back 5.1 audio or 7.1 audio depending on your setup. When you highlight your soundcard and click Configure you should get a window like this.

 

soundconfig.jpg

 

 

You might have some extra settings in your creative software to set and tweak to your liking. That should be it on the windows side. You will of course need to set your Onkyo to use the Optical output for that particular selection.

 

That all being said, an Optical or Coax digital connection will NOT give you the newer HiDef Audio that is currently on BluRay and older HDDVD. You must use an HDMI connection to pass those bits through.

 

As I stated earlier I use an Asus Xonar D2X sound card

 

P1000607.jpg

 

85% of my Audio listening is done through this card. I listen to alot of loss-less music on a daily basis, the DAC (Digital to Analog Conversion) circuitry in the Xonar, provides a much better listening experience than does the HDMI connection on my ONKYO. At least IMHO.

 

I do however agree with @NoControl and @PCDoc when it comes to playing back my Bluray and HDDVD rips. HDMI rules.You are not going to get DTSMasterAudio or Dolby TrueHD out of an optical cable.

 

Its kinda a PITA, but when I watch Blurays or HDDVDs I do change my default Audio over to the HDMI connection on my MB. It looks like this.

 

soundhdmi.jpg

 

I do Love my Xonar card though, it takes all Audio and auto converts it to Dolby Digital Live. Initially the drivers were a little buggy with Win 7 but it has been serving me up great audio now for a long time. It definitely makes my JBL speakers Sing!

 

Your loss of HDMI connection sounds like a HDCP handshake issue. Unfortunately in the world of HTPCs, this is an all to common problem. In my case I found that going into my ONKYO config GUI and selecting "Through" for the Video transmission has solved that problem. Your mileage may vary.

 

Hopefully this has helped you a little bit. If you have other questions.....post away. ;-)

Link to post
Share on other sites

For the configuration of your creative card open up the Sound control panel and set the Fatality X-fi as your default sound playback device. I use a Asus Xonar sound card also connected to an Onkyo TX-SR608 AVR, my settings look like this.

 

soundpanel.jpg

 

You will need to configure your sound card to play back 5.1 audio or 7.1 audio depending on your setup. When you highlight your soundcard and click Configure you should get a window like this.

 

soundconfig.jpg

 

 

You might have some extra settings in your creative software to set and tweak to your liking. That should be it on the windows side. You will of course need to set your Onkyo to use the Optical output for that particular selection.

 

That all being said, an Optical or Coax digital connection will NOT give you the newer HiDef Audio that is currently on BluRay and older HDDVD. You must use an HDMI connection to pass those bits through.

 

As I stated earlier I use an Asus Xonar D2X sound card

 

P1000607.jpg

 

85% of my Audio listening is done through this card. I listen to alot of loss-less music on a daily basis, the DAC (Digital to Analog Conversion) circuitry in the Xonar, provides a much better listening experience than does the HDMI connection on my ONKYO. At least IMHO.

 

I do however agree with @NoControl and @PCDoc when it comes to playing back my Bluray and HDDVD rips. HDMI rules.You are not going to get DTSMasterAudio or Dolby TrueHD out of an optical cable.

 

Its kinda a PITA, but when I watch Blurays or HDDVDs I do change my default Audio over to the HDMI connection on my MB. It looks like this.

 

soundhdmi.jpg

 

I do Love my Xonar card though, it takes all Audio and auto converts it to Dolby Digital Live. Initially the drivers were a little buggy with Win 7 but it has been serving me up great audio now for a long time. It definitely makes my JBL speakers Sing!

 

Your loss of HDMI connection sounds like a HDCP handshake issue. Unfortunately in the world of HTPCs, this is an all to common problem. In my case I found that going into my ONKYO config GUI and selecting "Through" for the Video transmission has solved that problem. Your mileage may vary.

 

Hopefully this has helped you a little bit. If you have other questions.....post away. ;-)

 

Where would I find the "through" option?

Link to post
Share on other sites
vinylfreak

Where would I find the "through" option?

 

On your ONKYO remote hit Setup > Input Output assign > Monitor Out then scroll to "Through"

Link to post
Share on other sites
ImTheTypeOfGuy

Its kinda a PITA, but when I watch Blurays or HDDVDs I do change my default Audio over to the HDMI connection on my MB. It looks like this.

 

soundhdmi.jpg

 

I do Love my Xonar card though, it takes all Audio and auto converts it to Dolby Digital Live. Initially the drivers were a little buggy with Win 7 but it has been serving me up great audio now for a long time. It definitely makes my JBL speakers Sing!

 

Your loss of HDMI connection sounds like a HDCP handshake issue. Unfortunately in the world of HTPCs, this is an all to common problem. In my case I found that going into my ONKYO config GUI and selecting "Through" for the Video transmission has solved that problem. Your mileage may vary.

 

Hopefully this has helped you a little bit. If you have other questions.....post away. ;-)

 

If you are not aware, Josh Pollard over at Digital Media Zone created a plugin for MC that allows you to change your audio source within MC. This would make it easier than having to exit/minimize MC and then go into the control panel.

Link to post
Share on other sites

If you are not aware, Josh Pollard over at Digital Media Zone created a plugin for MC that allows you to change your audio source within MC. This would make it easier than having to exit/minimize MC and then go into the control panel.

 

You happen to have a link to it? I can't locate it.

Link to post
Share on other sites
vinylfreak

If you are not aware, Josh Pollard over at Digital Media Zone created a plugin for MC that allows you to change your audio source within MC. This would make it easier than having to exit/minimize MC and then go into the control panel.

 

Thanks! I did not know that Josh made one.

I know a guy in France came up with one a couple years ago.

I tried it and it was a little buggy.

I will give Josh's a try.

I'm assuming it is on the DMZ site somewhere?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...