Jump to content
RESET Forums (homeservershow.com)

Universal restore?


Bitback
 Share

Recommended Posts

I know that a bare metal ie. new disk restore is pretty easy. But what if I got a totally new motherboard? Or another machine altogether?

 

Has anyone tried this? i suppose it would be like taking my OS disk form one machine and slapping it in a different machine and booting...

 

How does Acronis do it?

 

Thanks guys! Love the show!

Link to comment
Share on other sites

I have used many many times in my work. Acronis is able to this because they strip away at the HAL layer. This is rebuilt upon installation. Though Universal Restore is not perfect, it works very well. Well enough, that we could take a dektop image and go back and fourth to a laptop. Sometimes NIC drivers won't work and you have to re-install those. Sometimes CPUs do not show up correctly. In other words, if you have a quad core and you restored an image that used a core 2 duo, then you would simply need to delete the cpus listed in device manager and reboot. They will re-appear.

 

I hope this little nugget of information helps,

 

JerryW

Link to comment
Share on other sites

Any success with WHS 2011?

 

If the WHS 2011 backup is a VHD - could you theoretically mount the VHD, image it with Acronis, restore image to another piece of hardware?

 

A long workaround, but would be helpful. When a machine dies - most users want to upgrade (but want to be up and running quickly).

 

Thanks!

Link to comment
Share on other sites

Well, I don't think you technically need to use Acronis, although it might make things a little cleaner. It is possible to take a drive from one computer, slap it into another, and boot. You will, unless the 2 computers are identical, likely get all kinds of yellow triangles and stuff in Device Manager. But, if you clean them up, you should have a functioning computer. I've done it a few times.

 

The issue with this approach is that you pretty much have a new computer with bitrot built in. It's always cleaner, and better IMHO, to do a clean install. That way you don't have all kinds of unused driver files and so on hanging around the system.

Link to comment
Share on other sites

I have done this a bunch of times without the need to do anything but reboot, re-detect drivers, and re-activate. This is provided you stay in the same camp (AMD/Intel). My WHS home sever has already seen three motherboards.

Link to comment
Share on other sites

I have done this a bunch of times without the need to do anything but reboot, re-detect drivers, and re-activate. This is provided you stay in the same camp (AMD/Intel). My WHS home sever has already seen three motherboards.

 

Good point about AMD/Intel.

Link to comment
Share on other sites

Update:

 

I booted a new PC (lenovo with AMD) with the USB restore key, pointed it to another backup (Dell AMD) and got it to fully restore. BSOD on startup.

 

I could boot up to a Win7 CD and repair? I might try that....

Link to comment
Share on other sites

Update:

 

I booted a new PC (lenovo with AMD) with the USB restore key, pointed it to another backup (Dell AMD) and got it to fully restore. BSOD on startup.

 

I could boot up to a Win7 CD and repair? I might try that....

 

Did you try booting into Safe Mode, then cleanup Device Mangler and install drivers?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...