Jump to content
RESET Forums (homeservershow.com)

Non-RAID drive attached to RAID card - Controller failure


dvn
 Share

Recommended Posts

The title says it all. The drive in question was my WHS 2011 server backup drive. Here's the event message:

 

Disk 'SAMSUNG HD204UI-S2H7J9AB701690' at Controller1-Channel3 failed.

 

I removed it from the RAID card (it's not part of an array, just a single attached drive), attached it directly to the motherboard, booted but no luck in getting it to reappear in Dashboard. So I pulled it, connected it to my PC, booted, went into Disk Management, assigned a drive letter and tried to open it. No luck. Ok. The heck with it, I'll just wipe it and start over, which I did. While I was at it, I checked SMART and the drive looked perfect, full health, no reallocated sectors, nothing at all. Once all that was done, I reattached it to the server, reestablished it as the server backup drive, then configured and started a manual backup. It completed while I was at work today.

 

So here's the deal, or question, as the case may be. To me, it looks like a problem between the RAID card (it is using the lastest firmware, the same version as when I first installed it) and the Samsung HD204UI HDD, more specifically its firmware. So I flashed the Samsung. Actually, I re-flashed to the same version which was already at the latest, but what the heck. I did it anyway. This I did after work today, after the drive had finished backing up the server from scratch. I had to power the sytem off completely before the mobo would detect the drive, don't know why, but no problem. I can do that. So it's there and it seems fine. I'll keep an eye on it.

 

Any thoughts? Comments about the RAID card - HighPoint 2720? Samsung HD204UI and/or its firmware? I'm using HighPoint a breakout cables so I don't suspect them, but again, I'm not sure. So... What do you think?

Link to comment
Share on other sites

I had a similar problem with a WD 2TB EARS drive, out of the 4 connected to the card, 1 didn't even survive the initial build of the array. Bit later, it was working again, then failed, etc... Never did get around to trying it on a motherboard directly, though I should. When doing some other research, I found a little bit out about the differences between consumer and enterprise drives that may be what's happening.

 

Enterprise drives have a feature called TLER - Time Limited Error Recovery. If they can't recover an error within a few seconds, they quite trying. Consumer drives do not have this feature, and will scan to recover an error for a lot longer period of time. The problem with this is that while scanning they become non-responsive, and the RAID card ends up dropping them as dead even though they are functioning properly, just in the middle of an internal operation.

 

I don't know if this is what's happening to you or not, but I have seen similar issues, and this is an explanation that at least fit the description of what I was seeing.

Link to comment
Share on other sites

What you guys are describing is not a drop or related to TLER. The fact that Rich attached it to a motherboard and the fact it was not in an array rules that out. Andne, in you case it sounds like just a bad drive. I have had two bad drives in the past 12 months but no issues with dropouts. Issues related to TLER usually appear as almost a lock up. One was related to bad sectors and the other was just dead and was not detected just like what you are describing but right from the beginning. Put in a new drives and no issues since. I have a 14T and 10T array.

Link to comment
Share on other sites

Agree, get another drive; RMA that one if under warranty.

 

It sounds mostly like a drive controller board issue, as though the board is working sometimes and sometimes not. Could be heat related, cold solder joint, just a bad chip, contact corrosion in the interface to the drive internals, etc.

Link to comment
Share on other sites

Rich, so there was a time, when everything was working fine???

Yes. It was fine for 3 or so months.

 

Agree time for a new drive

It would seem, but SMART data looked fine when I had it connected to my PC. Maybe I should try Stable Bit Scanner?

 

Agree, get another drive; RMA that one if under warranty.

 

It sounds mostly like a drive controller board issue, as though the board is working sometimes and sometimes not. Could be heat related, cold solder joint, just a bad chip, contact corrosion in the interface to the drive internals, etc.

Well, the heat-related is a possibility as I was doing a complete server backup. But the total amount is a couple megs over 1TB, and the case is well-ventilated/cooled with 4 fans - 3)140mm + 1)120mm.

 

Anyway, I have one more thing to check out, something firmware related. I'll let you know.

Link to comment
Share on other sites

hm...5 Samsung HD204UI drives: 3 with one firmware version, 2 with another. So I flashed them all the same. Now that that is done, I'm going to wipe the server backup and rerun it, the whole thing. Let's see if RAID card and drives play nice now. And yes, I'm going to reconnect to the single drive to the RAID card.

 

If this solves the problem, I'll hate to say it but this was one of my own doing. I remember flashing a couple of the drives before I built the server but I'm sure they weren't all done. Either way it turns out, I should not have been so sloppy about it. Not when a RAID card is involved, right?

Link to comment
Share on other sites

Backup is started. Should be done by morning. I'm going to bed. Sure hope I don't get woken by any alarms tonight. :)

You let your WHS alarms wake you? That is what I call dedication. I like my sleep too much for that :mellow:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • Giuseppolino87
      By Giuseppolino87
      Hi everyone, today I wanted to install esxi 6.7 to try out the various functions, my question is the following, I have a server where I have installed esxi in an SSD and I have two other 4 tb disks so 8 tb total.  I would like to make sure that when I create a virtual machine in this case I will install the various virtual machines in the SSD and use the two disks for data.  So how can I do this?  Thank you very much for those who can help me.
    • E3000
      By E3000
      Looking for a quick answer here from someone in the know...
       
      I upgraded some of the internals of my Gen8 server and at the same time I did a BIOS reset as I had forgotten the password that I had set years ago. When booting back up the upgraded hardware was detected and fine but I received Error 1784 - Drive Array - Logical Drive Failure. I believe this is due to a setting change in the BIOS and not anything hardware related. I have gone into IP/SSA and see the array needs to be rebuilt. I had all drives configured as single RAID0. It says all data will be lost if I reconfigure this but I remember reading somewhere on here that the data will be fine if I reconfigure as RAID0.
       
      I do have a backup of course, but it’s not a high availability mirror and will take some time to get back the way I had it, so just want to know if it’s safe to reconfigure the RAID0 without erasing the drives. I have tried pulling the drives out and connecting them to another PC and they are fine. Can anyone tell me which options to choose to get these back to normal and remove the flashing red light?
       
      Thanks 😶
    • Mark Belanger
      By Mark Belanger
      Greetings,
       
      I'm new to the HPMSG8 world and so far I'm loving it. I have a stock Xeon with 16G of aftermarket memory with iLO patched to 2.70. Next up is adding a RAID card, so I can put my boot SSD on the onboard RAID. I picked up a LSI SAS9211-8i on Amazon, but am struggling to flash it to IT mode on the MicroServer. Is this even possible? Unfortunately, the only other system I have with PCI slots is 32-bit.
       
      Any pointers would be greatly appreciated.
       
       
      -MB
    • TakiBot
      By TakiBot
      I've got my hands on a HP N40L.
      Can i use raid 1+0 on my 4 2TB WD RED or only 1 and 0.
      Thanks for the help.
    • arefiev.dm
      By arefiev.dm
      Hello! I put P222 on my Gen8 server, but I can not use RAID6. Can someone share the key?
×
×
  • Create New...