Jump to content
RESET Forums (homeservershow.com)

since WHSv1 recovery RDP to server from internet is broken


ikon
 Share

Recommended Posts

A little while ago I had to do a recovery of my WHSv1. Since then, I have not been able to RDP directly into the server from outside my network.

 

When i try to initiate a connection to my WHSv1 I get the dreaded Remote Desktop can't connect to the remote computer....., so it's not even getting me to the login prompt. It behaves just as if it can't establish a link to my WHSv1 at all.

 

RDP to the server works fine from inside my network; it's only from outside my network that's an issue.

 

I can RDP just fine into my Win7 desktop machine from outside.

 

I have checked a lot of things, with no luck, so I'm appealing to the collective brain of the forums:

  1. WHSv1 does have the correct DNS and gateway entries.
  2. the port forward on my router (Untangle) is identical to the one I have for my Win7 desktop, with the exception of the IP address and outside port number of course. Both entries forward to port 3389 on the WHSv1 and my Win7 desktop.
  3. I have deleted the port entry for WHSv1 and re-created it, several times, and tried using a different outside port number.
  4. I have verified that the Remote tab in Control Panel/System of the WHSv1 has Remote Desktop enabled and that my user account is in the list.
  5. I've even verified that my user account in the WHSv1 Console has Remote Access permissions.

At this point I'm thinking I'm too close to the trees to see the obvious thing that's giving me grief. Can someone please point out the error of my ways (well, at least as far as RDP to my WHSv1 is concerned :) )

Link to comment
Share on other sites

  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

  • ImTheTypeOfGuy

    2

  • jmwills

    7

  • Grant B

    7

  • ikon

    12

As much as I admire Live Mesh, I shouldn't have to use it for this purpose :D

 

True. True.

 

Unfortunately I can't help you though as I do not use this feature. Good luck.

Link to comment
Share on other sites

 

True. True.

 

Unfortunately I can't help you though as I do not use this feature. Good luck.

That's OK, all participants are welcome to play our game. Don't forget to collect your consolation prize as you leave the studio ;)

Link to comment
Share on other sites

Let's try something simple as flushing the DNS cache on the client you are using remotely. ipconfig /flushdns

 

 

If that fails, I would disable the remote web access on the server, reboot, and then setup that function again.

Link to comment
Share on other sites

Let's try something simple as flushing the DNS cache on the client you are using remotely. ipconfig /flushdns

I thought of that but didn't think it would help because I can remotely RDP into my Win7 desktop, which tells me my remote computer can get to the outside port of my Untangle box just fine. It seems to be an issue between Untangle and the WHS. There's not really a problem doing it of course; I just didn't think it would help.

 

If that fails, I would disable the remote web access on the server, reboot, and then setup that function again.

Just to be clear, I'm not trying to access the server via web access; the issue is with RDP access only. That said, WTH, it doesn't cost anything but a little time to try it.

Link to comment
Share on other sites

Both functions should be using Port 3389 if I am reading the issue correctly. That's why I suggested removing that component and reinstalling it. also, chek to see if that service has been started.

Link to comment
Share on other sites

I wasn't aware that Remote Web Access uses 3389. Interesting. Based on that I checked my WHSv1 Settings - I had not Enabled Remote Access since the recovery. So, I turned it on and configured it. Still no go. I'm rebooting the WHS now to see if that works. Thanks for the tip.

Link to comment
Share on other sites

Still no go after reboot. This is a puzzling one.

 

Let's try something simple as flushing the DNS cache on the client you are using remotely. ipconfig /flushdns

Tried it from another remote computer entirely.... still no go; guess it's not a DNS issue.

 

If that fails, I would disable the remote web access on the server, reboot, and then setup that function again.

Just to be clear, are you suggesting to disable Remote Access in the WHSv1 Settings window; the one I found had not been enabled since the recovery? I'm just trying to ensure we're talking the same thing. BTW, since I configured it, Remote Access works - I got to the main web page and also to the login page.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...