Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
Technogod

Unable to connect to a computer via Remote Web Access

Recommended Posts

Technogod

I struggled with this problem for a long time until I followed basic network troubleshooting. I could reach all the computers on my network remotely from the WHS Remote Web Access website except one. I could ping the problem computer using it's ip address from the Server. When I tried to ping the problem computer using the computer name it was unreachable and the wrong ip address was displayed.

 

Solution: For some reason WHS added the following line to the host file.

192.168.1.131 SUPERCOMPUTER #Windows Server Added Entry#

The host file is located in the c:\windows\system32\drivers\etc folder. I use DHCP so when the ip address changed my computer was now unreachable. I deleted this line from the host file. I have no idea why WHS added this line to the host file.

Share this post


Link to post
Share on other sites
ikon

This appears to be caused by something called Local Link Multicast Name Resolution. According to Wikipedia this is a protocol described in RFC 4795 and is a way for both IP4 and IP6 to be able to do DNS on the same network.

 

However, if there is no actual DNS server on the local LAN, and name resolution takes longer than 100 ms repeatedly, the server will add a line like this to the hosts file to speed up resolution.

 

If you go to this google page, German LLMNR, and then ask google to translate the 2nd result that shows up, it will give you some info and links: translated page

 

From the little I scanned quickly, I think it might be worthwhile putting the entry back with the correct IP. It also suggests the erroneous entry might be caused by changing the 2011 IP.

 

You said you use DHCP. Do you use it for your servers as well? If so, I would change that practice and assign static IP's to servers, printers, routers, access points, etc. Only use DHCP for client computers.

Edited by ikon

Share this post


Link to post
Share on other sites
ikon

Thinking about this a little more, I think my advice to just add the entry back is not the best. It would be a quick fix, but it doesn't address the real issue, which is: why is name resolution on your network taking so long?

 

It seems like you may not have a DNS server on your LAN. In most home LANs the router is the DNS server (and the DNS relay as well). I think I would do IPCONFIG /ALL on all your computers and see what the DNS Server is set to. If it isn't the inside address of your router, then maybe your router 1) doesn't do DNS or 2) has DNS turned off.

Share this post


Link to post
Share on other sites
Technogod

Thanks for the info. I was wondering how this was happening. All computers on the network are pointing to the inside ip of the router. I checked the host table of the server and found the ip of my work laptop was now in the host table.

Share this post


Link to post
Share on other sites
jmwills

I would also check to see of there was an update for the routers firwmare and read thru the documenation to see if any DNS issues were resolved. If the clients are XP, you can also reset the TCP stack to see if that helps.

Share this post


Link to post
Share on other sites
ikon

I would do as jmwills says; check the router firmware. Also, depending on the make/model of the router, you may be able to run 3rd party firmware like Tomato or DD-WRT, which normally performs much better than the OEM stuff. It does seem that your router is not doing it's DNS job very well; otherwise name resolution would not take so long that 2011 feels it necessary to create the hosts file entries.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...