Jump to content
RESET Forums (homeservershow.com)

USB media card reader drives disappear shortly after connection


msawyer91
 Share

Recommended Posts

My WHS v1 box is presenting me with a puzzling head scratcher. Several folks have indicated to me that my add-in for WHS v1, Home Server SMART, suffers from a serious bug that prevents the add-in from functioning correctly, if at all. After much goings back-and-forth with folks, I've come to the conclusion that the folks experiencing these problems had DIY home servers with media card readers in them.

 

Media card readers present themselves to the OS as "hard drives" so to speak, in the format of \\.\PHYSICALDRIVEx (where "x" is an integer), accessible through the Win32_DiskDrive interface. If a card slot is empty, a lot of the values are null...things like sector size, sectors per track, tracks per cylinder, etc. Early versions of HSS did not do a good job checking for null, mainly because my EX490 doesn't have a card reader and so it never came up in my own tests.

 

And so I worked on making the code more robust, adding null checks even on values I thought could never possibly be null. And while this resolved some problems, others remained. The only way I was going to get to the bottom of this was to add my own media card reader to the server, and test it myself. So I went out and bought a USB card reader with 4 media slots.

 

The card reader works flawlessly on all of my computers...except the EX490! I have computers running Windows 7 and Vista (64-bit), Server 2008 R2 and Server 2008 (32-bit). And one running XP (32-bit).

 

The problem I'm seeing is that if I connect the card reader to the server, it loads just fine. Four lettered drives appear in Explorer under the heading "Drives with Removable Storage" (my C and D drives show up under "Hard Disk Drives"). And then after a few seconds, they disappear. Poof! Gone! Gone from Device Manager too. It makes no difference whether the slot(s) are populated with a card or not.

 

I tried rebooting the server. It makes no difference. If I disconnect and reconnect the card reader, the 4 drives come back, and then they're gone less than 10 seconds later. This does not happen on any other computer I connect this reader to. I tried different USB cables, a different USB port, but nothing works.

 

No errors or warnings appear in the event logs either. It's almost as if the OS is automatically performing a "safe removal" of this device for me.

 

So if I want to do any testing, I need to unplug the device, stop the HSS service, plug in the device and immediately restart the HSS service--and hope it enumerates all the devices in less than 10 seconds, because the card reader is "available" for only 10 seconds or less before it disappears.

 

What's up with that?

Link to comment
Share on other sites

I don't know what's with that, but I have a D-Link 7-port powered USB 2 hub that I can plug into my Acer H340 to see if I can replicate the problem.

Link to comment
Share on other sites

OK, so my H340 does the same thing that Win7 did when I first set it up; it 'hides' any USB ports that don't have anything inserted into them. My Win7 box does the same thing with the D-Link 7-port hub that's plugged into it. The multi-card reader built into my Dell 30" display behaves the same way.

 

The same thing happened on my work Win7 computer. IIRC, I found a setting that said not to hide empty slots. I don't recall where I found it, but I'll confirm that I 'fixed' it on my work machine and see if I can find the setting.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • MarkFlagman
      By MarkFlagman
      Hi, everyone!
      Hoping someone can help me out with this one!
      I have a simple RDS setup of 2 servers. One is the connection broker/gateway etc (RDS001), and the other is the session host (RDS002). These are both Server 2012 R2, in the same OU, with the same GPO's applied.
      I am using HP T510 clients (running ThinPro 5.2), with an RDP connection to the farm address (rds.domain.local). The connection is working fine, however usb devices (ie memory stick) will not redirect to the session host. All the redirection options in the collection properties are ticked. Audio redirects to the client with no problem. 
      I have also tried connecting directly to the session host (RDS002) with no difference. 
      I believe the redirect settings on the T510 to be correct, as if i set up another rdp connection from the client to another server or even the connection broker (RDS001) , the usb device i have plugged to the client redirects fine. 
      So, it seems as though it is only the session host (which is where i actually want to redirect a device to..lol) having this problem. 
      However, if i connect to the session host from a windows 10 pc, everything redirects as expected - just not from the t510!
      Any help appreciated!
    • Moreplavec
      By Moreplavec
      I have new Gen8 and installed SSD do 5th bay, trying to boot via USB Grub. But i can't get it to work. I switched in BIOS to USB boot and tried to install Ubuntu server 16 + /boot set to USB drive, partition created on USB (ext3). Not working.
       
      So i deleted all and tried to install Proxmox to SSD, without problem. Then i used tutorial to create USB bootable https://jarrodla.blogspot.cz/2014/04/hp-microserver-gen8-boot-from-5th-sata.html but again, no luck. I tried to create another three USB flash drives, still not booting, USB is skipped to next medium.
       
      Please, can you help me what's crucial to USB to be working as GRUB loader to boot from SSD? Thanks!

    • IndyLux
      By IndyLux
      I guess there is no reason why this would not have worked, but I can confirm that the Surface RT USB port can charge a cell phone (Lumia 900) while running on battery. Nice when you need it.
       
      I suppose it could charge/power any USB device.
    • pointdooly
      By pointdooly
      Only $16.99 for AmzDeal 40W 5V/8A USB Wall Charger 5-Port Family-Sized Desktop Charger (w/Prime)
       
      $16.99 = $24.99 - $8 OFF Coupon (Code: 9VZGJAM | Exp: Unkonw but Soon)
       
      - 5 USB smart ports auto-adjust charging speeds to charge phones, tablets or any USB-charged devices at their maximum speeds (up to 8A)
      - Matte Black
      - 5ft / 150cm detachable power cord
    • elerouxx
      By elerouxx
      Hey there! So... I am a new (two days old) user of the Surface Pro.
       
      I've been always in love of wacom penabled tablet pcs, long before the concept of a 'tablet'. 
      I have been using a Dell Latitude 10 (Atom powered) tablet with wacom technology. I love that one, despite its performance and limitations - the battery lasts forever!
       
      But I decided to finally go for real power, found a used (as new) Surface Pro 1 and bought it on Saturday.
       
       
      My debut with the Surface Pro was, however, a little tragic. In only one day, I managed to burn out  the USB PORT!  I was messing with a cheap USB 3.0 HUB, it seems that the HUB was broken, even so I insisted by connecting a external power source to the HUB. Nothing. And that evening I realized no device or pen-drive was working  Finally I concluded that I fried the port, in that regrettable instant. No UNDO.
       
       
      It took me two days to get over it, forgive myself for being such an idiot, and take it to the light side.
       
      I don't think fixing the usb port will be possible. However, this is still a very cool piece of hardware, a great tablet. I almost never use the USB port anyway, I store everything in the cloud.
      So I will take this as an "introductory" Surface Pro, until I'm able to get a new one, maybe the SP3 in about a year or so.
       
      And now, to install the apps! Blender and After Effects are waiting!
×
×
  • Create New...