Jump to content
RESET Forums (homeservershow.com)

Errors on Primary Volume


LegoTechMan
 Share

Recommended Posts

Hello,

 

This morning I got my second disk error (Primary Volume is failing) on my OS drive on my WHS v1 box.

 

I did a repair and it seems fine now, however I am a little concerned.

 

What is the best way to replace the OS drive? Can I create a disk image and just restore it onto a new drive? Or am I better off just doing a reinstall of the OS on a new drive?

 

I found the link to Microsoft site "How to Recover Data After a Server Failure" which has some good information, but I still have questions.

 

My biggest concern is that there is data on the drive. All of my critical data is duplicated so that is not an issue, but I have a lot of data that is not duplicated (DVD rips, backups) that I don't want to risk losing any of it if it happens to be on the OS drive.

 

The MS article mentions how to get data off of the drive, but I don't know if it as simple as copying it to another drive.

 

On a side note, there is no way in v1 to prevent data from being on the OS drive is there? If that is the case, am I better off going ahead and buying a larger drive for the OS or should I stick with a small drive (320GB is what I have now).

 

Thanks for any help/suggestions,

John

Link to comment
Share on other sites

Here's an article on how to clone/upgrade/replace the system drive: http://www.mediasmartserver.net/2010/01/17/forum-spotlight-how-to-successfully-clone-and-upgrade-a-whs-system-drive/

 

I wrote an add-in (still in beta) that you can install and it'll give you the health details of your disks. Most non-RAID controllers should work just fine, and many USB disks are supported as well. You can download that here: http://www.dojonorthsoftware.net/Freebies/HomeServerSMARTBeta.aspx

Link to comment
Share on other sites

I have had that pretty regularly on my v1 system drive, and so have others. After the first couple of times I got worried. I shut down the WHS, cloned the system drive with one that had been put through SpinRite at Level 4, and rebooted. Then I ran tests, including SpinRite on the 'failing' drive. It came out with a clean bill of health on all of them.

 

After a month or so, the WHS reported the replacement drive as failing. Since this drive had been SpinRited, I got suspicious. I again shut down, cloned the system drive back to the original, just tested, drive, and started backup. Sure enough, a few weeks later it reported as failing.

 

The long and short of it is, I don't believe the failing message is accurate most of the time. Of course, a drive could always be failing for real, but I now just have the system repair the drive and I keep an eye on the SMART values of the drive. If they haven't changed significantly, I don't worry about it.

Link to comment
Share on other sites

  • 9 months later...

I've just started experiencing a similar problem. First on my EX485. I got a message about drive 0 failing and ran repair. I also ran SpinRite on it. Everything checked out okay. Sometime later I got another message. At the same time I found my EX495 also reporting drive 0 failing. Seemed too much of a coincidence. I run LightsOut and also have Perfect Disk on the servers. I'm wondering if an operation was occurring when the the servers shut down that caused a disk error.

 

I had beem moving files between the two servers to balance storage and probably ran Prefect Disk during this time. Not exactly sure of the cause, but it's odd that both servers developed the same error at the same time. It happened again this morning, which prompted me to log in and post.

Link to comment
Share on other sites

  • 4 weeks later...

Not the whole time, just needed to make more room on one of the servers and moved some old movies over.

 

I had the message appear again when I returned from a two week trip. I uninstalled Perfect Disk and haven't seen the error return since. I still have it running on my EX495 and haven't seen the problem reappear there yet.

Link to comment
Share on other sites

Well, life for the EX485 seemed to take a turn for the worst. Decided to archive some of the files to an external drive hooked to the server via SATA. All of a sudden the server shut down during transfer. When I restarted it, the storage partition on the OS drive show up as not connected. and I couldn't add it back. All options were grayed out.

 

I could see the shares, but checking the backups, the only one apparently missing was my daughter's PC. It showed no backups at all. I shut down and pulled the drive. Ran SpinRite on it at level 4 for over a day (1.5TB). It didn't show any errors, but the SMART screen did show a couple red marks. Still nothing when I installed it again. I looked at backing up the backups using BDBB, but it said my external drive wasn't big enough.

 

I then attempted a OS restore, hoping it would bring back the missing partition on the OS drive. That didn't seem to work very well. I kept getting errors when I attempted the setup. I found some Microsoft documentation that suggested doing an OS restore and not going ahead with installing the connector, but rather remote in and doing updates until they have completed. It indicated the server would attempt to recover but may take a long time without showing much information. I'm hoping that's what's occurring, but wanted any advice someone more knowledgeable about this may have.

 

When I remote in, the console doesn't function, a popup says the backup isn't running, try rebooting or contact support. When I look at the explorer there are multiple drives showing. I, J, K, and L in addition to C. The server currently has 3 1.5TB drives and a 2TB drive, but drive L shows about 3.5 TB and the others are from about 0.5 to 0.9 TB. in drive L, I see shares and it looks like my files are still there. I'm hope this is a positive sign of restoring the shares. I've left the server running to see if it progresses, but do not see much difference. Does anyone know if it may just be rebuilding, or is this a lost cause.

 

I had already ordered 2 2TB drives through Newegg (using the Home Server Show link) when they were on sale and they should arrive today. I plan now to use them to copy off anything I can salvage. If a rebuild is a lost cause for the backups, I'll do a factory format and start to restore the files I have.

 

The good news is I've used CrashPlan on my servers and all my shares are backed up. The bad news is I was never able to fully backup the backups nor do I know if they could be restored correctly (always wanted to test it). Also, with Comcast's bandwidth cap, the more I can salvage, the quicker I can recover.

 

Although the backup db may be toast I still have my machines running, so I can start again. I'll have lost some old configurations, but as long as the family photos are intact, I can survive.

 

Any insight on WHS V1 rebuilding is appreciated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...