Jump to content
RESET Forums (homeservershow.com)
C4Tech

Remote Web Access Failure - Runtime Error

Recommended Posts

C4Tech

Today my son reported a problem trying to access the Remote Web Access page on my home server 2011. Here is the error we get:

 

Server Error in '/' Application.

 

Runtime Error

 

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

 

<!-- Web.Config Configuration File --><configuration> <system.web> <customErrors mode="Off"/> </system.web></configuration>

 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

 

<!-- Web.Config Configuration File --><configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web></configuration>

 

 

I did some searching and found others reporting the same issue but no soultions offered. Someone posted saying to display the page from the server console using Remote Desktop. This apparently gives more details. Here is what I see

 

 

Server Error in '/' Application.

 

Configuration Error

 

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

 

Parser Error Message: Could not load file or assembly 'Wssg.RootSite' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

 

Source Error:

 

Line 57: <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>Line 58: <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>Line 59: <add assembly="*"/>Line 60: <add assembly="System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>Line 61: <add assembly="System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>

 

Source File: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Config\web.config Line: 59

 

Assembly Load Trace: The following information can be helpful to determine why the assembly 'Wssg.RootSite' could not be loaded.

 

WRN: Assembly binding logging is turned OFF.To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.Note: There is some performance penalty associated with assembly bind failure logging.To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Version Information: Microsoft .NET Framework Version:2.0.50727.5446; ASP.NET Version:2.0.50727.5420

 

 

 

Has anyone else seen this error? I checked Windows Updates and there were some recent .NET pataches applied, but not for .NET 2.0

 

Any help would be appreciated.....thanks....brian

 

Forgot to mention....I tried rebooting the server and the error still happens....brian

Share this post


Link to post
Share on other sites
Jason

We need to get a resolution for this. I too was recently struck by this issue yet I cannot pinpoint the cause of it. While I don't use web remote access as often as RDP, I do have a need for it. Cannot figure out any way to reset remote access and the Turn on/off and repair options are ineffective. Please advise. Thanks.

Share this post


Link to post
Share on other sites
sasquatch

For what it is worth, I just got my new microserver today. Installed WHS 2011, ran windows update until there was no more updates to apply and when I went to use the website I got the same error. I am thinking it is one of the .net updates that it took for .NET 4 but it sure would be nice for an official solution.

 

My solution was to do a reinstall of the server (since it was brand new install I was only out my time). I then only updated anything that was not .NET related. I know have a reasonably updated WHS 2011 with no issues.

Edited by sasquatch

Share this post


Link to post
Share on other sites
jmwills

Which browser were the clients using? Are others having the same issue?

Share this post


Link to post
Share on other sites
sasquatch

The client machine I was using to try and connect was Windows 2008 R2. That said, this was a server error. One being generated from the HomeServer web site. Even if I tried to access the site on the homeserver itself I could not.

 

At this point I am back up and running with a fully updated system minus the following .NET Framework updates:

 

KB2416472

KB2487367

KB2518870

KB2539636

KB2468871

KB2533523

 

I also did not install IE 9 this time just to be paranoid.

Share this post


Link to post
Share on other sites
sasquatch

Looking at the message again, it is saying that the Wssg.RootSite assembly is buily using a later version of .net than what is loaded. Since WHS2011 requires .NET 4 I think what is going on is that the web server's app pools were reset to use .net 2 and not 4. Once I get all my files moved over and a checkpoint backup, I will brave the updates and confirm my suspicions. C4Tech and Jason, if you want to try, open IIS Admin console and look at the Application Pools. Most of them should be using a 4.0 framework especially the ones that say Root of WHS etc.

Share this post


Link to post
Share on other sites
C4Tech

All my application pools are set to .NET 4.0 except for

- Classis .NET AppPool

- Default AppPool

- RootApp

(I tooks a screen capture but I don't know how to include it)

 

In my case, I'm cautious about uninstalling some of the .NET updates since I'll be stuck if the server doesn't reboot (I mave a MediaSmart with no display)

Thanks for looking into this.....brian

Share this post


Link to post
Share on other sites
sasquatch

Ok. So on my working server RootApp is set to v4.0 and Integrated with Identity of ApplicationPoolIdentity. I think if you change that one it should work. I think you can recycle just the application pool but if that doesnt work then recycle IIS. One of those two *Should* do it. Please advise if that works. I'm almost at the point of being able to apply the updates and that will give some peace of mind.

Share this post


Link to post
Share on other sites
sasquatch

Alright, I have applied each of the .net 4 updates first the important 4 at once then the other two optional ones one at a time. This time when all the installs were done, the app domain for RootApp stayed at 4.0 framework version. I think this will be your key to solving your problem. Hope this all helps!

Share this post


Link to post
Share on other sites
ikon

(I tooks a screen capture but I don't know how to include it)

To post pics in your messages, you upload the pic to a site like picasa, photobucket, or Windows Live Photo Gallery, then post a link to it in your post. In the toolbar of the reply box is an icon for inserting a link; it looks kinda like a chain.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...