Jump to content
rheo

WHS 2011 - rdp remote access

Recommended Posts

ikon

You can adjust WHS2011 to allow you direct RDP access to the server rather than the desktop by modifying a reg setting, details here:

 

http://blog.djmatty.com/?p=366

 

Cheers

 

Matt

This is confusing me. When I RDP into my WHS2011 it always takes me to the desktop, always has. There is a disclaimer on the desktop stating that I shouldn't use the computer for general computing, but I get that when I'm working directly on the WHS as well. I don't recall ever having the Dashboard come up automatically.

Share this post


Link to post
Share on other sites
DJMatty

@ikon, if you use the Remote Web Access site via the internet to 'connect' to the home server machine itself (not one of the client computers) the default RDP session it creates will only show the dashboard app, rather than the server desktop. The reg setting will disable that 'feature' and connect directly to the desktop of the server. This means you do not have to open the RDP ports through the firewall onto the internet, as the server uses RDP over http for those sessions.

 

You, I assume, are using the rdp client directly to the server, which will connect you directly to the desktop.

Share this post


Link to post
Share on other sites
jmwills

I believe everyone is referring to the RDP connection from the Dashboard. A normal RDP connection through Term Services would take you to the remote desktop. I do know the RDP connection from the SBS 2011 (not essentials) will act like a true RDP connection.

 

I need to look at that Registry Entry and see what the properties are.

Share this post


Link to post
Share on other sites
DJMatty

To save a bit of time, i'll post the important bit of the info here :)

 

"After using dotpeek to dig around in the rdp assemblies, I noticed that it is checking a reg value when it builds the rdp file, and if the value is not set (or is 0) it adds an app alias to the dashboard. The name of this value is “EnableServerRemoteDesktop”. So, I opened reg edit and added a DWORD value at “HKLM\Software\Microsoft\Windows Server\RDP” with the aforementioned name, and set it’s value to 1, and reconnected to the WHS machine from the remote web page."

Share this post


Link to post
Share on other sites
ikon

@ikon, if you use the Remote Web Access site via the internet to 'connect' to the home server machine itself (not one of the client computers) the default RDP session it creates will only show the dashboard app, rather than the server desktop. The reg setting will disable that 'feature' and connect directly to the desktop of the server. This means you do not have to open the RDP ports through the firewall onto the internet, as the server uses RDP over http for those sessions.

 

You, I assume, are using the rdp client directly to the server, which will connect you directly to the desktop.

Annnnd, my confusion is cleared up. Thx. I never use the web access feature; didn't use it on v1 either. I looked at it, but that was all; couldn't see the point of it really when I have real RDP available.

Share this post


Link to post
Share on other sites
DJMatty

@ikon, yeah if you have the rdp ports opened through the firewall it's less necessary... but with WHS2011 its great for rdp access when you are behind a proxy/firewall that doesn't allow anything other http/https (like my work), I can still rdp into all my boxes at home via the remote web access site.

 

Before WHS2011, i had to use some arcane SSH magic to tunnel rdp sessions through HTTPS to my server :)

Share this post


Link to post
Share on other sites
ikon

@ikon, yeah if you have the rdp ports opened through the firewall it's less necessary... but with WHS2011 its great for rdp access when you are behind a proxy/firewall that doesn't allow anything other http/https (like my work), I can still rdp into all my boxes at home via the remote web access site.

 

Before WHS2011, i had to use some arcane SSH magic to tunnel rdp sessions through HTTPS to my server :)

 

Sounds painful. At work I can use RDP and, by the time they get around to changing it, I'll probably be retired ;)

Share this post


Link to post
Share on other sites
Paul at QuaarQ Technology

The Problem for me was:

Being that ‘Server Manager’ is the biggest set up option in the WHS software I used it to set up the users in a somewhat geeky and correct way I thought.

However there is a bug. Users set up in Server Manager is not seen in ‘Dashboard’. If one tries to setup the users in Dashboard, not seen in Dashboard, entered in Server Manager, it won’t let you because it tells you thoses users are already existing – even though they cannot be seen in Dashboard.

 

The answer is delete them from Server Manager and reset them up in Dashboard – Remote Web Access then worked fine for me.

Share this post


Link to post
Share on other sites
ikon

I guess that's why they have that warning post on the desktop of the default RDP screen :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×