Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
JediTim

Saving to Folder Issue - Read Only

Recommended Posts

JediTim

Seems like no one here uses HG. I wonder what the % of Windows users who do use HG is? Hmmm, sounds like a pole question.

 

Gotta say that it was painful for a while trying to figure out the issue. Then I realized that at the WHS home screen I was going through all of the initial settings and remembered that I had clicked on Homegroup...I thought I had skipped the section but I decided to check it again and sure enough I was activated in Homegroup even though the WHS "Recommeneded" the use of users.

Share this post


Link to post
Share on other sites
hewisond

thanks for the post; good to know. So, does this mean whs2011 is incompatible with HG?

 

Nope, you just have to use one or the other. Both at once causes conflicts. Also in HG, you set one blanket permission that covers all shares.. you cant individually set permissions per share as you normally would.. personally i'd stick to normal shares and leave HG in its box.

Share this post


Link to post
Share on other sites
JediTim

Nope, you just have to use one or the other. Both at once causes conflicts. Also in HG, you set one blanket permission that covers all shares.. you cant individually set permissions per share as you normally would.. personally i'd stick to normal shares and leave HG in its box.

 

That is the reason the User Account access is better than Homegroup IMO. I dodn't like the blanket access of my folders...I prefer to manage my user accounts and limit what I feel someone should have access to.

Share this post


Link to post
Share on other sites
Rensul

That is the reason the User Account access is better than Homegroup IMO. I dodn't like the blanket access of my folders...I prefer to manage my user accounts and limit what I feel someone should have access to.

 

I had problems getting my media center extenders to see an additional Music folder that I had created (I had to separate subscription-based, protected ZunePass content from my MP3 music files so that it worked with WHS2011 web access correctly...). Enabling Home Group fixed the problem, however, like others on this post I would prefer straight up user folder permission control / access.

 

So how do you change permissions on new folders to be seen by Windows Media Center extenders?

 

Thanks,

 

Rensul

Share this post


Link to post
Share on other sites
jmwills

I would "nest" the folder you want to restrict access to inside the "Default Music Folder". By default that special folder will inherit permissions form the parent but that is easily enough changed by manually changing the permission in the Access Control List. At least this way your device should be able to get at the folder since it alreadu know the location of the default folder.

 

This might cause an issue with your 2TB backups however if you are over the limit.

Share this post


Link to post
Share on other sites
Rensul

I would "nest" the folder you want to restrict access to inside the "Default Music Folder". By default that special folder will inherit permissions form the parent but that is easily enough changed by manually changing the permission in the Access Control List. At least this way your device should be able to get at the folder since it alreadu know the location of the default folder.

 

This might cause an issue with your 2TB backups however if you are over the limit.

 

If I nest the new Zunepass music folder inside the default music folder, the zunepass content will be picked up by the whs2011 web server but the songs will fail since the whs2011 web server doesn't handle the DRM. I'm trying to use the following folder setup without home group enabled:

 

DRM Music folder + Default Music folder = Windows Media Center access

 

Default Music folder = WHS 2011 remote web access

 

But still like you said I should be able to control permissions via the access control list - presumably that's under the "Security" tab in the folder properties? If so, which listed user applies to the media center extenders?

 

So it all works currently with home group enabled, but again I share the same reluctance as mentioned in this thread about adding the home server to the home group so I'm trying to clean things up.

 

Still got enough headroom with the 2TB limit...

 

Hats off to anyone who actually spends the time deciphering my situation described above!!!

 

Thanks,

 

Rensul

Share this post


Link to post
Share on other sites
jmwills

Permissions are Granted by User not via NetBios name of a client machine. I just ran a test configuration which involves both using the Console and Regular Security Permissions.

 

Using the Console I created a Folder Called "Public" (minus the quotes). The wizard will then ask you what users and permissions levels should be given out. In this case I gave my son and myself full R/W access. I then went into the My Computer applet, found the newly created folder and created a sub-folder name "Restricted Access". Now by default both my son and I have have full rights to the folder but I want to block any access or restrict access. Here's how you do it.

 

Right Click the sub Folder named Restricted Access and go to Properties and then the Security Tab where you will see the Access Control List or ACL. In order to modify the ACL for the first time click the Advanced Button and then Change Permissions. At the bottom of the next box you need to uncheck "Include Inheritable Permissions from this Objects Parent" You are then posed with Options to Add/Remove, etc. chose "Add" whereby you can remove the selected user, in this case my son or reduce his access to Ready Only. Choosing Add rather than Remove allows you to selectively remove users rather than selectively add users.

 

This would be one way of having just one "Public Facing Folder" for access but you would need to be careful when granting permissions. This should solve your music issue if I have read the question correctly.

 

The only other issue I would see say if you have a user who needs access to one of the upper level folders so to speak as well as one buried say 5 levels deep. You would then need to give that user rights to "traverse" or List Folder Contents. They can see the folders on their journey downward so to speak, they cannot open any until they get to where they have access.

Share this post


Link to post
Share on other sites
Rensul

Permissions are Granted by User not via NetBios name of a client machine. I just ran a test configuration which involves both using the Console and Regular Security Permissions.

 

Using the Console I created a Folder Called "Public" (minus the quotes). The wizard will then ask you what users and permissions levels should be given out. In this case I gave my son and myself full R/W access. I then went into the My Computer applet, found the newly created folder and created a sub-folder name "Restricted Access". Now by default both my son and I have have full rights to the folder but I want to block any access or restrict access. Here's how you do it.

 

Right Click the sub Folder named Restricted Access and go to Properties and then the Security Tab where you will see the Access Control List or ACL. In order to modify the ACL for the first time click the Advanced Button and then Change Permissions. At the bottom of the next box you need to uncheck "Include Inheritable Permissions from this Objects Parent" You are then posed with Options to Add/Remove, etc. chose "Add" whereby you can remove the selected user, in this case my son or reduce his access to Ready Only. Choosing Add rather than Remove allows you to selectively remove users rather than selectively add users.

 

This would be one way of having just one "Public Facing Folder" for access but you would need to be careful when granting permissions. This should solve your music issue if I have read the question correctly.

 

The only other issue I would see say if you have a user who needs access to one of the upper level folders so to speak as well as one buried say 5 levels deep. You would then need to give that user rights to "traverse" or List Folder Contents. They can see the folders on their journey downward so to speak, they cannot open any until they get to where they have access.

 

Wow somehow I missed this jmwills - thanks very much for the info - it's really helping me sort out how to handle my music folder.

 

Rensul

Share this post


Link to post
Share on other sites
Fast Charlie

Actually figured it out...I was connected to Homegroup which overrode up the User Account settings. Disabled Homegroup and everything is working.

 

Hi JediTim

I ran into the same issue, but all my shares have vanished from the web interface. I can still see they're being shared from the server, but not the web interface. Am thinking I'm going to have to rebuild it to get them back. Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites
jmwills

Just rebuild the shares before you go thru the hassle of rebuilding the server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...