Jump to content
RESET Forums (homeservershow.com)

My HP ex495 Conversion to WHS 2011


Recommended Posts

I have been a long time listener of the podcast and really appreciate the effort everyone puts into doing it. It has provided me with a lot

of valuable information and been very helpful in resolving problems and keeping things running smoothly. So, I thought I would perhaps contribute by

posting my experience upgrading from WHS v1 to v2 on my HP ex495 in case others thinking of doing this might benefit from my stumbles.


I have been thinking about doing this for a while now mainly because all of my computers that need to be backed up are running W7 x64 and

whs 2011 is 64 bit based; so, any recovery should be smoother.


I was kind of pushed into it earlier than I wished when a few weeks ago I got a message from my v1 installation saying that my backup

service was not running. After a few restarts, it still failed to start. After scanning the various Home Server web sites and technet it

appeared that I had a corrupted file , one of the ones with the { in it. I pulled the drives from my HP ex495 and checked them via esata in

another computer. One disk needed to be repaired. I was hopeful that might solve the problem. Nope, no such luck. Turns out this file exists

on each one of my disks and is the one containing the backups. Apparently if I blow away this file the back service will run and recreate it

but I will have lost all the existing backups and will need to recreate them .... hmmm time consuming and I don't have a backup for these

backups. So, I thought if I have to go through all this trouble, maybe I should just move to 2011.


I did some research on the various WHS web sites and thought I was prepared and well armed. I installed new fresh disks in my ex495; a 2TB

WD black for C and 3 green 2TB segates for the others. I created a bootable flash drive with WHS 2011 on it as per instructions on

http://www.mediasmartserver.net/2010/04/26/how-to-install-windows-home-server-vail-on-the-hp-mediasmart-server/ and created an unattended

installer file in the root directory. Placed the USB stick in the bottom USB slot, powered on the ex495 and quite quickly, I had my

installation up and running... very nice.


I installed the connector software on two PCs to test things and it worked fine. I then started setting up some shares and in the process

noticed that WHS 2011 did not have the same workgroup name as the other PCs and I could not change it when I remoted in to the mediasmart

server. More web searching... It turns out that in order to change the workgroup name, I needed to shut down Active Directory Certificate

Services first and that this needs to be done before installing connector software on any clients. Posts on this subject seem to indicate

that things will work o.k. with the ex495 in a different workgroup but I wanted it to be in the same workgroup as the other computers.


Soooo, I commenced reinstallation of the WHS 2011 O/S on the ex495 after uninstalling the connector S/W on the client PCs. This time the

unattended WHS 2011 install on my ex495 hung. After much head scratching, I finally noticed that the install process writes an extra

confirmation line into the installer file when it completes. When I removed this extra line, the install went through o.k. I then followed

instructions from a technet post on how to stop the service, change the workgroup name, and restart the service. I then installed the

connector on 3 macs (all running windows 7) and 2 other windows 7 only machines. I copied over the 4 TB of multimedia files from the old v1

installation drives into newly created folders on each of the ex495's new drives.


I was able to split the media files up so that they were in separate folders and not over 2TB each. I noticed that the copy speed for the

first X number of files was amazingly good, 100 to 130 MB/sec. I was impressed. After everything was moved over, I noticed that write speeds

had slowed somewhat to 50 to 80 MB/sec. I had planed to upgrade memory on the ex495 as part of this install because it was now running a x64

O/S and could make use of the extra if needed. After I did the upgrade from 2GB to 4GB (Gskill F2-6400CL5S-4GBPQ), I noticed that the file

transfer speed jumped back up to the 100 to 130 range again for a 2 to 3 GB file. Not sure if it was a result of the memory upgrade or not

but it is too much trouble to check it by putting the 2GB stick back in. The v1 speeds would start at 100+ but degrade quickly to 70/50.


The next problem came when I ran backups on the clients. I thought that I had read that folders could be larger than 2GB in size but if they

were you could not use WHS backup to back them up. Not a problem, I will just use something else like others (syncback?) are doing but I had

not realized that the backup folder would not migrate or extend itself automatically on another drive if it reached 2GB. Also, there was no

way to tell WHS to back up some PCs on 1 drive and others on another drive. Major oversight MS!


O.K., looks like the best way for me to get around this is to create a raid array and connect it to the esata port. I was not keen on using

the various drive extender replacements since at this point they are mostly in beta and unproven. So, I got a TowerRAID TR5UT+B - 5 Bay USB

3.0 / eSATA Hardware RAID 5 Tower. I put 5 2TB green drives in it, set it up as raid 5 and connected it to the ex495's esata port. No joy!

The ex495 could not see the raid array. Again, after much googling, I found out that I needed to install a 64 bit driver for the esata port

(http://www.siliconimage.com/support/searchresults.aspx?pid=80&cat=3). After doing that, the raid box was visible. The set it up as GPT.

When I added the raid array in through the dashboard it created multiple 2TB drives... not what I wanted. So, I had to go in via a remote

connect and use disk manager to remove the extra partitions so that there was just 1 large 8TB disk with its own drive letter. I then used

the folder move utility to move the backup folder over to the raid drive.


Everything is now working o.k. I plan to backup the multimedia files that are on the ex495 drives to the raid array since they are less than

2TB each. I am not sure if I need to back up the computer backup folder that is on the raid array since the data in this folder is also on

the client computers and the raid array has a level of redundancy itself. The problem is that in order to back it up I would need to set up

another raid array because the backup fold can get greater than 2TB.


Now although, I am reasonably happy with what I have, it was certainly a lot of work to get there compared to v1 and this setup is quite a bit more

expensive than the v1 setup. It is not something that I feel that I could recommend to my non tech friends at this point in time whereas v1

was. The v1 setup was something simple and straight forward worthy of dare I say it Apple. v2 seems to perform better but is more

complicated to set up and use. Although it works well when configured properly, it seems to me to be an unfinished product for the typical home

use market that v1 seemed targeted at.


I really appreciate all the posts on all the various web sites. Resolving problems would certainly be much more painful without them.

Please keep the podcasts coming.



Link to comment
Share on other sites



Interesting write up, thanks. It would be useful I think to have references to the posts you found when solving various issues. For example the line in the unattended setup file I think is completed=1 that needs to be removed to use the USB installation again.




Link to comment
Share on other sites

Thanks for the comments.


I ran across 1 more hoop to jump through when I went to set up a server backup. I wanted to back up the ex495 system drive along with the 3 individual data drives which are each 2TB to the raid 5 disk. When I tried to do this through the dashboard, it said "the wizard cannot find any disks that are suitable for a backup". I discovered that this is because my raid array is greater than 2TB. The solution turns out to be to run the built in server backup directly. It sees the raid array. The dashboard server backup feature seems to be limited.



Here are the links that I remember using through out the ex495 upgrade:


Unattended WHS 2011 install on ex495 via USB key



The cfg.ini file copied from this link that needs to be created and inserted in the root directory is:











PasswordHint=some password hint



After installation it looked like this:






EXTRA LINE of TEXT INSERTED HERE but don't remember what it said <--------------






PasswordHint=some password hint



If I tried to do a reinstall without removing this extra line, the install would hang. I don't have a link for this. I just happened to noticed this myself.


Here is a link with the steps that I followed to change the WHS 2011 workgroup name:



Here is a link that pointed me the the location of the 64 bit esata driver for my ex495:




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...