Jump to content
RESET Forums (homeservershow.com)
st3lvio

Remote Access Router Config Fails - Help

Recommended Posts

st3lvio

Great articles over at PortForward.com that shows just about every program out there for port forwarding. Here is the specific setup for WHS and that model D-Link router.

 

Yes. I followed that one and this one at WGS , seems like a no brainer, but something is blocking me.

 

There are several router firewall settings for the DIR-655, which I left as defaults when first setting my remote access up, but it fails. I can't find any thing in the router logs telling my of any dropped patckets (0) or denials. So where to troubleshoot? The port checker tool shows all my ports as being stealth.

 

At a loss.

Share this post


Link to post
Share on other sites
jmwills

The only thing coming to mind is to reset the router to factory defaults and start over. What is the URL for the server?

Share this post


Link to post
Share on other sites
st3lvio

The only thing coming to mind is to reset the router to factory defaults and start over. What is the URL for the server?

 

Well, I purchased a new router (DIR-655 verB) mostly because I thought my old one (Linksys WRT610N) had gone bad since I could not get WHSv1 to enable remotely as well. So at this point I do not believe it's the router.

A year ago on WHSv1 I did have remote access configured properly and working. I could access my SERVER.homeserver.com site, but I never used it.

But, in anticipation of WHS2011 I tried to access it again a few months ago and it would not connect. I can only guess at some point Cox has changed policies on me. I talked to Cox support weeks ago, and before I bought the new router (DIR-655). They did confirm they do block port 80, but assured me port 443 (https) is not blocked. That info is consistent with this document. I don't need port 80 anyway, since https is port 443.

 

server url: 192.168.0.101, static ip,

 

What ways can I test my ports? The Open Port Check tool from portforward.com shows all my ports stealthed.

 

Thanks for the suggestions.

Edited by st3lvio

Share this post


Link to post
Share on other sites
jmwills

That is your internal IP not the external. Somewhere in the status section (or at least that is what most companies refer to it) they will show you your external Ip address.

 

To access your WHS site you could use your external address followed by the port number such as https://10.1.5.6:443 where 10.1.5.6 is your external IP Address.

 

This site is my test 2011 server back in the states and you can see I had to reconfigure the IIS settings since I already have an SBS 2008 server running on the same network.

 

https://chaseandmax.homeserver.com:8443/Remote/logon?ReturnUrl=%2fremote

Share this post


Link to post
Share on other sites
st3lvio

That is your internal IP not the external. Somewhere in the status section (or at least that is what most companies refer to it) they will show you your external Ip address.

 

To access your WHS site you could use your external address followed by the port number such as https://10.1.5.6:443 where 10.1.5.6 is your external IP Address.

 

This site is my test 2011 server back in the states and you can see I had to reconfigure the IIS settings since I already have an SBS 2008 server running on the same network.

 

https://chaseandmax.homeserver.com:8443/Remote/logon?ReturnUrl=%2fremote

 

Thanks for the reply, yes I know 192.168.0.101 is my internal ip - I'm not going to post my external ip for security reasons.

I have tried to access it as you described before, but still a no go.

 

So you reconfigured your https port from 443 to 8443? I'll try that. Thanks for the suggestion.

Share this post


Link to post
Share on other sites
jmwills

Yes for the 8443 because SBS was already using that port (443) for the internal Share Point Site.

Share this post


Link to post
Share on other sites
timekills

Thanks for the reply, yes I know 192.168.0.101 is my internal ip - I'm not going to post my external ip for security reasons.

I have tried to access it as you described before, but still a no go.

 

So you reconfigured your https port from 443 to 8443? I'll try that. Thanks for the suggestion.

Of course, you'll have to set the IIS port 443 to the new port and forward that port via your router to your WHS's NAT'd IP (i.e. the .101 IP above.)

 

I've read all above, and you have a few options:

1) You can plug your WHS directly into your cable modem bypassing router (thus getting addressable (real) IP and not NAT'd IP from router) and see if you can hit port 80. If yes - it's the router blocking it. If no - could be your ISP (rare) or could be not configured in IIS (odd). As stated above leave out the UPnP. I'm not retyping it here, but you can search for my other posts on why UPnP is evil, besides just not working correctly most often.

 

2) If port 80 (and/or 443) is blocked, you can change the HTTP and HTTPS ports in IIS and then redirect the new ports via your router to your .101 IP. That is what I do with my WHS2011 since I still use my WHSv1 on ports 80 and 443. I've changed the HTTP and HTTPS ports to different ports in the WHS2011 IIS and then forwarded those ports to my WHS2011 so I can use both servers via web access. I'm no TimeWarner, BTW.

 

I suppose I could get motivated and do a writeup on how to configure port changes in WHS2011 - it is slightly different than v1 since it is Server 2K8 based rather than 2K3, but the above comments are the abridged version.

Share this post


Link to post
Share on other sites
st3lvio

Of course, you'll have to set the IIS port 443 to the new port and forward that port via your router to your WHS's NAT'd IP (i.e. the .101 IP above.)

 

I've read all above, and you have a few options:

1) You can plug your WHS directly into your cable modem bypassing router (thus getting addressable (real) IP and not NAT'd IP from router) and see if you can hit port 80. If yes - it's the router blocking it. If no - could be your ISP (rare) or could be not configured in IIS (odd). As stated above leave out the UPnP. I'm not retyping it here, but you can search for my other posts on why UPnP is evil, besides just not working correctly most often.

 

2) If port 80 (and/or 443) is blocked, you can change the HTTP and HTTPS ports in IIS and then redirect the new ports via your router to your .101 IP. That is what I do with my WHS2011 since I still use my WHSv1 on ports 80 and 443. I've changed the HTTP and HTTPS ports to different ports in the WHS2011 IIS and then forwarded those ports to my WHS2011 so I can use both servers via web access. I'm no TimeWarner, BTW.

 

I suppose I could get motivated and do a writeup on how to configure port changes in WHS2011 - it is slightly different than v1 since it is Server 2K8 based rather than 2K3, but the above comments are the abridged version.

 

Thanks for the tips. I did read your post here a few weeks ago. I was still on WHSv1 and using my WRT610N to connect to my SERVER.homeserver.com web site that I set up last year but never used. I wanted to get it to work before my WHS2011 upgrade and even moved to a new DIR-655 as I stated above.

No need to write up a seperate post, during my troubleshooting last month I found these instructions over at WGS. There is a small section that is specific to WHS 2011 IIS in this WHS 2011 unleashed e-book, which I have.

My next step is to attempt this as suggested. Cox does block port 80 (tech support told me so) and it's stated here on thier site. I asked about port 443, and they do not block it - so it should work?, this is where my frustration (and this thread) came to.

I was hoping someone fimiliar with the DIR-655 and it's firewall (or other) settings would post "oh, you have to make sure you..." Anyway, I try to use alternate ports, if that doesn't work, I'll try suggestion 1.

 

Thanks again.

Share this post


Link to post
Share on other sites
pcdoc

Thanks for the tips. I did read your post here a few weeks ago. I was still on WHSv1 and using my WRT610N to connect to my SERVER.homeserver.com web site that I set up last year but never used. I wanted to get it to work before my WHS2011 upgrade and even moved to a new DIR-655 as I stated above.

No need to write up a seperate post, during my troubleshooting last month I found these instructions over at WGS. There is a small section that is specific to WHS 2011 IIS in this WHS 2011 unleashed e-book, which I have.

My next step is to attempt this as suggested. Cox does block port 80 (tech support told me so) and it's stated here on thier site. I asked about port 443, and they do not block it - so it should work?, this is where my frustration (and this thread) came to.

I was hoping someone fimiliar with the DIR-655 and it's firewall (or other) settings would post "oh, you have to make sure you..." Anyway, I try to use alternate ports, if that doesn't work, I'll try suggestion 1.

 

Thanks again.

 

 

The settings for the DIR-655 are as follows. For starters disable that useless UpNP setting in the router. Go to Virtual servers and set your router accordingly as in the piture except inserting the IP address of your server. Once that is done, go into the setting of the dashboard and manually configure your remote access and you should be good to go. Let us know if that does not work.

 

 

 

portforwardingd.jpg

Share this post


Link to post
Share on other sites
st3lvio

The settings for the DIR-655 are as follows. For starters disable that useless UpNP setting in the router. Go to Virtual servers and set your router accordingly as in the piture except inserting the IP address of your server. Once that is done, go into the setting of the dashboard and manually configure your remote access and you should be good to go. Let us know if that does not work.

 

 

 

portforwardingd.jpg

 

Thanks again doc.

But my settings are identical to the pic above. I even went as far as disconnecting my Workstation (where I configure my router) from my network when attempting the WHS remote setting page - thinking it may be a Windows firewall issue. I get the router failed picture as I posted above. I've tried this several times and after many reboots as well. All, before posting here asking for help. My homeserver domain gets approved and logging into my windows live account I find this:

 

2nir3hh.jpg

 

Pending DNS config. - I'm guessing when it can ping my server from outside my network I'll be good to go.

So next (which I setup a month ago on WHSv1 - and it still failed to connect) is to reassign ports 443 and 4125 to alternative ports.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...