Jump to content
RESET Forums (homeservershow.com)

SettIng up FTP?


dagamer34
 Share

Recommended Posts

Anyone know how to setup FTP on Windows Home Server 2011? I want to have the same shares in the Dashboard available on an FTP for access from iPhone apps and such.

Link to comment
Share on other sites

Anyone know how to setup FTP on Windows Home Server 2011? I want to have the same shares in the Dashboard available on an FTP for access from iPhone apps and such.

 

1. Go to the server manager, right click on "web server (IIS)" and click on "add role". Scroll to the bottom and you will see the FTP server.

Link to comment
Share on other sites

1. Go to the server manager, right click on "web server (IIS)" and click on "add role". Scroll to the bottom and you will see the FTP server.

 

Yeah, I was able to get the FTP server running but had major problems trying to share folders and setting users (IIS is very confusing). I ended up installing FileZilla like I had for WHS v1 and put and end to it.

Link to comment
Share on other sites

Yeah, I was able to get the FTP server running but had major problems trying to share folders and setting users (IIS is very confusing). I ended up installing FileZilla like I had for WHS v1 and put and end to it.

 

That will work.

Link to comment
Share on other sites

I believe WHS2011 can do a bit better, and offer encrypted ftp (ftps) too. See if your clients support it too.

Edited by kermi
Link to comment
Share on other sites

  • 3 weeks later...

I'm also having problems getting the FTP server working.

Any thoughts? surely I'm missing something obvious

 

I've setup and been able to access from the server console but even then I don't see any files. I get no response from the FTP server from my local network.

 

I turned off the firewall and still cannot contact the FTP server hence assume its something wrong with my settings

 

 

FTP Server bindings: Type=ftp:, Host Name="ServerName", Port = 21, Address = tried either "AllUnassigned" or "IP address" of server

 

FTP Basic Setting: SiteName=FTP Server, Application Pool = "DefaultAppPool", Path = Destination path name - confirmed via TEST Connection

 

FTP Authnication: Basic, Enabled, Built In. Domain name left blank

 

FTP Authorization: All users Read / Write

 

Firewall state = Off for testing

 

From client IE = connecting to ftp://serveraddress yields no reply

 

From FTP client in Win7 command shell OPEN serveraddress yields no reply

Link to comment
Share on other sites

Install the web server role with the iis management consoleand ftp server role services:

 

1. Create a new ftp site

2. Setup the site with the default bindings and choose allowssl if you don’t plan on deploying a certificate

3. Configure user permissions and basic or anonymouspermission. if your server is connectedto your domain you can specify domain users, otherwise they must be local useraccounts

4. Finally you’ll have to configure your server’s firewallrules to allow access. Disregard any existing ftp firewall rules; although theyshould be enabled, they don’t actually allow access. (LAME!) Create new inbound / outbound rules to allowa program through windows firewall and grant access toc:\windows\system32\svchost.exe

 

 

I tried this on SBS2011e and it works but WHS might be diffferent.

Edited by no-control
Link to comment
Share on other sites

Install the web server role with the iis management consoleand ftp server role services:

 

1. Create a new ftp site

2. Setup the site with the default bindings and choose allowssl if you don’t plan on deploying a certificate

3. Configure user permissions and basic or anonymouspermission. if your server is connectedto your domain you can specify domain users, otherwise they must be local useraccounts

4. Finally you’ll have to configure your server’s firewallrules to allow access. Disregard any existing ftp firewall rules; although theyshould be enabled, they don’t actually allow access. (LAME!) Create new inbound / outbound rules to allowa program through windows firewall and grant access toc:\windows\system32\svchost.exe

 

 

I tried this on SBS2011e and it works but WHS might be diffferent.

 

Thank you much for your input.

Check on everything other than the firewall. I previously disabled the firewall and still failed. Upon walking thru your checklist, I realized I missed the firewall tabs - I disabled the firewall for when server is connected to a domain - didn't notice the other tabs for when connected to a public/private network. As soon as I turn the firewall off otherwise, I can connect. Thank you so much for the insight.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...