Jump to content
RESET Forums (homeservershow.com)

Issue with WHS 2011 Router Config


edamiga1
 Share

Recommended Posts

I successfully set up my router and can access it externally, but the Remote Web Access is still complaining that it is not set up correctly.

 

Any idea on why this is and what I can do to resolve it?

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

  • cskenney

    3

  • Renny

    8

  • timekills

    4

  • edamiga1

    3

Where are you trying to do the remote access from? i.e., Are you trying to hit the server webpage from inside your internal LAN? What's the router make and model?

Link to comment
Share on other sites

Did you use UpNp or did you manually configure? Which part is complaining and what are you settings.

Link to comment
Share on other sites

I tried both, but I finally went with the manual config to get it working. The problem is that WHS is still showing an error alert that the router is not configured correctly, but I can access it from my work. So everything is working fine, but the error keeps coming up as an alert. When I say to ignore it, it goes away for a while and then comes back again.... Ideas...

Link to comment
Share on other sites

My idea is to ignore it. I assume that is not what you are looking for, so I'll take a stab at some potentially more useful suggestions:

 

1) Ensure UPnP is disabled on your router.

-Although you manually configured the port forwarding, did you also turn UPnP off on your router? If not, it will still cause errors when WHS tries to use it to configure the router. By default, if it "sees" UPnP is enabled, it will attempt to configure the router using UPnP. You've now guaranteed it won't work (well - it works, but not via UPnP) since you've manually forwarded the ports.

 

It would be nice if MS had WHS check for working access first, and if it is working than not try to configure via UPnP, but that's not the way it, err, works.

 

2) Check logs on router

-Sounds like for some reason your WHS is occasionally not able to confirm access to itself when it checks. It then tries to reconfigure, fails, and throws up an error. Is your router showing any intermittent reboots or loss of connectivity? If so, of course that would cause WHS to lose connection and then it would attempt to reconfigure.

 

3) Disable SPI on router

-SPI (stateful packet inspection) - or something like it depending on router manufacturer - can prevent the access check from being responded to. In theory, since the request originated from you, the router's firewall, using SPI, should allow a response back but it doesn't always work that way. Along that train of thought...

 

4) Disable ping blocking

-Although not responding to pings is safer (it helps make your router a bit less obvious and enticing to wannabe hackers) it also can prevent a response when the WHS checks for availability.

 

5) Ignore it and be happy you can actually get to your WHS because you're doing better than many.

-Oops. I already gave that snippy "help" :)

Edited by timekills
Link to comment
Share on other sites

I turned off the remote management and it now works????

 

Thanks for the detailed response, it is apprecieated. I wonder if the page with the remote mangement, which also had the disable UPNP on it was not saving correctly. The Linksys web page is fairly flaky.

 

I also installed all of the patches to the server at the same time, so it could have been related to that.

 

Not willing to undo this to check, since I might not get it to work again.

 

Everything is clean now. Currently patching the hyperv and my old WHS V1. Will reboot the server shortly and hopefully everything comes backup up;-)

 

Thanks again for your help.

Link to comment
Share on other sites

High guys, this original post was as close as I can get to describing my problem.

I simply cannot set up my domain name to enable remote access. I have tried:

using my old V1 name.homeserve.com

bought a new .com domain name from GoDaddy

\Got an SSL certificate too

Set up a new windows live account

Disabled "protected mode" (or whatever they call it) for IE9 on the server

Manually forwarded router ports

turned off UPNP as per Timekills suggestion above.

 

I have tried every reasonable combination of the above to get it to work to no avail.

I am not getting any errors for the roter setup.

I just get this helpful message to try again later ever time the domain name fails to install.

ISP isnt blocking ports and am using a Belkin ADSL modem/router connected to a Linksys GB switch.

Any suggestions?

Link to comment
Share on other sites

High guys, this original post was as close as I can get to describing my problem.

I simply cannot set up my domain name to enable remote access. I have tried:

using my old V1 name.homeserve.com

bought a new .com domain name from GoDaddy

\Got an SSL certificate too

Set up a new windows live account

Disabled "protected mode" (or whatever they call it) for IE9 on the server

Manually forwarded router ports

turned off UPNP as per Timekills suggestion above.

 

I have tried every reasonable combination of the above to get it to work to no avail.

I am not getting any errors for the roter setup.

I just get this helpful message to try again later ever time the domain name fails to install.

ISP isnt blocking ports and am using a Belkin ADSL modem/router connected to a Linksys GB switch.

Any suggestions?

Have you actually tried remote accessing the server from outside your network and confirmed it's not working?

Link to comment
Share on other sites

Have you actually tried remote accessing the server from outside your network and confirmed it's not working?

Yes I have SK.

The new GoDaddy address goes to GoDaddy and the old .homeserver address comes up with server cannot be found.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...