Jump to content
RESET Forums (homeservershow.com)

Stablebit Scanner killed my console interface - help!


juzzle
 Share

Recommended Posts

Any Stablebit Scanner users out there who have tried to remove a drive from the pool?

 

I have been using Scanner for a week now (and am impressed so far). However, this morning I attempted a Remove Drive procedure which, due to conflict with Scanner, has locked me out of accessing my WHS console interface (note, I can start the cosole, but the interface will not load).

 

Here's what's happended so far:

The process started normally: http://screencast.com/t/nZgRYzya7eZ

The process began (WHS advises the usual "few hours" duration)

BUT then, the WHS console interface disappeared revealling: http://screencast.com/t/2FxRULkd4Fg

 

I can RDP into my WHS, but I am unclear about what measures I can take to restore the console. I note that the Demigrator and Stablebit's OmniDriveGuard services/tasks are still running: http://screencast.com/t/NLpFccAkhFM

 

It's imperative that I see my console ointerface in order to witness my removal process (which I assume is still under way).

 

Does anyone have any idea how do I get around this issue?

 

WHS v1

HP Datavault X510

2 x 1.5TB, 2 x 2TB

Edited by juzzle
Link to comment
Share on other sites

Any Stablebit Scanner users out there who have tried to remove a drive from the pool?

 

I have been using Scanner for a week now (and am impressed so far). However, this morning I attempted a Remove Drive procedure which, due to conflict with Scanner, has locked me out of accessing my WHS console interface (note, I can start the cosole, but the interface will not load).

 

Here's what's happended so far:

The process started normally: http://screencast.com/t/nZgRYzya7eZ

The process began (WHS advises the usual "few hours" duration)

BUT then, the WHS console interface disappeared revealling: http://screencast.com/t/2FxRULkd4Fg

 

I can RDP into my WHS, but I am unclear about what measures I can take to restore the console. I note that the Demigrator and Stablebit's OmniDriveGuard services/tasks are still running: http://screencast.com/t/NLpFccAkhFM

 

It's imperative that I see my console ointerface in order to witness my removal process (which I assume is still under way).

 

Does anyone have any idea how do I get around this issue?

 

WHS v1

HP Datavault X510

2 x 1.5TB, 2 x 2TB

Maybe pause the DEmigrator service using pssuspend.exe and stop the StableBit Scanner service, then try to start the Console?

Link to comment
Share on other sites

Update: Stablebit have replied quickly with the following advice.

 

I can confirm that after reproducing the issue, the console does come back normally after removal is complete. It was determined that the error was actually coming from the Microsoft libraries and the scanner error detection was catching it. You can confirm this by looking at the log files in C:\Documents and Settings\All Users\Application Data\Microsoft\Windows Home Server\logs @ the HomeServerConsole.*.log file.

 

They confirm this has happended to someone else, so it's an acknowledged bug (of sorts - see MS libraries reference above). I am impressed with their response time.

Link to comment
Share on other sites

A further update from Stablebit:

 

sit tight and DO NOT shut down or restart your computer. Your console will come back after disk removal is complete.
Link to comment
Share on other sites

Update: Solved!

True to StableBit's word, the console interface recovered properly after the Remove process was finished

 

Two lessons:

 

1. If you're going to remove a drive from a WHS on which Stablebit's Scanner is installed, uninstall the add-in first, or

2. If you choose to leave Scanner installed during a Remove process, be warned that you will be blacked-out until the remove is finished

 

Stablebit advise that "If [they] can find a bug it will be patched asap and a new version will be pushed out"

Link to comment
Share on other sites

Update: Solved!

True to StableBit's word, the console interface recovered properly after the Remove process was finished

 

Two lessons:

 

1. If you're going to remove a drive from a WHS on which Stablebit's Scanner is installed, uninstall the add-in first, or

2. If you choose to leave Scanner installed during a Remove process, be warned that you will be blacked-out until the remove is finished

 

Stablebit advise that "If [they] can find a bug it will be patched asap and a new version will be pushed out"

excellent news. These guys are really on it. Gives one a nice feeling :)

Link to comment
Share on other sites

Guys,

 

Just a small update on this. We've just deployed version 1.0.1.2530 (http://www.stablebit.com/scanner/download). It has a fix for the potential crash on disk removal and some other changes/fixes.

 

I say potential crash because it did not crash every time you removed a disk. It was intermittent.

 

Automatic updating will start in a few days.

 

Regards,

Covecube Inc.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...