Jump to content
RESET Forums (homeservershow.com)
fredload

You need permission to perform this action - Error message

Recommended Posts

fredload

Your username will be "nested" inside the Group that has been given access to the Share. In your case it just might be easier to remove your account and put it back in.

 

You can go the the D Drive, then to Shares and there you will see all the shared folders created by the console. Right Click the folder you cannot access and go to properties. You will see the two groups that were given access. One will be RO_* and RW_* where * is the drive mapping of the share.

 

Now go back to the Computer Management applet in the Control Panel>Admin Tools and find that Group and see if your user account is in the RW Group for the shared folder in question.

have

Example: You a shared folder named Software. Two users named Bill and Joe. Bill has full rights and Joe has read rights. Both users will be in the Security Permissions by default, the access to work within the folder comes with the Security permissions. In this case, Bill will be in the RW (Read Write) Group and Joe will be in the RO (Read Only) Group.

 

If this is a little daunting, then just restore your client machine to a point in time before this all started. Is this a case from multiple clients or just one. If multiple clients, then its an issue with the account, if just one client, its the client machine.

I used my laptop with the same username and password as my main desktop machine and had no problem making changes etc to the folders on the server. So it is obviously just a problem with my Desktop PC. Any idea what would cause one machine to not have permissions but another using the same username and login info not to? Thanks again for the help, I do appreciate it.

Share this post


Link to post
Share on other sites
jmwills

Many things could cause this, that's the reason I mentioned about doing a Windows Restore to a point intime when everything was working properly. Something changed with your user ID on that desktop.

Share this post


Link to post
Share on other sites
Trevor Nysetvold

It turns out that adding your WHS (at least WHS2011) to a homegroup can screw up the built-in permissions. If the Homegroup permissions are more restrictive, then they will 'take over' and you will unexpectedly find that all the users that have greater permissions than the homegroup get the 'you need permission to perform this action' error message. If you remote into the server and remove the server from the homegroup, the problem goes away. Of course, your mileage may vary.

Share this post


Link to post
Share on other sites
ikon

Issues with WHS2011 & HomeGroup have been documented in threads on these forums many times. The general concensus is: Don't Use HomeGroup With WHS2011. It's not an absolute rule, but it is recommended by most.

Share this post


Link to post
Share on other sites
Drashna Jaelre

Ick.... Seriously. Yeah, if you have homegroups enabled, it uses that permission *regardless*. And it's caused issues with non domain computers trying to connect to my domain controller... :(

 

So yeah, I'm one of those that highly recommends disabling it (I disable the services even, and always tell people to pick "Work" for the group and not "Home").

Share this post


Link to post
Share on other sites
ImTheTypeOfGuy

Issues with WHS2011 & HomeGroup have been documented in threads on these forums many times. The general concensus is: Don't Use HomeGroup With WHS2011. It's not an absolute rule, but it is recommended by most.

 

Heck, that was first reported with V1.

Share this post


Link to post
Share on other sites
jmwills

IMO, if you are tech savvy enough to be here, you have no reason to be fooling around with HomeGroups. HomeGroups were designed for the average novice home users who either do not care to learn about file permissions or are too lazy to learn. I'm not disparaging anyone about their technical ability but take some time to learn about your systems and how to lock them down.

 

HomeGroups open your network for everyone to be able to read so the only thing to crack is the password. Just make sure that you and your network are not part of the low hanging fruit crowd.

 

<he steps down from the soapbox>

  • Like 1

Share this post


Link to post
Share on other sites
donpaul

Hi,

 

I know I'm too late for this reply but this method worked for me. So, I'm just putting it out there so that other people too can refer to it. Smiley Happy

 

Learn to Change Permissions

 

Normally this error will be related to an actual permissions problem, so let’s at least get that out of the way before trying other options.

 

Go ahead and right-click on the folder and choose Properties.

 

Next you want to click on the Security tab and then click on the Advanced button.

 

Now you want to click on the Change Permissions button at the bottom left.

 

Now is the fun part. It definitely looks complicated and that’s why you have to do this section right, otherwise you’ll think you

set the permissions right when, in fact, they are wrong.

 

First of all, go ahead and check the Replace all child object permissions with inheritable permissions from this object box.

 

Then go ahead and uncheck the Include inheritable permissions from this object’s parent box. When you uncheck the box, you’ll get a warning box where you’ll have to choose from Add or Remove. Go ahead and click on Add.

 

Now a normal folder that is deletable should look something like above with SYSTEM, Administrators and the user (Aseem) having Full Control with the Type set to Allow. At this point, you need to see what’s different and get your permissions to look like this using the Add, Edit and Remove buttons.

 

If you see any permissions with Deny in the Type, go ahead and remove them. Next make sure to add your username and the Administrators group and give them Full Control. Just click Add and type in the user name for your Windows account and then click Check Names. My Windows user name was Aseem, so I typed that in and clicked the button and it automatically changed it to WINDOWSMAC\Aseem.

 

Do the same thing for administrators, just type the word and click Check Names. If SYSTEM is not present, go ahead and add that also just to be on the safe side. When you are done and the permissions look correct, go ahead and click OK. It might take some time if the folder is large and has a lot of subfolders. Once it’s complete, go ahead and try to delete the folder!

 

This answer from Microsoft might be helpful too. You can always look at alternative ways to solve you need permission to perform this action issu if this one doesn't work for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×