Jump to content
RESET Forums (homeservershow.com)

Can't install ESXi 7 on my ML350p Gen8


Visca
 Share

Recommended Posts

Hi! As the title says, I can't get ESXi to install on my Gen8 Proliant. The server boots from the installation media (USB), starts booting the ESXi installation program starts, and then just reboots again. I have reset every little thing in my server because I've been fiddling around with it so much I forgot what the base settings and stuff was. So it's an install on a clean system, on a empty SSD drive.

 

Can anyone help me? Does anyone know of some obscure settings I need to configure in the BIOS , or setting te use when creating the installation media (I use Rufus for that) or is there a specifix ESXi iso I should use?

 

I've added a pic of some (I believe) relevant information on the ML350p Gen8 I have, with ROM and firmware information.

My server has two Intel(R) Xeon(R) CPU E5-2650 processors and 152 Gb of RAM.

The ESXi installation media I am using for the installation of ESXi is VMware-ESXi-7.0.3-20036589-HPE-703.0.0.10.9.1.5-Jul2022

 

 

Any help would be most welcome as I'm growing tired of this bootloop nonsense and not getting any further..

 

 

567567567657.png

Link to comment
Share on other sites

Maybe try a newer bios? The latest is 7 years newer than the one installed. Once updated, I'd also perform a factory reset of the bios settings to make sure you've not done anything weird.

 

I would also suggest grabbing an SSP ISO to make sure all the other firmware is updated. Given the bios is so old, it feels like some devices will need updates.

 

You might also want to check what storage controller you have. If it's the same B120i as the gen8 microserver, I don't believe that works in esxi 7 so you may need a separate card. Probably a P222, P420 or similar...

 

The official instructions to create a USB installer can be found here: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.esxi.install.doc/GUID-33C3E7D5-20D0-4F84-B2E3-5CD33D32EAA8.html

 

Dell also have some Rufus instructions so I'd expect the same settings to work for HPE servers - obviously choose the HPE iso :)

 

Rufus configuration screen

  • Like 1
Link to comment
Share on other sites

Hi @langers2k,

 

Thanks for replying! I have looked into upgrading the BIOS but I can't get that sorted out, can you hint me in the direction or towards some kind of guide?

I've got the SSP ISO, so that's already as up to date as possible. I've performed the factory reset as well before, but I'll do it again when the BIOS and other things are in place :)

I've got the P420i controller so that's no problem I guess.. just like the Rufus settings, they're kind of the standard/logical settings.

 

Hopefully you can point me in the right direction regarding upgrading the BIOS and that will help me somewhat!

Link to comment
Share on other sites

Latest versions can be found at this link: https://support.hpe.com/connect/s/product?language=en_US&tab=driversAndSoftware&kmpmoid=5195931&driversAndSoftwareFilter=8000012

 

This version should help you create a bootable USB key: https://support.hpe.com/connect/s/softwaredetails?language=en_US&softwareId=MTX_5788f28a979549d581bfbff9c1

 

If you go to the ilo > administration > firmware, I think it can also use the 6B8 file (C:\SWSetup\SP99440\ROMPaq Flat Files\CPQP7213.6B8) the bootable USB key tool spits out. You'll need to reboot the server afterwards for the new bios to load.

 

I'm surprised the SSP hasn't tried to update it for you - there might be an intermediate version that needs installing.

Link to comment
Share on other sites

@langers2kthanks again!

 

The update worked, it's now at:

System ROM P72 05/24/2019
System ROM Date

 

05/24/2019

 

I will now go and try installing an OS (ESXi) works, hopefully it does!

Link to comment
Share on other sites

Well, I got ESXi 6.5 running now, I think the newer BIOS and not going for 7.0 straight away did the trick.

I had 7.0 running before all this, so I want to try to upgrade to it again, what would be the best way to do that @langers2k? Create a new installation media USB? Or should I do it via iLO? Or is it possible/better from within ESXi itself?

Link to comment
Share on other sites

I tried it with a clean install through a USB drive and that worked like a charm. Seems that it was the BIOS all the time, although I had something running on it before

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...