Jump to content
RESET Forums (homeservershow.com)

ESXi 6.7.0 not seeing external USB HDD's


itm
 Share

Recommended Posts

I've installed ESXi 6.7.0 from a HPE Custom Image. It is booting from an internal MicroSD card in the Microserver. While I see a USB controller in the device list in ESXi, it is not showing either of the two external USB hard drives which I have plugged into the ports at the back of the Microserver.

The ESXi hardware list showed two USB controllers. I have toggled passthrough on both and rebooted - they are now showing as "Active" in the Passthrough column.

Any idea how I can get ESXi to recognise these drives?

Link to comment
Share on other sites

It seems that the USB drives are being detected at some level, as I can add them to guest VMs as USB devices if I edit their settings. They are not detected as disks by the guest VMs though.

???

 

Link to comment
Share on other sites

Have you assigned the USB controllers to the VM you are using, its been a while since I've played with esxi so can't remember the exact route for this..

Link to comment
Share on other sites

So I managed to resolve the problem by removing the USB 2.0 controller which has already been assigned to the VM, adding a new USB 3.0 controller, and re-adding the external drives as USB devices. The VMs now see them as disk drives.

I have no idea why the USB 2.0 controller had problems.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...