Jump to content
RESET Forums (homeservershow.com)

Problems installing/booting ESXi 6.7


itm
 Share

Recommended Posts

I've installed ESXi 6.7 on my HP Microserver Gen8 from a virtual drive (using an HPE Custom Image). I installed to an SSD connected to the internal SATA connector in the Microserver.

The installation completed successfully, but when I rebooted it was unable to boot into ESXi. The messages were:

Attempting Boot From USB DriveKey (C:)
Attempting Boot From Hard Drive (C:)
Error: no such device: 02e5e0b4-29f2-4176-8fd6-cf5805b8b7f1.
Entering rescue mode...
grub rescue>

It looks as if it can't find a boot partition, but I have no idea whether it is looking in the right place for it - i.e. the SSD. There are several other drives installed - 4 internal and 2 external (USB).

If I reset and go to the Microserver boot menu, I can only choose from the following options:

  • One time boot to CD-ROM
  • One time boot to Floppy
  • One time boot to USB Drivekey
  • One time boot to Intelligent Provisoning
  • One time boot to HDD
  • One time boot to Network
  • One time boot to ROM Based Setup Utility

There's no option to direct it to a specific drive. If I choose "One time boot to HDD" I get the error above.

 

So I tried a couple of different approaches, but hit another couple of brick walls...

(1) Put a 64GB MicroSD card in the internal card slot in the Microserver (I have been using this card to boot the same server into Lubuntu for the last few years, so I know it's OK). Installed ESXi 6.7 to the card and rebooted. Got the same problem - it couldn't find a boot partition - same messages as above. From memory, it should see the SD card as a USB key. but even if I manually selected USB Key as the boot device it wouldn't boot from it

(2) Tried to install ESXi 6.5.0 U2 (HPE Custom Image) to boot from a "real" USB key. I put the ESXi ISO on a 4GB USB key, put the USB key into one of the front slots on the Microserver, and booted up. When I was asked to select a target device for installation the USB drive was not shown (nor were the USB hard drives which were attached) - only the 4 drives installed in the internal drive bays. So I could not install to USB.

 

I seem to be running out of options. Any ideas?

Link to comment
Share on other sites

I finally resolved it - power down and unplugged the server for 30 seconds. When I plugged it back in and restarted it booted from the SD card.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...