Jump to content
RESET Forums (homeservershow.com)

ESXi will only boot from traditional HDD (not SSD, or USB)


Mai1d
 Share

Recommended Posts

I have a Gen8 which was running ESXi 6.0 off of the internal USB 2.0 port. Everything was working fine.

 

I recently upgraded the CPU and though I may as well upgrade ESXi too. Big mistake.

 

ESXi installer boots just fine and installs just fine, however once installed it will not boot. "Non-System Disk or Disk Error"

 

  • I've installed it to the same USB the installation ISO was on
  • I've installed it to a different USB
  • I've installed it to a SATA SSD

 

All of these install just fine but refuse to boot "Non-System Disk or Disk Error"

 

I've tried 7.0U2a, 7.0.2 HP Specific ISO, 6.7, 6.5, 6.0 (which was originally working ok) but no luck. Always the "Non-System Disk or Disk Error" message.

 

I have set the boot order in BIOS and have also tried the force one-time boot option, still nothing.

 

When I install it to the WD Red 4TB HDD, it boots right away.

 

Why is this?

 

I want to run ESXi from the internal USB as I was doing previously.

 

I understand VMWare is moving away from running ESXi from USB/SD, but that's not a topic for this post please.

 

 

Can anyone help me please?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...