Jump to content
RESET Forums (homeservershow.com)

Migrating from N54L to Gen8 -- questions on performance/compatibility


Recommended Posts

stangri

Hello,

 

I'm currently running an N54L with esxi 6.5, single Ubuntu VM (NAS/UniFi Controller/Plex) and ZFS raidz. I was able to get a second (if not third/fourth) hand Gen8 with the E3 1220L-V2, 16Gb of RAM and B120i fake-Raid card.

 

As I'm not going to need the B120i raid functionality, I'll be switching it to AHCI mode and trying to install esxi 7. Now, to the questions...

 

1. The box will come without caddies. Will any Proliant gen8 compatible HDD Caddy work? Is there a preferred seller of inexpensive caddies? I've seen some on ebay/ali as low as CDN $8, but they do not explicitly say microserver gen8 compatible, so I'm at loss.

2. I have looked at the E3 1265L-V2 CPUs but they cost about 60% of what I'm paying for the microserver. Would an E3 1265L (non-V2) for about CDN $60 be a decent enough upgrade from 1220L-V2? I was refering to this chart: https://n40l.fandom.com/wiki/Cpu_gen8 for TDP and CPU Passmark scores, but it doesn't even list non-V2 1265L. It does have a 1260L which scored about 30% higher than 1220L-V2, does anyone have a real-world experience going from 1220L-V2 to 1260L or 1265L?

3. The reason I'm considering a CPU upgrade is the h265/h264 encoding/decoding in Plex. Given that I'd already receive the 1220L-V2 and not a Celeron CPU, should I instead look into GPU? 

4. If so, is there a list of inexpensive video cards compatible (size/dimensions-wise) with Gen8? Is nVidia better than AMD Radeon for esxi/Ubuntu? Never had a video card in a headless server, so would appreciate directions. Would I have to pull the B120i to make room for a video card?

5. Only used a very old and crappy iLo on an equally old Proliant 1U box and it wasn't that great. I've checked the links to HP site on iLo4 functionality from the stickied thread, but all of those were broken. Is there an up-to-date guide on iLo4 functionality in Gen8 and, most importantly, what does advanced license unlock? My goal is to use iLo to install esxi 7 on a microSD card and then use esxi to manage the box, would a trial 60-days advanced license work for me? Why may I want to buy a lifetime advanced license?

 

Thanks!

Edited by stangri
Link to post
Share on other sites
stangri

Well, I'm going to reply to myself whatever I researched so far...

 

1. The HP caddy SKU is 651314-001, so search your favourite marketplace (amazon/ebay/aliexpress) for that keyword and you'll find plenty of options. I found a few sellers on ali, the caddies are about CDN $10 shipped each.

2. If anyone is using gen8 to store H265-encoded videos I'd appreciate real-world feedback about real time conversion to non-H265 supporting clients still.

3. See above.

4. Well, the B120i is integrated, it doesn't occupy a PCIe slot, so there's room for video card.

5. Biggest difference between unlicensed iLo and licensed Advanced iLo is ability to use remote console after POST. Even unlicensed you can kinda use remote console after POST, but it does time out pretty quickly. If you're planning on using the remote DVD boot thru remote console, more likely than not with the unlicensed iLo the connection will time out before the booting process finishes. Buying the license is useless if you're running gen8 connected to the monitor/keyboard and have DVD drive in it, however if you're planning on installing hypervisor/OS on a headless server -- definitely spend about US $10 to buy advanced license on ebay. Given how picky gen8 is about boot media (I couldn't get it to boot from USB stick with esxi ISO "burned" onto it), it's money well spent. My plan to get a trial license from HP was spoiled -- afaik HP no longer issues trial iLo4 licenses (as of Jan 1st, 2021).

 

Another thing I'd like to add -- I was unable to install esxi 7.0 U1 HPE image on Gen8 -- it fails after about 5% with the errno 38. The 6.7 HPE image installed just fine, still no joy with neither update to 7.0 U1 HPE image nor fresh install after that.

 

So if you're running 6.7 esxi on your gen8, do NOT attept to update to the Jan 2021 HPE 7.0 esxi image! It will destroy your esxi install.

 

 

 

  • Like 1
Link to post
Share on other sites
stangri

Correction on the last tidbit of information, the VMware-ESXi-7.0.1-17325551-HPE-701.0.0.10.6.3.9-Jan2021.iso file results in errno 38, however the Synergy-enabled VMware-ESXi-7.0.1-17325551-HPE-701.0.0.10.6.5.12-Jan2021-Synergy.iso seems to work.

 

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...