Jump to content
RESET Forums (homeservershow.com)

Sata speed problem


Recommended Posts

Richie-Kotzen

Hi, I have a problem on my microserver gen10+ .
Configuration:
Intel (R) Xeon (R) E-2236 CPU @ 3.40GHz
2x16GB DDR4 2666 HP 879527-091
1 nvme Samsung 970evo 1TB on PCIE adapter
4 Samsung 850evo 500GB SSD

 

I am attaching in photos the current configuration at the level of updates (everything should be updated).

The disks are currently configured in AHCI mode for run esxi 670.U3.10.6.0 (HPE image).
The first problem is that in ILO5 "System Information - Storage Information" the wrong size reported on SATA disks (they should be GB and not MB, but maybe it's just a bug).
The biggest problem is related to the writing speed is very low. I also tried with HDD, but write performance is much lower than what I get on other machines. Any idea what it could be?
I also tried to install the esxi 7.01 image, but the problem remains. I also tried to install windows 10 or windows 2019 server natively on one of the SATA disks, but the installation is not successful (after selecting the installation disk, I think it asks me for the sata controller drivers). If it can be a useful further test, I will try to install a windows operating system to understand if it is an esxi problem.
Thank you!

firmware_config.jpg

storage_config.jpg

benchmark_ssd.jpg

Link to post
Share on other sites
Richie-Kotzen

Updated situation:
i installed Windows 2019 Server as main machine, so not a VM under esxi. Installed on the same sata SSD that was giving poor write performance under esxi. Under Windows 2019 Server, however, the performance is correct, in line with the performance of the SSD (550MB / s writing and 550MB / s reading). Do you have any idea how it can solve? Could it be a problem of non-optimized esxi SATA drivers? Yet I installed both 6.7 and 7.0.1 from HPE image.
Thank you all!

Link to post
Share on other sites

 

Firstly, only VMware ESXi 6.5-U3 and 6.7-U3 are on the official HCL. Try both. If they work then it's probably a storage driver change in the newer images. Software raid is not available.

Secondly it must be in AHCI mode - have you doen this?

 

Having said this, I had the same issue with ESXi on the Gen10 but ESX wasn't supported so I just had to accept it and install Windows Server.
 

As VMware ESXi is supported on the Gen10+ then I would raise a support ticket with HP and ask them to resolve it. Don;t accept any rubbish about you not having supported hard drives ebcause they're not HP - that's an excuse and if you get it escalate the call.

Edited by Scepticalist
Link to post
Share on other sites
Richie-Kotzen

Yesterday I opened a ticket with HP.  clearly not having supported HP disks they told me it's not their problem.  I had no doubts about the answer.  today I did some testing.  I started from ESX 6.5 up to 7.0.1.  The problem persists.  With windows 2019, however, the disks have perfect performance.  Clearly the controller is set to AHCI ( the raid is done by FreeNas that it returns the disks on iSCSI in ESXI). I think it's a HP driver problem ... I will wait for a new upgrade ... I have no alternative for now.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...