Jump to content
RESET Forums (homeservershow.com)

Connecting to WHS 2011 Server - via Dashboard or Remote Desktop Connection


Recommended Posts

Hey all!


I have an HP EX470 that I'm about to replace - figured I had better update before something went sideways with my EX470. Although, it has been extremely reliable for quite a few years! Well, until today!


Now, I'm suddenly having issues logging into my server - either using the WHS Dashboard or using the Remote Desktop Connection.


Either way, this get to the point of a remote connection and I get the following error ...

"To log on to this remote computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. If you are not a member of the Remote Desktop Users group or another group that has this right, or if the Remote Desktop Users group does not have this right, you must be granted this right manually."


Trying to find a solution to this. I didn't make any adjustments to the system before starting to receive this error. Removed and reinstalled connector software on client computer. Issue remains.


Any suggestions on getting logged into system - either with dashboard or remote desktop connection?

Link to comment
Share on other sites

Sounds strange if this is something that happened all of a sudden.


Are you sure that you are logging in with the same user account to the WHS box as you use to? (Administrator).


Have you tried rebooting the WHS?

Link to comment
Share on other sites

Yes. I've only had 1 user, that I know of. It's the same user info I use to access the network folders - and this works just fine. I can enter this username/password and access the shared folders from the client systems (Mac and Windows). I've been using this same Windows system to access the WHS via the Dashboard for the last couple years.


If I try using the WHS 2011 Dashboard it gets all the way to setting up the remote desktop and then gives me the error. After installing the WHS Client/Connector software I had to login to the Launchpad again ... this same user account info logged me into this.


I did a reboot ... a couple of them. No change. If you have any other recommendations, I'd appreciate it!

Link to comment
Share on other sites

Not sure if this will work. But give it a try. Try to connect to the server using Remote Desktop and with the /admin parameter after the IP-address/server name.


Link to comment
Share on other sites

Oddly, I tried logging in as username: administrator (after admin didn't work) ... and I got in.


Now that I'm in the Dashboard, I see the user login name is just what I was attempting to enter and the remote web access shows allowed and status of user is active. There are only 2 users listed, this one and guest which is inactive.


Based on the error, any tips to make adjustments that will further enable access with the primary username? Thanks!!

Link to comment
Share on other sites

Ok. Check that "Remote Desktop Users" are listed in secpol under "Log on through Remote Desktop Services". 


See this guide (skip the first part as that is for newer versions and not WHS 2011 and go to "Securing Remote Desktop".



Now, Open Computer Management (START / Run - enter "compmgmt.msc" and hit Ok)

Make sure that  your other user account is a member of the "Remote Desktop Users" group




Link to comment
Share on other sites

Thanks!! I greatly appreciate the help and advice.


I have this user added now ... either way, I know I can get back into my Dashboard to easily manage server.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...