Jump to content
RESET Forums (homeservershow.com)
nielsvanbaal

New install / advise / best practice

Recommended Posts

nielsvanbaal

Hello,

 

I have a gen8 running since a couple of years. It ran/runs fine on xpenology barebone. When I got the server I tried with ESXi but the performance was bad, and I couldn't get the driver version to downgrade if I recall correctly.

 

My setup now is 8gb ram, E3-1220L V2, samsung ssd, 2* 4 TB RED, one older harddisk wich I use for videosurveilance recording. I run the onboard controler in RAID without arrays (don't know why but at that time that was a solution for some problem I can't recall anymore, might be fan control).

The SSD is down to 0% lifespan, that was my trigger to start thinking about change.

 

So far ive ordered: 500gb RED SSD, 8 TB red disk, P222 with 1gb flash back thingie, mini sas to sata cable.

 

I also have laying around a 40gb Intel SSD. And I want to use the 2* 4 TB RED in RAID and put important stuf on there so it is a little bit safer(think about photos etc).

 

My initial thoughts are, ESXi on a microsd or directly on the Intel SSD. Put the datastore of xpenology on that.

Then passthrough the complete P222 to xpenology and boot from the RED SSD. 

 

My questions are: does  that make sense?

Do I use hardware RAID on the P222 or let synology figure this out for the 2 4TB disks?

If I let synology sort this out, do I put the P222 in RAID or AHCI?

Same question for the onboard controler, RAID or AHCI?

 

My main goal is that the harddisks spin down when not needed. That doesn't work now with xpenology bare metal.

Share this post


Link to post
Share on other sites
schoondoggy

I have not played with Xpenology and ESXi together for a long time, but:

1.Unless something has changed Xpenology does not like RAID cards. HBA's work well and allow Xpenology to configure and manage the drives.

2. In the past the P222 did not behave well as a HBA. I think the latest firmware from HPE is better at supporting HBA mode, but I have not tested it. Xpenology users seem to have good luck using LSI based HBA's in passthrough with ESXi. 

3. For the onboard controller, you could add a breakout cable to the system board and use those ports for SSD's. ESXi tends to like RAID controllers, but there have been performance issues with the B120i drives and ESXi in the past. Some have had good luck with AHCI.

 

Sorry I do not have more definitive answers, but these are the areas I would research. Perhaps someone else will have more detail.

  • Like 1

Share this post


Link to post
Share on other sites
nielsvanbaal
Posted (edited)

Thank you for your answers! They helped so much.

Ive updated and switched the P222 to HBA, to find out that it xpenology doesnt support it anymore.

 

Ordered a IBM M1015 for cheap and flashed it to IT mode, passed it on to xpenology.

This also gave me extra internal ports(there are 13 sata now of wich I use 6 now). So I can connect extra 2,5 drives in the future. 

 

For now there is one SSD where ESXI 7.0 runs on. Ive installed 6.5 preGEN9 and updated it to 7.0 with generic build. 

The onboard controller is in AHCI indeed.

 

This all works wonderfull now. Next steps, create more sata power and some more cooling I think. 

Edited by nielsvanbaal
  • Like 1

Share this post


Link to post
Share on other sites
E3000

Pass through on Gen8 is very problematic and bastardy...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...